Page MenuHomePhabricator

Docker Image: Add Elastic + CirrusSearch-powered search to the default docker image
Closed, ResolvedPublic5 Story Points

Description

Technical Requirements:

  • Add ElasticSearch & Elastica mediawiki extensions to the wikibase-bundle docker image.
  • Add https://hub.docker.com/_/elasticsearch/ to example docker-compose system
  • Configure mediawiki with extension to talk to the elasticsearch service

How to verify:

  • Spin up a fresh example setup using the example docker-compose. The setup should be able to use elasticsearch for searching and entity suggesting?!

Event Timeline

RazShuty created this task.Apr 23 2018, 4:08 PM
Restricted Application added a project: User-Addshore. · View Herald TranscriptApr 23 2018, 4:08 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
RazShuty updated the task description. (Show Details)Apr 24 2018, 6:07 AM
Restricted Application added a project: Wikidata. · View Herald TranscriptApr 24 2018, 6:16 AM
RazShuty moved this task from To Do to Doing on the Wikibase-UserGroup board.Apr 24 2018, 10:48 AM
Addshore removed Addshore as the assignee of this task.Apr 25 2018, 8:44 AM
Addshore added subscribers: Tarrow, Addshore.
WMDE-leszek renamed this task from Docker Image: Add Elastic + new search to the default docker image to Docker Image: Add Elastic + CirrusSearch-powered search to the default docker image.May 8 2018, 1:58 PM
Tarrow claimed this task.May 8 2018, 2:03 PM
Tarrow added a project: User-TArrow.
Tarrow moved this task from Features to Doing on the Wikibase-Containers board.May 15 2018, 12:59 PM
Tarrow moved this task from Backlog to Review on the User-TArrow board.May 16 2018, 1:57 PM
Tarrow moved this task from Needs Review to In Progress on the Wikidata-Ministry-Of-Magic board.
Tarrow edited projects, added Patch-Needs-Improvement; removed Patch-For-Review.

Needed a rebase which is now done.

Currently waiting for a reply from @Addshore on the PR comments

The current status of this is as I understand is it is now ready to be merged once it has been rebased.

@Addshore can correct me if I'm wrong.

I've now done the rebase and it's just waiting on review.

@Addshore has reported some problems with the image on his machine which you can read about in the PR.

I'll be investigating these and seeing if I can reproduce them or at least document the causes.

Tarrow moved this task from In Progress to Needs Review on the Wikidata-Ministry-Of-Magic board.

I have tracked down some problems that existed with the image for sure. We were using two different types of way to specify the ENV vars for the elastic host.

I've also put in the sha of the elastic docker image in case that caused the problem.

I'm now putting this back up for review by @Addshore (and anyone else who wants to try it).

Tarrow closed this task as Resolved.May 30 2018, 5:23 PM

Merged!

Vvjjkkii renamed this task from Docker Image: Add Elastic + CirrusSearch-powered search to the default docker image to efeaaaaaaa.Jul 1 2018, 1:14 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii triaged this task as High priority.
Vvjjkkii removed Tarrow as the assignee of this task.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed the point value for this task.
Vvjjkkii removed a subscriber: Aklapper.
AfroThundr3007730 renamed this task from efeaaaaaaa to Docker Image: Add Elastic + CirrusSearch-powered search to the default docker image.Jul 1 2018, 5:52 AM
AfroThundr3007730 closed this task as Resolved.
AfroThundr3007730 raised the priority of this task from High to Needs Triage.
AfroThundr3007730 updated the task description. (Show Details)
AfroThundr3007730 set the point value for this task to 5.
Wong128hk assigned this task to Tarrow.Jul 1 2018, 5:52 AM
Wong128hk removed the point value for this task.
Wong128hk added a subscriber: Aklapper.
AfroThundr3007730 set the point value for this task to 5.Jul 1 2018, 5:52 AM