Page MenuHomePhabricator

At IE11, URL address bar changes while using the NWE and selecting "Always give me the source editor"
Closed, ResolvedPublicBUG REPORT

Description

Steps to Reproduce:

  1. Go to Internet Explorer 11 at Windows 7 or 8 (or 10 when using the IE mode in MS Edge).
  2. When logged-in, go to your Preferences settings page, or click "Beta".
  3. If "Preferences" is clicked, then click "Beta features" tab
  4. Enable "New wikitext mode".
  5. If "Temporarily disable the visual editor while it is in beta" option is checkmarked, then de-checkmark the option to re-enable the selection menu.
  6. Under the selection menu, select "Always give me the source editor".
  7. When settings are saved, go to any page, like a sandbox or an article.
  8. Click the "Edit" tab.

Actual Results:

Expected Results:

  • In Chrome and Firefox, the URL address bar still remains as https://en.wikipedia.org/wiki/<article/page>?action=edit.
  • When either exiting the NWE or refreshing a page, the browser should not redirect a user to that disambiguation page.
  • A user at IE11 should not have experienced the "Actual Results" described above.

Event Timeline

gh87 created this task.Apr 24 2018, 11:27 PM
Restricted Application added a project: VisualEditor. · View Herald TranscriptApr 24 2018, 11:27 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
gh87 updated the task description. (Show Details)Apr 24 2018, 11:37 PM
Vvjjkkii renamed this task from At IE11, URL address bar changes while using the NWE and selecting "Always give me the source editor" to xaeaaaaaaa.Jul 1 2018, 1:14 AM
Vvjjkkii triaged this task as High priority.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
CommunityTechBot renamed this task from xaeaaaaaaa to At IE11, URL address bar changes while using the NWE and selecting "Always give me the source editor".Jul 1 2018, 6:55 AM
CommunityTechBot updated the task description. (Show Details)
CommunityTechBot added a subscriber: Aklapper.
gh87 raised the priority of this task from High to Needs Triage.Jul 1 2018, 8:03 AM
matmarex claimed this task.Apr 16 2020, 7:07 PM
matmarex added a subscriber: matmarex.

I accidentally found the reason for this bug while reviewing the patch for T249957.

The root cause of the issue is that on IE 11, history.pushState( null, null, undefined ) behaves like history.pushState( null, null, 'undefined' ) (navigates to the relative URL 'undefined'), while on other browsers it behaves like history.pushState( null, null ) (does not navigate anywhere) – and we've left the desired URL for the source editor undefined in SET mode.

Change 589403 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/VisualEditor@master] DesktopArticleTarget.init: Set veEditSourceUri in SET mode too

https://gerrit.wikimedia.org/r/589403

Change 589403 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] DesktopArticleTarget.init: Set veEditSourceUri in SET mode too

https://gerrit.wikimedia.org/r/589403

gh87 updated the task description. (Show Details)May 19 2020, 9:39 PM
gh87 updated the task description. (Show Details)
JTannerWMF closed this task as Resolved.Oct 20 2020, 6:57 PM
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptOct 20 2020, 6:57 PM