Page MenuHomePhabricator

Determine which applications should be enabled.
Closed, ResolvedPublic

Description

This is different from T12: (test) How do design attachments/assets work?, since an application can be enabled, but not shown on the default home page.

Current proposal:

Trusted User Tool deployment:

  • Legalpad

Day 1

  • Dashboards
  • Feed
  • Maniphest
  • People
  • Pholio
  • Projects
  • Facts
  • Files
  • Flags
  • Herald
  • Paste
  • Tokens
  • Auth
  • Config
  • Daemons
  • Mailing Lists - not to manage a list but to add them to a ticket as if it was a person for updates
  • OAuth Server
  • Conduit

Details

Reference
fl330

Event Timeline

flimport raised the priority of this task from to High.Sep 12 2014, 1:36 AM
flimport set Reference to fl330.

mattflaschen wrote on 2014-05-13 19:43:34 (UTC)

It looks like Ponder (Q&A) was disabled (it was on earlier). This could be useful, particularly if we use a license (T279) that matches the wiki (for easy copying back and forth). It could also be a place to send people who think they may have a bug, but it turns out just to be a question. This would be for questions about technical issues with the software (how to install/configure something, help with getting an extension working, question about a Lua script) etc, not wiki-specific questions (policies, which infobox to use, etc.).

There are potential reasons we might consider keeping it off. Some wikis (including MediaWiki.org and English Wikipedia) have help desks targeted for technical questions already, but I doubt all do.

This could potentially replace https://www.mediawiki.org/wiki/Project:Support_desk , or we could keep both.

swalling wrote on 2014-05-13 20:22:57 (UTC)

I've uninstalled the following applications:

  1. Legalpad (we host legal docs on-wiki, public or private)
  2. Macros (this is non-functional right now anyway)
  3. Diviner (as suggested by others)

demon wrote on 2014-05-13 23:37:06 (UTC)

I uninstalled xhprof, it's only meant to be used for development on Phabricator itself.

qgil wrote on 2014-05-13 23:38:38 (UTC)

About Day 1, I would enable only what falls within the scope of Day 1: task and bug management.

  • Maniphest
  • Feeds
  • Pholio
  • Projects
  • People
  • Flags
  • Herald
  • Tokens
  • Files

Since the documentation will live in https://www.mediawiki.org/wiki/Phabricator , it makes sense that support lives in MediaWiki as well. Otherwise the risk of having broken documentation in two places just increases.

qgil wrote on 2014-05-13 23:40:45 (UTC)

(Ooooh, no mid-air collision! I had started to type my reply before @demon posted his, yet both posts could just land at their right time) :)

mattflaschen wrote on 2014-06-02 19:20:03 (UTC)

Can we have Paste installed in the production version too?

I don't think we have any other Wikimedia site for this, and it's good for integrating Pastes into bug reports, etc (since you can embed or link them easily).

qgil wrote on 2014-06-02 22:06:21 (UTC)

A small but significant change caused by the Trusted User Tool project: we will launch a Phabricator instance in production only with Legalpad enabled.

The next steps will be geared toward Day 1 and will include Maniphest and the other apps required for bug / task management.

aklapper wrote on 2014-07-02 11:01:04 (UTC)

In T330#20, @mattflaschen wrote:

Can we have Paste installed in the production version too?
I don't think we have any other Wikimedia site for this

https://tools.wmflabs.org/paste/ (if that counts).

and it's good for integrating Pastes into bug reports, etc (since you can embed or link them easily).

I guess we could enable it.

Rush wrote on 2014-07-02 15:01:52 (UTC)

I would vote yes on paste since it's nice to keep all context for a ticket together and in prod

aklapper wrote on 2014-07-02 15:14:54 (UTC)

Alright, summarizing the current proposal:

  • Maniphest
  • Feeds
  • Pholio
  • Projects
  • People
  • Flags
  • Herald
  • Tokens
  • Files
  • Paste
  • Legalpad

If there's no other input or pros and cons, I'd say we're ready to go here?

Rush wrote on 2014-07-02 15:19:22 (UTC)

Mailing Lists - not to manage a list but to add them to a ticket as if it was a person for updates
Auth
Config

Rush wrote on 2014-07-02 15:26:06 (UTC)

oops also no legalpad here as for the moment they have their own space

https://legalpad.wikimedia.org (coming soon)

Rush wrote on 2014-07-08 18:07:51 (UTC)

also, dashboard :)

Rush wrote on 2014-09-06 14:41:12 (UTC)

no updates for a long time, closing this as it seems basically good

importing issue status

flimport closed this task as Resolved.Sep 12 2014, 1:36 AM
Qgil reopened this task as Open.Sep 17 2014, 7:19 PM
Qgil added a subscriber: Qgil.

Reopening, as there are many apps that need to be uninstalled or disabled.

Qgil added a comment.Sep 17 2014, 7:22 PM

We can remove Files for now (see T373: get certificate for phab.wmfusercontent.org) and we can leave Legalpad.

There is no reason to keep a separate http://legalpad.phabricator.org and there is also the possibility to run the tech volunteer NDA process here, see https://wikitech.wikimedia.org/wiki/Talk:Volunteer_NDA (being experimented at phab-01).

In T193#23, @Qgil wrote:

We can remove Files for now

We cannot --- "This application is required for Phabricator to operate, so all users must have access to it."

Qgil assigned this task to chasemp.Sep 19 2014, 3:40 PM
Qgil set Security to None.

Rush wrote on 2014-07-02 15:19:22 (UTC)

Mailing Lists - not to manage a list but to add them to a ticket as if it was a person for updates
Auth
Config

I am going to add that to the initial description here. Mailing Lists would e.g. influence T453.

So if I get it right we need modules/phabricator/data/fixed_settings.yaml in operations/puppet.git to change https://phabricator.wikimedia.org/config/edit/phabricator.uninstalled-applications/ (by inverting the list given above)

Aklapper updated the task description. (Show Details)Sep 19 2014, 10:58 PM

My clueless attempt in https://gerrit.wikimedia.org/r/#/c/161624/ is awaiting review.

I'd like to request that the calendar app be enabled ... it's highly useful and I can see absolutely no drawback to enabling it.

Qgil added a comment.Sep 21 2014, 9:23 AM
In T193#33, @mmodell wrote:

I'd like to request that the calendar app be enabled ... it's highly useful and I can see absolutely no drawback to enabling it.

Good idea... but might have more complexity behind, see T466: Enable the Calendar app in Phabricator and let's continue discussing the Calendar app there.

I think we should focus in closing tasks and avoid opening new discussions if they are not required for Day 1.

Qgil added a comment.Sep 23 2014, 7:10 AM

I have set the policies of all the apps to visible only to admins. This is an interim solution while Andre's patch is reviewed. Good enough to make this task not a blocker of T463 anymore.

In T193#5343, @Qgil wrote:

while Andre's patch is reviewed

As Chase pointed out in Gerrit my patch is the wrong approach, and we should disable apps that we want to disable in this specific instance via its web admin UI. @chasemp: Please correct me if I got you wrong.

nope, is true

Qgil added a comment.Oct 1 2014, 2:25 PM

Then... are we done with this task?

Not quite, I need to go through the applications and verify their settings
and document the security stuff.

chasemp closed this task as Resolved.Oct 2 2014, 10:56 PM