Page MenuHomePhabricator

common.css is not loaded in hewiki
Closed, InvalidPublic

Description

See for example the infobox in: https://he.wikipedia.org/wiki/%D7%90%D7%91%D7%A8%D7%94%D7%9D_%D7%9C%D7%99%D7%A0%D7%A7%D7%95%D7%9C%D7%9F
infobox class defined in Common.css (https://he.wikipedia.org/wiki/%D7%9E%D7%93%D7%99%D7%94_%D7%95%D7%99%D7%A7%D7%99:Common.css) is not loaded, resulting in corrupted view (the infobox should float left)

Event Timeline

eranroz created this task.Apr 25 2018, 9:25 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 25 2018, 9:25 PM
eranroz triaged this task as Unbreak Now! priority.Apr 25 2018, 9:25 PM
Restricted Application added subscribers: Liuxinyu970226, TerraCodes. · View Herald TranscriptApr 25 2018, 9:25 PM
eranroz lowered the priority of this task from Unbreak Now! to Medium.Apr 25 2018, 9:30 PM

issue seems to be solved. changing the priority for medium as there is no yet root cause

Restricted Application added a project: Performance-Team. · View Herald TranscriptApr 26 2018, 6:28 AM
Nirmos added a subscriber: Nirmos.Apr 26 2018, 6:57 AM

Could someone remind me, is hewiki one of the two Wikipedias that get new software updates one day early? Is it hewiki and cawiki?

And, to clarify, you didn't do anything on-wiki to resolve this issue?

Could someone remind me, is hewiki one of the two Wikipedias that get new software updates one day early? Is it hewiki and cawiki?

Yes, see https://noc.wikimedia.org/conf/highlight.php?file=dblists/group1-wikipedia.dblist

Krinkle closed this task as Invalid.Apr 26 2018, 2:56 PM

Task T191596 was due to a change specific to MobileFrontend, it couldn't affect the desktop site, which this bug report is about. (based on domain name, and based on Common.css being desktop-only).

It seems to be loaded correctly from the page HTML, and responding with a stylesheet without issue. I was also not able to find any error log entries relating to he.wikipedia.org and ResourceLoader ("load.php") during the last 30 days.

I suspected maybe a change to Common.css may've resulted in invalid syntax thus causing later styles to be corrupted, giving it the appearance of some styles being missing (when actually they are there, but invalid, e.g. similar to typing <div hello world> instead of <div> hello world</div> and not seeing the text on the page. However, I don't see any recent edits to MediaWiki:Common.css or MediaWiki:Vector.css on he.wikipedia.org that would explain this.

I'll close it for now given we have no data to analyse and thus no way to get closer to a root cause. Once it happens again, please re-open this task.

Restricted Application removed a subscriber: Liuxinyu970226. · View Herald TranscriptApr 26 2018, 2:56 PM
Vvjjkkii renamed this task from common.css is not loaded in hewiki to o7daaaaaaa.Jul 1 2018, 1:14 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii raised the priority of this task from Medium to High.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
Mainframe98 renamed this task from o7daaaaaaa to common.css is not loaded in hewiki.Jul 1 2018, 7:46 AM
Mainframe98 closed this task as Invalid.
Mainframe98 lowered the priority of this task from High to Medium.
Mainframe98 updated the task description. (Show Details)