Page MenuHomePhabricator

Maplink shifts right on zoom-in
Closed, DeclinedPublic

Description

Hi,

Recently we started using the Kartographer extension's maps on hewikivoyage. However, we have one major problem with the maps.

Try to focus on one of the points on the map here and zoom-in: https://he.wikivoyage.org/wiki/%D7%9E%D7%95%D7%A0%D7%93%D7%99%D7%90%D7%9C_2018. You will see that the map suddenly behaves strangely and shifts right.

For example, as you can see in the attached video, when I tried to focus on point number 4, all the parts of the map shifted right.

When I try to do the same thing in the maps of the English Wikivoyage or the French version, the problem doesn't appear and I manage to focus on the point when I zoom-in.

I usually use Google Chrome ,but I should point out that both Internet Explorer and Firefox will have similar results.

Event Timeline

DekelE created this task.Apr 28 2018, 1:14 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 28 2018, 1:14 PM
DekelE triaged this task as Normal priority.Apr 28 2018, 1:16 PM
DekelE updated the task description. (Show Details)
Aklapper added a comment.EditedApr 28 2018, 1:58 PM

Hi @DekelE, thanks for taking the time to report this! I can neither reproduce this in Firefox 59 nor Chromium 65.

Does this problem also happen when using safemode? See https://www.mediawiki.org/wiki/Help:Locating_broken_scripts for more information.

After I enabled all gadgets on https://he.wikivoyage.org/wiki/מיוחד:העדפות#mw-prefsection-gadgets I see errors in the console of the browser's developer tools on https://he.wikivoyage.org/wiki/מונדיאל_2018?debug=true regarding the files מדיה_ויקי:LoadingContent.js, מדיה_ויקי:Gadget-OrphanCheck.js - that could be related or not. :-/

Again, this might be unrelated, but at least in Chromium I also get:

load.php?debug=true&lang=he&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=vector&version=1nv7gwr:13675 Error: Unknown dependency: mediawiki.action.history.diff
    at sortDependencies (load.php?debug=true&lang=he&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=vector&version=1nv7gwr:11986)
    at sortDependencies (load.php?debug=true&lang=he&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=vector&version=1nv7gwr:12031)
    at resolveStubbornly (load.php?debug=true&lang=he&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=vector&version=1nv7gwr:12066)
    at Object.load (load.php?debug=true&lang=he&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=vector&version=1nv7gwr:12997)
    at מונדיאל_2018?debug=true:447
    at startUp (load.php?debug=true&lang=he&modules=startup&only=scripts&skin=vector:8386)
    at HTMLScriptElement.script.onload (load.php?debug=true&lang=he&modules=startup&only=scripts&skin=vector:8411)

QuickRCDiff defines mediawiki.action.history.diffon מיוחד:העדפות:Gadgets-definition which seems to throw an error somehow.

Vvjjkkii renamed this task from Maplink shifts right on zoom-in to 90daaaaaaa.Jul 1 2018, 1:13 AM
Vvjjkkii raised the priority of this task from Normal to High.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
CommunityTechBot renamed this task from 90daaaaaaa to Maplink shifts right on zoom-in.Jul 2 2018, 3:00 PM
CommunityTechBot lowered the priority of this task from High to Normal.
CommunityTechBot updated the task description. (Show Details)
CommunityTechBot added a subscriber: Aklapper.
MSantos closed this task as Declined.Sep 25 2018, 3:27 PM
MSantos added a subscriber: MSantos.

It seems ok and we are not able to reproduce the issue, I am going to decline but if someone can reproduce it or think it still need solving, please reopen it.