Page MenuHomePhabricator

Notice: Undefined index: 0 in /srv/mediawiki/php-1.32.0-wmf.1/extensions/AbuseFilter/includes/AbuseFilter.php on line 1498
Closed, ResolvedPublic

Description

We seem to get a few thousand of these per day. Seems wrong on several levels: something is calling AbuseFilter::takeConsequenceAction wrong (yay for completely undocumented public methods), but also why don't we have a type:mediawiki log event with a stack trace? And why is everything logged in duplicate? (one, two)

Details

Related Gerrit Patches:
mediawiki/extensions/AbuseFilter : REL1_31Check if parameters are set instead of using strlen
mediawiki/extensions/AbuseFilter : masterCheck if parameters are set instead of using strlen

Event Timeline

Tgr created this task.Apr 29 2018, 9:37 AM
Restricted Application added subscribers: Scoopfinder, Aklapper. · View Herald TranscriptApr 29 2018, 9:37 AM

Change 429659 had a related patch set uploaded (by Daimona Eaytoy; owner: Daimona Eaytoy):
[mediawiki/extensions/AbuseFilter@master] Check if parameters are set instead of using strlen

https://gerrit.wikimedia.org/r/429659

@Tgr Maybe T193324?

Not exactly, but caused by the same change.

Change 429713 had a related patch set uploaded (by Daimona Eaytoy; owner: Daimona Eaytoy):
[mediawiki/extensions/AbuseFilter@REL1_31] Check if parameters are set instead of using strlen

https://gerrit.wikimedia.org/r/429713

Daimona claimed this task.Apr 30 2018, 6:10 AM

Change 429659 abandoned by Krinkle:
Check if parameters are set instead of using strlen

Reason:
Superseded by cbabcf1276da506abfa8187792d327c492078194

https://gerrit.wikimedia.org/r/429659

Change 429713 abandoned by Krinkle:
Check if parameters are set instead of using strlen

Reason:
Superseded by https://gerrit.wikimedia.org/r/#/c/429999/

https://gerrit.wikimedia.org/r/429713

Krinkle closed this task as Resolved.May 1 2018, 2:27 AM
Krinkle added subscribers: Catrope, Krinkle.

Noticed and fixed independently by @Catrope in rEABFcbabcf1276da: Follow-up 392f37d516501fd: fix undefined index notice, which has since been deployed.

Vvjjkkii renamed this task from Notice: Undefined index: 0 in /srv/mediawiki/php-1.32.0-wmf.1/extensions/AbuseFilter/includes/AbuseFilter.php on line 1498 to s0daaaaaaa.Jul 1 2018, 1:13 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii removed Daimona as the assignee of this task.
Vvjjkkii triaged this task as High priority.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed subscribers: gerritbot, Aklapper.
Daimona renamed this task from s0daaaaaaa to Notice: Undefined index: 0 in /srv/mediawiki/php-1.32.0-wmf.1/extensions/AbuseFilter/includes/AbuseFilter.php on line 1498.Jul 1 2018, 10:17 AM
Daimona closed this task as Resolved.
Daimona claimed this task.
Daimona raised the priority of this task from High to Needs Triage.
Daimona updated the task description. (Show Details)
Daimona added subscribers: gerritbot, Aklapper.
mmodell changed the subtype of this task from "Task" to "Production Error".Aug 28 2019, 11:09 PM