Page MenuHomePhabricator

[wmf.1] Horizontal scrolling on full-map view panel
Closed, ResolvedPublic

Description

The issue is present in betalabs too:

Go to any mapframe (or insert one e.g. below:) - the horizontal scrolling will be present:

<mapframe text="India (80,20)" width=700 height=400 zoom=3 longitude="80" latitude="20">

Details

Related Gerrit Patches:

Event Timeline

Restricted Application added a project: Maps. · View Herald TranscriptApr 30 2018, 7:23 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Etonkovidova updated the task description. (Show Details)Apr 30 2018, 7:23 PM
Restricted Application added a project: Discovery. · View Herald TranscriptApr 30 2018, 7:23 PM

@Mooeypoo You've worked on this panel. Any idea why it started scrolling?

eek; it was a combination of an older condition with the padding/placements that the new widgets used.

Fixed in the attached commit.

Change 432008 had a related patch set uploaded (by Mooeypoo; owner: Mooeypoo):
[mediawiki/extensions/Kartographer@master] Adjust padding/overflow to prevent redundant scrollbars in map sidebar

https://gerrit.wikimedia.org/r/432008

Change 432008 merged by jenkins-bot:
[mediawiki/extensions/Kartographer@master] Adjust padding/overflow to prevent redundant scrollbars in map sidebar

https://gerrit.wikimedia.org/r/432008

Perfectly working in betalabs (also works when re-sizing the window):

@Mooeypoo
However, when clicking on "View more", the horizontal scrolling appears. I vaguely remember that it's extremely difficult to disable horizontal scrolling if a vertical scrolling is in place, so maybe we should be fine as it is?

Mooeypoo added a comment.EditedMay 10 2018, 2:14 AM

@Mooeypoo
However, when clicking on "View more", the horizontal scrolling appears. I vaguely remember that it's extremely difficult to disable horizontal scrolling if a vertical scrolling is in place, so maybe we should be fine as it is?

Oy, I'll take another look at this. I think I know why this happens, though, so I have a place to start...

I think I can try and play around with the sizing of the buttons to make this go away. If not, I can try and cheat but having the buttons themselves smaller than the highlight area, and have that area extend with an overflow. Alternatively, I can also hide all horizontal scrollbars, since those should never appear, but I am slightly worried about them being needed at some point in smaller screens.

I'll take another look.

Change 432640 had a related patch set uploaded (by Mooeypoo; owner: Mooeypoo):
[mediawiki/extensions/Kartographer@master] Adjust sidebar items' width to prevent horizontal scrollbar

https://gerrit.wikimedia.org/r/432640

Change 432640 merged by jenkins-bot:
[mediawiki/extensions/Kartographer@master] Adjust sidebar items' width to prevent horizontal scrollbar

https://gerrit.wikimedia.org/r/432640

Checked in betalabs - fixed:

Etonkovidova closed this task as Resolved.May 20 2018, 4:43 PM
Vvjjkkii renamed this task from [wmf.1] Horizontal scrolling on full-map view panel to bydaaaaaaa.Jul 1 2018, 1:12 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii removed Mooeypoo as the assignee of this task.
Vvjjkkii triaged this task as High priority.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed subscribers: gerritbot, Aklapper.
CommunityTechBot renamed this task from bydaaaaaaa to [wmf.1] Horizontal scrolling on full-map view panel.Jul 1 2018, 2:14 PM
CommunityTechBot closed this task as Resolved.
CommunityTechBot assigned this task to Mooeypoo.
CommunityTechBot updated the task description. (Show Details)
CommunityTechBot added subscribers: gerritbot, Aklapper.
CommunityTechBot raised the priority of this task from High to Needs Triage.Jul 3 2018, 1:50 AM