Page MenuHomePhabricator

CX2: Translation options are not available for some languages
Closed, ResolvedPublic

Description

The issue exists for certain pairs of source-translate language - I saw it for translations from English to Deutsch (German), English to Tamil. The issue does not exist for translating from English to español

  1. The translation options are not available:

  1. The console displays multiple warning messages:
jQuery.Deferred exception: Cannot read property 'getDefaultNonMTProvider' of undefined TypeError: Cannot read property 'getDefaultNonMTProvider' of undefined
  1. Clicking to add paragraph does not result in adding a paragraph to translation, but displays

POST http://cxserver2.wmflabs.org/v2/translate/en/ta/Yandex 403 (Forbidden) (previously filed as T191856).

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 1 2018, 12:43 AM
Etonkovidova renamed this task from CX2: Options for automatic translation are not available for some languages to CX2: Translation options are not available for some languages.May 1 2018, 5:03 AM
Etonkovidova updated the task description. (Show Details)
Pginer-WMF triaged this task as Normal priority.May 1 2018, 4:37 PM
Pginer-WMF moved this task from Needs Triage to CX2 on the ContentTranslation board.

Change 430590 had a related patch set uploaded (by Nikerabbit; owner: Nikerabbit):
[mediawiki/extensions/ContentTranslation@master] CX2: Fix error when no MT providers available

https://gerrit.wikimedia.org/r/430590

Nikerabbit moved this task from Backlog to In Review on the Language-2018-Apr-June board.
santhosh moved this task from In Review to QA on the Language-2018-Apr-June board.May 4 2018, 4:49 AM

Change 430590 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] CX2: Fix error when no MT providers available

https://gerrit.wikimedia.org/r/430590

Checked in cx2-testing - the specific errors mentioned in the ticket are not displayed. @Nikerabbit - do you think that issues mentioned below were supposed to be fixed by your patch or there will be more work done?

However, the issue is still present

  • the translation cannot be made - clicking on a paragraph will not result in loading it in the translation column
  • the other options for translation are not available
  • the Console error will be displayed
cxserver2.wmflabs.org/v2/translate/en/ta/Yandex:1 POST http://cxserver2.wmflabs.org/v2/translate/en/ta/Yandex 403 (Forbidden)

In cx-testing, the Console error is the same, but the translation is possible and the translation options are available:

I only fixed the error message. Point number 3 is tracker in T193753/T191856 and my upcoming patches for T188247 should fix point number 1.

Etonkovidova closed this task as Resolved.May 10 2018, 10:17 PM

Closing this ticket - the other aspects of the issue will be addressed by other phab tasks.

Vvjjkkii renamed this task from CX2: Translation options are not available for some languages to mxdaaaaaaa.Jul 1 2018, 1:12 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii removed Nikerabbit as the assignee of this task.
Vvjjkkii raised the priority of this task from Normal to High.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii edited subscribers, added: Nikerabbit; removed: gerritbot, Aklapper.
Arrbee renamed this task from mxdaaaaaaa to CX2: Translation options are not available for some languages.Jul 2 2018, 1:28 PM
Arrbee closed this task as Resolved.
Arrbee assigned this task to Nikerabbit.
Arrbee lowered the priority of this task from High to Normal.
Arrbee updated the task description. (Show Details)
Arrbee removed a subscriber: Nikerabbit.