Page MenuHomePhabricator

" Uncaught Error: Unbalanced set of replace operations found" appears while switching from option "Automatic Translation" to "Don't use machine translation"
Closed, DuplicatePublic

Description

" Uncaught Error: Unbalanced set of replace operations found" appears while switching from option "Automatic Translation" to "Don't use machine translation"

Event Timeline

Ryasmeen created this task.May 1 2018, 10:48 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 1 2018, 10:48 PM
Pginer-WMF triaged this task as Normal priority.May 3 2018, 2:01 PM
Pginer-WMF moved this task from Needs Triage to CX2 on the ContentTranslation board.
Vvjjkkii renamed this task from " Uncaught Error: Unbalanced set of replace operations found" appears while switching from option "Automatic Translation" to "Don't use machine translation" to xtdaaaaaaa.Jul 1 2018, 1:14 AM
Vvjjkkii raised the priority of this task from Normal to High.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
Mainframe98 renamed this task from xtdaaaaaaa to " Uncaught Error: Unbalanced set of replace operations found" appears while switching from option "Automatic Translation" to "Don't use machine translation".Jul 1 2018, 7:43 AM
Mainframe98 lowered the priority of this task from High to Normal.
Mainframe98 updated the task description. (Show Details)
Mainframe98 added a subscriber: Aklapper.
Pginer-WMF closed this task as Resolved.Jul 6 2018, 9:42 AM
Pginer-WMF claimed this task.

With the recent changes on the MT card, the issue is not appearing. Feel free to try to reproduce the issue again, and reopen the ticket if still applies.

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptJul 6 2018, 9:42 AM
Ryasmeen reopened this task as Open.Jul 17 2018, 1:26 AM

I see a different error now though while doing the same and in fact now it does not even switch to the option "Don't use machine translation" anymore.

VM165:421 Uncaught TypeError: Cannot read property 'getModel' of undefined
    at VeInitMwCXTarget.ve.init.mw.CXTarget.getTargetSectionNode (<anonymous>:421:772)
    at VeUiCXTranslationAction.<anonymous> (<anonymous>:463:177)
    at fire (load.php?debug=false&lang=en&modules=jquery|mediawiki.base&only=scripts&skin=vector&version=069i1tc:46)
    at Object.fireWith [as rejectWith] (load.php?debug=false&lang=en&modules=jquery|mediawiki.base&only=scripts&skin=vector&version=069i1tc:47)
    at process (load.php?debug=false&lang=en&modules=jquery|mediawiki.base&only=scripts&skin=vector&version=069i1tc:50)

I see a different error now though while doing the same and in fact now it does not even switch to the option "Don't use machine translation" anymore.

VM165:421 Uncaught TypeError: Cannot read property 'getModel' of undefined

Same as: https://phabricator.wikimedia.org/T198368 ?

I see a different error now though while doing the same and in fact now it does not even switch to the option "Don't use machine translation" anymore.

VM165:421 Uncaught TypeError: Cannot read property 'getModel' of undefined

Same as: https://phabricator.wikimedia.org/T198368 ?

Thanks @Ryasmeen for rechecking, and @KartikMistry for the related ticket.
I think both are also the same issue as T199011, which is in the process of getting fixed (a patch in review). I'll merge them as duplicates.