Page MenuHomePhabricator

Requesting access to Logstash for jbennett
Closed, ResolvedPublic

Description

Username: jbennett
Full name: John Bennett

Event Timeline

JBennett created this task.May 3 2018, 5:36 PM
Restricted Application added a project: Operations. · View Herald TranscriptMay 3 2018, 5:36 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
RobH updated the task description. (Show Details)May 3 2018, 5:37 PM
RobH updated the task description. (Show Details)
RobH added a subscriber: RobH.May 3 2018, 5:44 PM

@JBennett: Can you clarify exactly what you need to access on logstash? Do you just need to read files, or administrate the node? I'm not really sure what you want to do there, so not sure what group to put you in.

We'll also need you to comment with a public ssh key. This ssh key should have a passphrase on the private key, and not be used on any other systems. It should be dedicated to Wikimedia production shell, not shared with cloud or anywhere else.

Depending on the access requested, we may have to have it reviewed in our weekly SRE meeting (if it has any sudo access in the request.)

RobH added a comment.May 3 2018, 5:44 PM

@JBennett: Can you clarify exactly what you need to access on logstash? Do you just need to read files, or administrate the node? I'm not really sure what you want to do there, so not sure what group to put you in.

We'll also need you to comment with a public ssh key. This ssh key should have a passphrase on the private key, and not be used on any other systems. It should be dedicated to Wikimedia production shell, not shared with cloud or anywhere else.

Depending on the access requested, we may have to have it reviewed in our weekly SRE meeting (if it has any sudo access in the request.)

Your Full Name: John Bennett
developer access userid: jbennett
ssh key:
ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAABAQDIOdNYh9J4uSm7uuVZG7zttu/9Xtk5IaCPSokdOyhNnAoMBE51mnTZTrGm+SxUTfXs3tniklrn2lZtDDookMOnDFzN/HwhKbw0QEsef9f2hOVj16QLF5jqdZi8Tk/15OOaHJST4/BafT3uFpMnaQLRpApfSYlKvqLxs2cZFLCtfZZ2HscCpNUPpbNLyRg0OcPoFhjui+dnVZJR856L+wStSFv9oUytshOa0/JYd0VMRV78kDcXIKIMbaqufhaMKCel3lA7QnJzQMoTvWY/FB888koHza+si0bzwc/DhQE19kE6Oobu8WabmDwiP3sQyiuc+bEM6Xn3YUer8nnJoBPx john@gpants

Reason: need access to logstash

I need to be able to access logstash to invistigate security incidents. So, i'll similar access to Brian Wolff or Sam Reed.

RobH claimed this task.May 3 2018, 5:49 PM
RobH triaged this task as Normal priority.
RobH updated the task description. (Show Details)
RobH edited projects, added LDAP-Access-Requests; removed SRE-Access-Requests.

IRC Update:

John actually needs access to the https frontend, not shell access. So moving from SRE-Access-Requests to LDAP-Access-Requests. Since ldap flags have no waiting period, I'll add @JBennett to the ldap only users section of the admin module and add the proper wmf ldap flag.

Change 430635 had a related patch set uploaded (by RobH; owner: RobH):
[operations/puppet@production] adding john bennett to ldap users section

https://gerrit.wikimedia.org/r/430635

Change 430635 merged by RobH:
[operations/puppet@production] adding john bennett to ldap users section

https://gerrit.wikimedia.org/r/430635

RobH closed this task as Resolved.May 3 2018, 5:59 PM

Confirmed wikitech account, added to ldap users section of admin module, and added to wmf ldap group.

Vvjjkkii renamed this task from Requesting access to Logstash for jbennett to sodaaaaaaa.Jul 1 2018, 1:12 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii removed RobH as the assignee of this task.
Vvjjkkii raised the priority of this task from Normal to High.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed subscribers: gerritbot, Aklapper.
CommunityTechBot renamed this task from sodaaaaaaa to Requesting access to Logstash for jbennett.Jul 2 2018, 2:08 PM
CommunityTechBot closed this task as Resolved.
CommunityTechBot assigned this task to RobH.
CommunityTechBot lowered the priority of this task from High to Normal.
CommunityTechBot updated the task description. (Show Details)
CommunityTechBot added subscribers: gerritbot, Aklapper.