Define english (en) as a fallback language for greek (el) for maps
Closed, ResolvedPublic

Description

Maps on greek (el) projects (or at least elwiki) that display el labels should fallback to english labels before falling back to local labels.
This should also happen when the map has a lang="el" parameter.

Discussed in https://www.mediawiki.org/wiki/Topic:Ubzgfi8j4bdsqe9p
and proposed in elwiki village pump with no objections: https://b.geraki.gr/2rk57yQ

geraki created this task.May 4 2018, 1:05 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Restricted Application added a project: Discovery. · View Herald TranscriptMay 4 2018, 1:27 PM
Catrope renamed this task from Define english (en) as a fallback language for greek (el) to Define english (en) as a fallback language for greek (el) for maps.May 8 2018, 6:11 PM

@CKoerner_WMF, as suggested, @geraki has gone to the community for consensus. If this looks good to you, we are prepared to implement.

@geraki, after we add the fallback, you'll want to be on the lookout for cases where a map of a Greek territory on a Greek wiki is suddenly showing English labels for things that should have Greek labels. This will probably indicate that there is a Greek local label but no Greek multilingual label (tagged with "el"). In such a case, you can declare the map lang="local" or go to OpenStreetMap and add the label in Greek with the "el" tag. The issue is described here.

@jmatazzoni Looks good to me. Thanks @geraki for helping with this.

Now that this PR is merged, Babel needs to be tagged, a new package has to be published, and upstream repos have to use it for this change to ever make it into production.

jmatazzoni added a comment.EditedMay 10 2018, 8:42 PM

In T193866#4198535, @SBisson wrote:

Now that this PR is merged, Babel needs to be tagged, a new package has to be published, and upstream repos have to use it for this change to ever make it into production.

So, will that happen now as part of this ticket, or do we need to create more tickets (and for us or other teams?). The word "ever" makes it sound hard.

I thought this process was simpler. I'm literally just about to write a post telling wikis how to get their fallback changed and, implicitly, encouraging smaller languages to do it. (I'm looking at you Catalan, which falls back only to Oc—which means Catalan maps of foreign parts are not good at all.) Does this raise a concern? Should I hold off, or, maybe, just raise the possibility but downplay it?

In T193866#4198535, @SBisson wrote:

Now that this PR is merged, Babel needs to be tagged, a new package has to be published, and upstream repos have to use it for this change to ever make it into production.

So, will that happen now as part of this ticket, or do we need to create more tickets (and for us or other teams?). The word "ever" makes it sound hard.

I thought this process was simpler. I'm literally just about to write a post telling wikis how to get their fallback changed and, implicitly, encouraging smaller languages to do it. (I'm looking at you Catalan, which falls back only to Oc—which means Catalan maps of foreign parts are not good at all.) Does this raise a concern? Should I hold off, or, maybe, just raise the possibility but downplay it?

It will be part of this ticket. All of that is easy and takes just 5 minutes.

The reason I wrote it here instead of doing it is to make sure @Catrope remains aware of it. Now that he's been pinged I will go ahead and do it.

Done. Will be deployed next week.

Etonkovidova closed this task as Resolved.Jun 12 2018, 5:17 PM
Etonkovidova claimed this task.
Etonkovidova added a subscriber: Etonkovidova.

Checked on elwiki (wmf.7) - the fallback to English works.

Vvjjkkii renamed this task from Define english (en) as a fallback language for greek (el) for maps to 5ldaaaaaaa.Jul 1 2018, 1:12 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii triaged this task as High priority.
Vvjjkkii removed Etonkovidova as the assignee of this task.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
CommunityTechBot assigned this task to Etonkovidova.
CommunityTechBot raised the priority of this task from High to Needs Triage.
CommunityTechBot closed this task as Resolved.
CommunityTechBot renamed this task from 5ldaaaaaaa to Define english (en) as a fallback language for greek (el) for maps.
CommunityTechBot added a subscriber: Aklapper.