Page MenuHomePhabricator

On this day in Russian possibly miscalculating number of years
Closed, ResolvedPublic

Description

From OTRS - https://ticket.wikimedia.org/otrs/index.pl?Action=AgentTicketZoom;TicketID=10684931
Note -Translated the text via google. This is not happening on the English version and I cannot read Russian to tell if it is correct there.

Steps:

  1. Set the device language to Russian
  2. Navigate to On This Day, scroll down

Expected:
The number of year since an event is correct

Actual:
The number of years is incorrect

From the user
Некорректно определяет количество прошедших лет


Event Timeline

ABorbaWMF created this task.May 4 2018, 5:28 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 4 2018, 5:28 PM

@ABorbaWMF: It might be good to also include the original untranslated text. Associating a project tag is very welcome.

Going to https://ru.wikipedia.org/wiki/Заглавная_страница and looking at the В этот день section, it says 4 мая which is still today (at least in some Russian timezones). Clicking the last listed item called 1979 — Маргарет Тэтчер стала первой женщиной — премьером Великобритании. the article at https://ru.wikipedia.org/wiki/Тэтчер,_Маргарет says that her office started on 4 мая 1979 года so I don't see a bug? Note that I am logged in.

This might be the very same issue as T192419: Problema con el cálculo de la edad / Problem with age calculation which I could not reproduce either.

ABorbaWMF updated the task description. (Show Details)May 4 2018, 7:32 PM

@Aklapper I added the text and some screenshots. Let me know if I can help with anything else. Thanks

@ABorbaWMF: I do not know how to get to the view that is shown in the screenshots. Is that in a web browser? Or is that some app?

@Aklapper Sorry! I was inputting a few tickets and I must have forgotten to tag this one properly. This is an iOS App bug.

LGoto triaged this task as Low priority.May 7 2018, 6:43 PM
Mhurd removed Mhurd as the assignee of this task.
Mhurd added a subscriber: Mhurd.

I am still seeing this (I think) on 5.8.2 (1420). when I scroll down I am seeing the same characters as in the original description.

Vvjjkkii renamed this task from On this day in Russian possibly miscalculating number of years to cldaaaaaaa.Jul 1 2018, 1:11 AM
Vvjjkkii raised the priority of this task from Low to High.
Vvjjkkii removed JoeWalsh as the assignee of this task.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii edited subscribers, added: JoeWalsh; removed: Aklapper.
CommunityTechBot assigned this task to JoeWalsh.
CommunityTechBot lowered the priority of this task from High to Low.
CommunityTechBot renamed this task from cldaaaaaaa to On this day in Russian possibly miscalculating number of years.
CommunityTechBot edited subscribers, added: Aklapper; removed: JoeWalsh.
JoeWalsh removed JoeWalsh as the assignee of this task.Jul 12 2018, 6:51 PM
JoeWalsh added a subscriber: JoeWalsh.

Looking good to me across a few cards and devices on 6.2.1 (1586)

JMinor closed this task as Resolved.Tue, Apr 9, 5:27 PM