Page MenuHomePhabricator

"Publish" after translation with content translation with an unsupported language combination gives an error
Closed, ResolvedPublic

Description

Steps:

  1. Invoking Content Translation with a Danish article to an English article.
  2. The language combination seems not to be supported by the automatic translation, so the article was manually translated.
  3. After translation press the "Publish" in the corner.

The steps result in an error written on the top of the interface (I do not have access to the precise wording).

I would have expected that the new English article was published.

This occurred for an account that I do not have access to. I have not attempted to recreate the steps on another article.

Event Timeline

Fnielsen created this task.May 5 2018, 7:29 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 5 2018, 7:29 PM
Fnielsen renamed this task from " publish" after translation with content translation with an unsupported language combination gives an error to "Publish" after translation with content translation with an unsupported language combination gives an error.May 5 2018, 7:38 PM
Fnielsen updated the task description. (Show Details)

I wonder how I can test this. Is there a test system? The only way I can imaging is to find a Danish article that needs translation to English.

Pginer-WMF triaged this task as Normal priority.May 9 2018, 9:38 AM
Pginer-WMF moved this task from Needs Triage to Check & Move on the ContentTranslation board.
Pginer-WMF added a subscriber: Pginer-WMF.

English Wikipedia has restricted the publication of translations into English (more details). Currently you need to have more than 500 edits in order to publish translations in English Wikipedia. This may be the cause of the issue, although each wiki has a different set of edit filters to catch issues such as links to sites that the community consider as SPAM and similar patterns. Without the error message it is hard to know which is the exact issue. In any case, we are working to communicate these circumstances better in the new version of the tool (T192144) as well as porting some of the improvements to the current one (T194147).

Pginer-WMF closed this task as Resolved.Jun 6 2018, 3:57 PM
Pginer-WMF claimed this task.
Vvjjkkii renamed this task from "Publish" after translation with content translation with an unsupported language combination gives an error to wjdaaaaaaa.Jul 1 2018, 1:11 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii raised the priority of this task from Normal to High.
Vvjjkkii removed Pginer-WMF as the assignee of this task.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
CommunityTechBot assigned this task to Pginer-WMF.
CommunityTechBot lowered the priority of this task from High to Normal.
CommunityTechBot closed this task as Resolved.
CommunityTechBot renamed this task from wjdaaaaaaa to "Publish" after translation with content translation with an unsupported language combination gives an error.
CommunityTechBot added a subscriber: Aklapper.