Page MenuHomePhabricator

Remove the "zoom in" / "zoom out" buttons of <mapframe> on ku.wikipedia
Closed, ResolvedPublic

Description

Hello. Can we remove the buttons "zoom in" zoom out "and freeze the map when it is small. And after enlargement when returning back find the same frame.

These things exist on all wikis that have <mapframe> enabled, for example see es.wikipedia: https://es.wikipedia.org/wiki/Pompaelo.
In comparison here is what we see on ku.wikipedia: https://ku.wikipedia.org/wiki/S%C3%BBra_Amed%C3%AA

Thanks

See also: T190944

Event Timeline

Ghybu created this task.May 8 2018, 2:03 PM
Restricted Application removed a project: Patch-For-Review. · View Herald TranscriptMay 8 2018, 2:03 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Ghybu updated the task description. (Show Details)May 8 2018, 2:11 PM

ku.wikipedia.org uses a local {{Mapframe}} template.
es.wikipedia.org instead uses a local {{map draw}} template.

Can we remove the buttons "zoom in" zoom out "and freeze the map when it is small. And after enlargement when returning back find the same frame.

@Ghybu: Is this a request that someone writes code to add such a new feature to the software?
Or have you seen this behavior in a wiki that has <mapframe> enabled already? If so, where exactly?

@Ghybu: In general, please follow https://mediawiki.org/wiki/How_to_report_a_bug : Structure the tasks that you create by providing 1) steps to reproduce, 2) expected outcome, 3) actual outcome, to avoid misunderstandings. Thanks!

Ghybu added a comment.EditedMay 8 2018, 8:06 PM

@Aklapper: I thought I answered these questions :) I know my english is bad...

{{Mapframe}} and {{map draw}} use the same code, even if they have different names

At the risk of repeating myself:

  • As I said above, this behavior exists on all wikis that have <mapframe> active. What I ask is the same behavior as all these wikis.
  • Comparing es.wiki and ku.wiki you can see that on es.wiki the keys "+" and "-" to zoom is not displayed: I try to do the same.

To be clear: I surrounded in red the difference: https://upload.wikimedia.org/wikipedia/ku/2/2a/Ghybu_test.png

Thanks, that makes it clearer! :)
(I have no idea whether to add some Map related project tag like Maps or Maps-Sprint to this task or not.)

Ghybu added a comment.May 9 2018, 2:01 PM

@Aklapper: It's fixed now. Has anyone done anything? :) Thanks.

Aklapper closed this task as Resolved.May 11 2018, 1:14 PM

Works for me too now. No idea which specific changes happened in the meantime.
Closing as resolved, but please reopen this task if this happens again!

Vvjjkkii renamed this task from Remove the "zoom in" / "zoom out" buttons of <mapframe> on ku.wikipedia to 0ddaaaaaaa.Jul 1 2018, 1:11 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii triaged this task as High priority.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
Restricted Application added a subscriber: Dereckson. · View Herald TranscriptJul 1 2018, 1:11 AM
CommunityTechBot renamed this task from 0ddaaaaaaa to Remove the "zoom in" / "zoom out" buttons of <mapframe> on ku.wikipedia.Jul 1 2018, 3:34 PM
CommunityTechBot closed this task as Resolved.
CommunityTechBot claimed this task.
CommunityTechBot raised the priority of this task from High to Needs Triage.
CommunityTechBot updated the task description. (Show Details)
CommunityTechBot edited subscribers, added: Aklapper; removed: Dereckson.