Page MenuHomePhabricator

No localized Chechen letter for WikiEditor toolbar buttons is provided in Chechen Wikipedia
Closed, ResolvedPublic1 Estimated Story Points

Description

I ask to return the Chechen icon to the toolbar in the Chechen wikipedia.

https://commons.wikimedia.org/wiki/File:Toolbaricon_bold_I.png

Screenshot_11.jpg (189×688 px, 27 KB)

Event Timeline

Aklapper renamed this task from Localized toolbar buttons to the Chechen language to Chechen Wikipedia only uses localized WikiEditor toolbar buttons when explicitly passing uselang=ce.May 8 2018, 8:52 PM

@Aklapper Are you sure? Those two pages look the same to me:

image.png (980×1 px, 189 KB)

The second URL will use your account's interface preferences if set, it seems (or the content language if not); my account (set to en-gb) shows B/I, logged out shows Ж/К.

Aklapper changed the task status from Open to Stalled.May 9 2018, 8:42 AM

Sorry, definitely my fault. https://ce.wikipedia.org/wiki/Белхан:ГӀирсаш was set to English language. Which means that nobody can reproduce the problem.

@Umar: What is the language setting in your account?

Sorry, definitely my fault. https://ce.wikipedia.org/wiki/Белхан:ГӀирсаш was set to English language. Which means that nobody can reproduce the problem.

@Umar: What is the language setting in your account?

The Chechen language. And I see the Russian letter Ж.

@Umar: Let me ask you another time: Please always structure your bug reports like this in the future:

  • Steps to reproduce
  • What you expect to see
  • What you actually see

I thought that the image above (F18085571) is what you expect to see. Obviously I was wrong. I don't speak Chechen. Having to guess what exactly is asked for in a bug report is not a good use of time.

This task has seven comments now. Still it is only you who knows which exact letter you expect to see, if Ж does not exist in Chechen language.

Aklapper renamed this task from Chechen Wikipedia only uses localized WikiEditor toolbar buttons when explicitly passing uselang=ce to No localized Chechen letter for WikiEditor toolbar buttons is provided in Chechen Wikipedia.May 9 2018, 4:54 PM
Aklapper changed the task status from Stalled to Open.

I suppose the expected behavior is an icon like this:
(this is a screenshot of WikiEditor toolbar with uselang=ce before it started using OOUI, at b0a5d572d1a4785ac520d0969ea1cf9bbb9a6523)

image.png (68×580 px, 15 KB)

The custom icon for Chechen was previously added in rEWED38d28d5631d0: Add format-bold-Iab image for lang ce per T119716.

I think it's better to make one letter. Like all wikis
https://commons.wikimedia.org/wiki/File:Toolbaricon_bold_I.png

@Umar: Please confirm that you have read and understood T194211#4194581 and that you will follow T194211#4194581 in the future. Thank you.

The requested glyph would appears to be "Ӏ" which is CYRILLIC LETTER PALOCHKA (U+04C0).

We use sans-serif fonts for icons, but there appears to be an exception for italic-i, presumably because a sans-serif I is just not recognisable out of context.

Change 435819 had a related patch set uploaded (by Esanders; owner: Esanders):
[oojs/ui@master] Add bold icon for Chechen language

https://gerrit.wikimedia.org/r/435819

The requested glyph would appears to be "Ӏ" which is CYRILLIC LETTER PALOCHKA (U+04C0).

We use sans-serif fonts for icons, but there appears to be an exception for italic-i, presumably because a sans-serif I is just not recognisable out of context.

Just use the Latin capital I instead of the palochka. It does not matter. Unfortunately, on the letter, a significant number of Chechens use the figure 1 in general.

Change 435819 merged by jenkins-bot:
[oojs/ui@master] Add bold icon for Chechen language

https://gerrit.wikimedia.org/r/435819

This change has been merged and is included in OOUI v0.27.1, which will be included in MediaWiki 1.32.0-wmf.7, which will be deployed to Wikimedia wikis next week, 5-7 May (per the usual schedule).

For reference, this is the icon we used:

Deskana assigned this task to Esanders.
Deskana triaged this task as Medium priority.
Vvjjkkii renamed this task from No localized Chechen letter for WikiEditor toolbar buttons is provided in Chechen Wikipedia to kcdaaaaaaa.Jul 1 2018, 1:11 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii removed Esanders as the assignee of this task.
Vvjjkkii raised the priority of this task from Medium to High.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed the point value for this task.
Vvjjkkii removed subscribers: gerritbot, Aklapper.
CommunityTechBot renamed this task from kcdaaaaaaa to No localized Chechen letter for WikiEditor toolbar buttons is provided in Chechen Wikipedia.Jul 1 2018, 4:17 PM
CommunityTechBot closed this task as Resolved.
CommunityTechBot assigned this task to Esanders.
CommunityTechBot lowered the priority of this task from High to Medium.
CommunityTechBot set the point value for this task to 1.
CommunityTechBot updated the task description. (Show Details)