Enable $wgUseRCPatrol on azwiki
Closed, ResolvedPublic

Description

As per this community consensus , installation of the FlaggedRevs extension is requested for azwiki.

There are a very large number of changes, so older changes are hidden. Show Older Changes
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 10 2018, 12:21 PM
Neriman2003 updated the task description. (Show Details)May 10 2018, 12:22 PM
Neriman2003 updated the task description. (Show Details)
Neriman2003 updated the task description. (Show Details)
Reedy added a subscriber: Reedy.

I'm not sure if we're installing FlaggedRevs on wikis now...

Also, what configuration do you want it in?

How can we download it?

I'm not sure if we're installing FlaggedRevs on wikis now...

No we ain't. T143886#2586658.

Reedy changed the task status from Open to Stalled.May 10 2018, 12:34 PM
Reedy removed a project: Wikimedia-Site-requests.

How can we install it?

Stryn added a subscriber: Stryn.May 10 2018, 3:58 PM

Patrol system

Maybe Patrol System is another thing? I think the patrolling system is related to wgUseRCPatrol, Which Enable Mark as Patrol.

Stryn added a comment.May 10 2018, 4:59 PM

They mean the Flagged Revision extension. They just opened a new voting at https://az.wikipedia.org/wiki/Vikipediya:K%C9%99nd_meydan%C4%B1#Patrul but as Samral says there they already have gained consensus in 2016. (also https://meta.wikimedia.org/wiki/Requests_for_comment/Flagged_revisions_deployment#Request_from_Azerbaijani_wikipedia).

Yeah. Patrol system --> wgUseRCPatrol,

Jayprakash12345 renamed this task from İnstall FlaggedRevs extension on azwiki to Enable $wgUseRCPatrol on azwiki.May 11 2018, 11:19 AM
Jayprakash12345 changed the task status from Stalled to Open.
Jayprakash12345 removed Neriman2003 as the assignee of this task.
Jayprakash12345 removed a subscriber: Jayprakash12345.

For clarify: Do you want to turn patrolling edits (wgUseRCPatrol) OR the extension that is used on some wikis and probably won't be tured on on additional wikis anymore?

revi removed a subscriber: revi.May 12 2018, 6:00 PM
Neriman2003 added a comment.EditedMay 16 2018, 3:08 PM

@Urbanecm, @Reedy Yes, we want patrolling edits (wgUseRCPatrol)

Restricted Application added a project: User-Urbanecm. · View Herald TranscriptMay 16 2018, 7:32 PM

Change 433440 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[operations/mediawiki-config@master] Enable $wgUseRCPatrol on azwiki

https://gerrit.wikimedia.org/r/433440

Urbanecm triaged this task as Normal priority.May 16 2018, 7:33 PM
Urbanecm moved this task from Backlog to To deploy - SWAT necessary on the User-Urbanecm board.
Urbanecm moved this task from Config - to process to To deploy on the Wikimedia-Site-requests board.

Hello, I scheduled the patch(es) above for deployment and it will happen on Tuesday. It should happen between 13:00 and 14:00 UTC.

Change 433440 merged by jenkins-bot:
[operations/mediawiki-config@master] Enable $wgUseRCPatrol on azwiki

https://gerrit.wikimedia.org/r/433440

Mentioned in SAL (#wikimedia-operations) [2018-05-22T13:25:26Z] <addshore@tin> Synchronized wmf-config/InitialiseSettings.php: SWAT: [[gerrit:433440|Enable $wgUseRCPatrol on azwiki]] T194389 (duration: 01m 20s)

Deployed. All revisions as of now are not patrolled (even when the author has autopatrol). This just because the recent changes table wasn't rebuilded. If wanted, I can bot-patrol all revisions from autopatrolled by bot as I did for cs.wiki.

Undeployed, because of T195293. We are not sure what was the issue, if this or not, but it was done at the time when things broke - reverting is more safer than not reverting.

I'm marking this as stalled. No action should be performed when T195293 is open - we need to know what was the root cause of linked incident before deploying anything that can be possibly related.

Urbanecm changed the task status from Open to Stalled.Tue, May 22, 9:38 PM
Urbanecm changed the task status from Stalled to Open.Sat, May 26, 12:54 PM
Urbanecm added a subscriber: Addshore.

Reopening. I have green light from @Addshore because it probably isn't relevant to this patch nor any other SWAT patch.

Change 435628 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[operations/mediawiki-config@master] Revert "Revert "Enable $wgUseRCPatrol on azwiki""

https://gerrit.wikimedia.org/r/435628

So it will be opened soon?

I'm pretty sure we can do this in the week of May 28.

Change 435628 merged by jenkins-bot:
[operations/mediawiki-config@master] Revert "Revert "Enable $wgUseRCPatrol on azwiki""

https://gerrit.wikimedia.org/r/435628

Mentioned in SAL (#wikimedia-operations) [2018-05-28T13:40:33Z] <zfilipin@tin> Synchronized wmf-config/InitialiseSettings.php: SWAT: [[gerrit:435628|Revert "Revert "Enable $wgUseRCPatrol on azwiki"" (T194389)]] (duration: 01m 20s)

Urbanecm closed this task as Resolved.Mon, May 28, 2:03 PM

@Urbanecm Ready?

I'm not sure if I understand you fully. If you mean the scope of task, it was resolved => RCPatrol is enabled nowadays on azwiki and no futher action from sysadmins is necessary. If you mean something else, please ask with different words. Thanks!

@Urbanecm Ready?

Yes, Now Sysop can review edits and also they can see the red exclamation mark (!) in Special:RecentChanges

There is no patroller

See https://az.wikipedia.org/wiki/X%C3%BCsusi:ListGroupRights

Mark others' edits as patrolled (patrol) in Administrators Section

Only sysop is allowed to Patrol by Default. If Your Couummity want then We can create new user rights to patrol the edit like other wikis have with name patroller, reviewer etc.

Please create new user rights

@Neriman2003 If you are a sysop, then go https://az.wikipedia.org/wiki/Special:RecentChanges and Select unpatrolled in New Edit Filter. You will get all unpatrolled revisions. then open Diff of Revision and Click on the mark as Patrol.

@Jayprakash12345 Administrators can not give a status.

Get community consensus on new user rights at the local wiki and Create new Task here.

Your request was about enabling RCPatrol. This mean that those who can patrol now (administrators only) should be able to patrol individual edits. There is no right difference between patrolling edits, files or new pages. Everybody with "patrol" right can patrol anything. So, if you want to create new user group for patrolling, it must be approved by community voting/English summary of a discussion in local language written by a bureaucrat as @Jayprakash12345 say.

If you want to allow a new group to patrol edits and only edits, it is not possible and that request will be blocked on development (which can take years).

Thank you for understanding,

Martin Urbanec

@Neriman2003 Please fill a new task clearly describing what you want to have and somebody will have a look on it. Thanks!