Page MenuHomePhabricator

Ingenico We don't have an order status after doing a GET_ORDERSTATUS.
Closed, ResolvedPublic

Description

Result of the first 1-hour test. Some transactions reporting an error with the message 'We don't have an order status after doing a GET_ORDERSTATUS.'

Details

Related Gerrit Patches:
mediawiki/extensions/DonationInterface : masterHandle no status code for Ingenico api
mediawiki/extensions/DonationInterface : masterRefactor of ConfirmCreditCard to handle pending flag

Event Timeline

XenoRyet created this task.May 11 2018, 4:57 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 11 2018, 4:57 PM
XenoRyet removed XenoRyet as the assignee of this task.Jun 5 2018, 8:23 PM
mepps added a subscriber: mepps.Jun 12 2018, 7:30 PM

Hmm just beginning to look into this, but could it be that we're getting a different statuscode than globalcollect expects? I'll see if I can reproduce.

mepps added a comment.EditedJun 12 2018, 7:54 PM

So far I can't reproduce. I'll take a closer look at the logs.

mepps added a comment.Jun 13 2018, 3:08 PM

Hmm this is what I see, the curl response seems to be: {"status":"IN_PROGRESS"}, which is why we can't get a status out of it.

mepps added a comment.Jun 13 2018, 3:22 PM

Oh! So it looks like when a payment is in progress, there is no status code: https://epayments-api.developer-ingenico.com/s2sapi/v1/en_US/java/statuses.html. I'll need to add handling.

mepps claimed this task.Jun 14 2018, 3:22 PM

Change 440465 had a related patch set uploaded (by Mepps; owner: Mepps):
[mediawiki/extensions/DonationInterface@master] WIP: Handle no status code for Ingenico api

https://gerrit.wikimedia.org/r/440465

Vvjjkkii renamed this task from Ingenico We don't have an order status after doing a GET_ORDERSTATUS. to 23caaaaaaa.Jul 1 2018, 1:11 AM
Vvjjkkii removed mepps as the assignee of this task.
Vvjjkkii triaged this task as High priority.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed subscribers: gerritbot, Aklapper.
jgleeson renamed this task from 23caaaaaaa to Ingenico We don't have an order status after doing a GET_ORDERSTATUS..Jul 2 2018, 12:58 PM
jgleeson assigned this task to mepps.
jgleeson raised the priority of this task from High to Needs Triage.
jgleeson updated the task description. (Show Details)
jgleeson edited subscribers, added: Aklapper; removed: mepps.

Change 444311 had a related patch set uploaded (by Mepps; owner: Mepps):
[mediawiki/extensions/DonationInterface@master] WIP Refactor of ConfirmCreditCard

https://gerrit.wikimedia.org/r/444311

Ejegg moved this task from Backlog to Doing on the Fundraising Sprint Owls board.Jul 30 2018, 10:39 PM

Change 444311 merged by jenkins-bot:
[mediawiki/extensions/DonationInterface@master] Refactor of ConfirmCreditCard to handle pending flag

https://gerrit.wikimedia.org/r/444311

Change 440465 merged by jenkins-bot:
[mediawiki/extensions/DonationInterface@master] Handle no status code for Ingenico api

https://gerrit.wikimedia.org/r/440465

Ejegg closed this task as Resolved.Aug 22 2018, 1:05 AM
Ejegg triaged this task as Medium priority.
Ejegg moved this task from Backlog to Campaign ready on the Fr-Ingenico-integration_2017-18 board.