Page MenuHomePhabricator

Mass subscription attempt to a mailing list from same domain (aol and yahoo)
Closed, ResolvedPublic

Description

Hello,

For the past few days, I have had mass attempts to subscribe to one of the mailing lists (apg-grantees) for which I am an admin (around 100 last week, 261 this week) from apparently a bot trying to register aol.com or yahoo.com addresses. I have added regex to the subscription filters and made the list not public on the servers to try and fend off further attempts, but I thought I'd report it here in case this has been happening to others.
As far as I can see, deleting unwanted subscribers can only happen one at the time (I couldn't find, like for emais, a "discard all marked differ" button) so having to click 261 times on "discard" takes quite a bit of time.

Here is an extract of the subscribe list for info.

The apg-granteesATlists.wikimedia.org mailing list has 261 request(s)
waiting for your consideration at:

        https://lists.wikimedia.org/mailman/admindb/apg-grantees

Please attend to this at your earliest convenience.  This notice of
pending requests, if any, will be sent out daily.

Pending subscriptions:
    biobudweihyd1979@aol.com Fri May 11 08:55:34 2018
    elbrechesto1976@aol.com Fri May 11 08:56:52 2018
    emudbussign1972@aol.com Fri May 11 09:04:48 2018
    carsugeglea1980@aol.com Fri May 11 09:10:02 2018
    enefenoph1972@aol.com Fri May 11 09:29:05 2018
    hyfepati1972@aol.com Fri May 11 09:32:33 2018
    highlaventi1979@aol.com Fri May 11 09:41:18 2018
    capulmige1970@aol.com Fri May 11 09:41:33 2018
    miofacnechi1978@aol.com Fri May 11 09:44:52 2018
    rresmencrapenf1978@aol.com Fri May 11 10:03:40 2018
    harrisjonathan605@yahoo.com Fri May 11 10:52:05 2018
    jkevin397@yahoo.com Fri May 11 10:55:10 2018
    marylangdonqu893qu@yahoo.com Fri May 11 10:56:11 2018
    john.baskerville@yahoo.com Fri May 11 10:57:00 2018

If there is anything I can/should do that I haven't done, please advise.

Thanks!

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald Transcript

This is being discussed on the List admins mailing list and in non-public T194032.

herron claimed this task.
herron added a subscriber: herron.

Closing as duplicate of T194032

Vvjjkkii renamed this task from Mass subscription attempt to a mailing list from same domain (aol and yahoo) to u1caaaaaaa.Jul 1 2018, 1:10 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii removed herron as the assignee of this task.
Vvjjkkii triaged this task as High priority.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
CommunityTechBot renamed this task from u1caaaaaaa to Mass subscription attempt to a mailing list from same domain (aol and yahoo).Jul 2 2018, 4:15 PM
CommunityTechBot closed this task as Resolved.
CommunityTechBot assigned this task to herron.
CommunityTechBot raised the priority of this task from High to Needs Triage.
CommunityTechBot updated the task description. (Show Details)
CommunityTechBot added a subscriber: Aklapper.