Page MenuHomePhabricator

Undefined offset when given ​​other than 0 and 1 value for hide_tag_log parameter
Closed, ResolvedPublic

Description

Steps to reproduce:
Given ​​other than 0 and 1 value for hide_tag_log parameter on a log page. E.g. https://dev.razesoldier.cn/w/index.php?title=Special:Log&hide_tag_log=2, this page shows

PHP Notice:  Undefined offset: -1 in mediawiki/w/includes/logging/LogEventsList.php on line 185

Current version: 1.31.0-rc.0 (b05a169)

Related Objects

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 14 2018, 1:24 AM

Change 438244 had a related patch set (by Matěj Suchánek) published:
[mediawiki/core@master] Prevent "Undefined offset notice"

https://gerrit.wikimedia.org/r/438244

Krinkle added a subscriber: Krinkle.EditedJun 8 2018, 2:06 PM

@RazeSoldier Was there a link to "hide_tag_log=2" somewhere in the interface, or was this link manually created in the address bar?

If this is not an accident, then what is "2" supposed to do?

@RazeSoldier Was there a link to "hide_tag_log=2" somewhere in the interface, or was this link manually created in the address bar?

If this is not an accident, then what is "2" supposed to do?

In fact, my bug detector found this notice. So, generally speaking, this notice will not be triggered by user.

I don't know what the detection logic of my detector is because it is closed source. But I don't think there is a link to "hide_tag_log=2" on mediawiki.

Change 438244 merged by jenkins-bot:
[mediawiki/core@master] Prevent "Undefined offset notice"

https://gerrit.wikimedia.org/r/438244

matmarex closed this task as Resolved.Jun 29 2018, 7:37 PM
matmarex removed a project: Patch-For-Review.
Vvjjkkii renamed this task from Undefined offset when given ​​other than 0 and 1 value for hide_tag_log parameter to b1caaaaaaa.Jul 1 2018, 1:10 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii removed matej_suchanek as the assignee of this task.
Vvjjkkii triaged this task as High priority.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii edited subscribers, added: matej_suchanek; removed: gerritbot, Aklapper.
CommunityTechBot renamed this task from b1caaaaaaa to Undefined offset when given ​​other than 0 and 1 value for hide_tag_log parameter.Jul 2 2018, 4:14 PM
CommunityTechBot closed this task as Resolved.
CommunityTechBot assigned this task to matej_suchanek.
CommunityTechBot raised the priority of this task from High to Needs Triage.
CommunityTechBot updated the task description. (Show Details)
CommunityTechBot edited subscribers, added: gerritbot, Aklapper; removed: matej_suchanek.