Page MenuHomePhabricator

Info popups possibly overlap with upper-right personal toolbar
Closed, ResolvedPublic0 Story Points

Description

Steps to reproduce: Make your browser window very small. If there is not enough space at the bottom, the popups open to the top. Then the first 2 popups overlap with skin elements.

This might be an upstream OOUI bug, or simply a z-index missing.

See bug report here.

Event Timeline

Restricted Application added a project: TCB-Team. · View Herald TranscriptMay 15 2018, 2:20 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
thiemowmde triaged this task as Low priority.May 15 2018, 2:20 PM
thiemowmde added a project: good first bug.
Bmueller updated the task description. (Show Details)May 15 2018, 2:24 PM
matmarex added a subscriber: matmarex.

Setting a z-index will not help, because the Vector skin is constructed so that elements inside the content (.mw-body-content) can not obscure the skin interface elements (like the menus), because it creates a stacking context (with position: relative; z-index: 0;).

To avoid this, you should pass $overlay: true when constructing the FieldLayout, this way the popup is appended elsewhere in the DOM (under <body>) and will appear on top of everything else. See https://www.mediawiki.org/wiki/OOUI/Concepts#Overlays.

Please re-add OOUI if you find that there is a OOUI bug.

That's super helpful, @matmarex, thank you a lot!

kai.nissen set the point value for this task to 2.Jun 4 2018, 10:35 AM
kai.nissen changed the point value for this task from 2 to 1.
thiemowmde moved this task from Incoming to Advanced Search on the TCB-Team board.Jun 12 2018, 4:07 PM

Change 440538 had a related patch set uploaded (by Tonina Zhelyazkova; owner: Tonina Zhelyazkova):
[mediawiki/extensions/AdvancedSearch@master] Fix overlay in popups

https://gerrit.wikimedia.org/r/440538

Change 440538 merged by jenkins-bot:
[mediawiki/extensions/AdvancedSearch@master] Fix overlay in popups

https://gerrit.wikimedia.org/r/440538

Lea_WMDE changed the point value for this task from 1 to 0.

Moving this over so it can still be deployed :) And I realize now that I don't know where to test this, since Wmde-uca test is still down :/

Vvjjkkii renamed this task from Info popups possibly overlap with upper-right personal toolbar to 6wcaaaaaaa.Jul 1 2018, 1:09 AM
Vvjjkkii raised the priority of this task from Low to High.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed the point value for this task.
Vvjjkkii removed subscribers: gerritbot, Aklapper.
kai.nissen renamed this task from 6wcaaaaaaa to Info popups possibly overlap with upper-right personal toolbar.Jul 2 2018, 7:11 AM
kai.nissen lowered the priority of this task from High to Normal.
kai.nissen updated the task description. (Show Details)
kai.nissen added a subscriber: Aklapper.
Tobi_WMDE_SW set the point value for this task to 0.Jul 3 2018, 8:14 AM
Tobi_WMDE_SW added a subscriber: Tobi_WMDE_SW.

restoring

Lea_WMDE closed this task as Resolved.Jul 20 2018, 12:50 PM