Page MenuHomePhabricator

[testwiki-wmf.4] Maplink opened in a different tab shows double "mw-kartographer-buttonfoot" and "mw-kartographer-captionfoot" elements
Closed, ResolvedPublic

Description

The issue is present in Chrome64 and FF58.
Note: The issue happens only on the first load. Subsequent clicks on a maplink won's display double footer elements.

  1. On testwiki, insert a maplink, e.g.

<maplink text="maplink with lang=en" zoom=9 latitude=31.925 longitude=34.62 lang="en"></maplink>

  1. Right-click on the saved maplink to open it in a new tab - the map will open with footer elements displayed doubled.

Details

Related Gerrit Patches:
mediawiki/extensions/Kartographer : masterMake sure footer is created once

Event Timeline

Restricted Application added a project: Maps. · View Herald TranscriptMay 15 2018, 11:00 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Restricted Application added a project: Discovery. · View Herald TranscriptMay 15 2018, 11:01 PM

Change 437628 had a related patch set uploaded (by Mooeypoo; owner: Mooeypoo):
[mediawiki/extensions/Kartographer@master] Make sure footer is created once

https://gerrit.wikimedia.org/r/437628

Change 437628 merged by jenkins-bot:
[mediawiki/extensions/Kartographer@master] Make sure footer is created once

https://gerrit.wikimedia.org/r/437628

SBisson added a subscriber: SBisson.

This should be deployed to group 0 this afternoon and be testable on testwiki at https://test.wikipedia.org/w/index.php?title=User:JMatazzoni_(WMF)/maptest-basic#/maplink/0

I was not able to reproduce the issue locally or in betalabs. Note that the labs map instance is currently broken.

Etonkovidova closed this task as Resolved.Jun 12 2018, 10:32 PM

Checked the fix in testwiki (wmf.8).

Vvjjkkii renamed this task from [testwiki-wmf.4] Maplink opened in a different tab shows double "mw-kartographer-buttonfoot" and "mw-kartographer-captionfoot" elements to 4vcaaaaaaa.Jul 1 2018, 1:09 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii removed Mooeypoo as the assignee of this task.
Vvjjkkii triaged this task as High priority.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed subscribers: gerritbot, Aklapper.
CommunityTechBot renamed this task from 4vcaaaaaaa to [testwiki-wmf.4] Maplink opened in a different tab shows double "mw-kartographer-buttonfoot" and "mw-kartographer-captionfoot" elements.Jul 2 2018, 4:08 PM
CommunityTechBot closed this task as Resolved.
CommunityTechBot assigned this task to Mooeypoo.
CommunityTechBot raised the priority of this task from High to Needs Triage.
CommunityTechBot updated the task description. (Show Details)
CommunityTechBot added subscribers: gerritbot, Aklapper.