Page curation (rfd) creates an error message
Closed, ResolvedPublic

Description

The nomination for a redirect for discussion throws up this error message https://en.wikipedia.org/w/index.php?title=Fast_attack&oldid=841518850.

this happened 3 times today.

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 16 2018, 1:29 PM
Anomie added a subscriber: Anomie.

I see the edit summary says the edit was made with "Page Curation". As far as I can tell, PageTriage was never updated for the changes to enwiki's Template:Rfd that were made in 2014, so it's still prepending {{subst:rfd}} instead of wrapping the content as described at https://en.wikipedia.org/wiki/Template:Rfd#Usage.

Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptMay 16 2018, 2:08 PM

Ug, I doubt PageTriage even has a mechanism for wrapping content with a tag rather than prepending a tag.

I imagine the most practical way to solve this will be to create a new PageTriage-specific tag and have PageTriage use that instead of the rfd template.

ApiPageTriageTagging seems to have a "bottom" parameter in addition to the "top" parameter ext.pageTriage.delete.js already uses. If the JS were to pass {{subst:rfd|content= for "top" and }} for "bottom", that might do it.

I created a simple tag version at https://en.wikipedia.org/wiki/Template:Rfd-NPF. Will update the code shortly. Note that this is only a temporary fix and isn't ideal. In the long run, we should refactor the PageTriage tagging code to support wrapping content.

@Anomie: Unfortunately, PageTriage currently only handles passing entire template calls to the API, but your proposed solution sounds perfect for the real fix to this bug.

Change 436082 had a related patch set uploaded (by Kaldari; owner: Kaldari):
[mediawiki/extensions/PageTriage@master] Temporary fix for RfD template bug

https://gerrit.wikimedia.org/r/436082

+2'd, but to repeat what I said there: The live template appears to be in the hidden category https://en.wikipedia.org/wiki/Category:Redirects_for_discussion_from_May_2018

I'm assuming something needs to be wrapped in <includeonly> or what have you?

Change 436082 merged by jenkins-bot:
[mediawiki/extensions/PageTriage@master] Temporary fix for RfD template bug

https://gerrit.wikimedia.org/r/436082

@MusikAnimal: Thanks! Template fixed.

@kaldari It'd be great if Special:NewPagesfeed in betalabs worked as in production, so I filed a new phab task for betalabs - T196954: [betalabs]: Page triage: "Uncaught TypeError: Cannot read property 'getLogPageTitle' of undefined" for 'Redirects for discussion'

In betalabs using Special:NewPagesFeed 'Mark for deletion'->'Redirects for discussion' throws the following error (and the action never finishes on a page):

Uncaught TypeError: Cannot read property 'getLogPageTitle' of undefined
    at child.logPage 
    at Object.success
    at fire 
    at Object.fireWith [as resolveWith] 
    at done 
    at XMLHttpRequest
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptJun 11 2018, 9:08 PM
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptJun 12 2018, 6:07 PM
Vvjjkkii renamed this task from Page curation (rfd) creates an error message to hvcaaaaaaa.Jul 1 2018, 1:09 AM
Vvjjkkii triaged this task as High priority.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed subscribers: gerritbot, Aklapper.
CommunityTechBot raised the priority of this task from High to Needs Triage.
CommunityTechBot renamed this task from hvcaaaaaaa to Page curation (rfd) creates an error message.
CommunityTechBot added subscribers: gerritbot, Aklapper.
Restricted Application added a project: Growth-Team. · View Herald TranscriptOct 5 2018, 1:45 PM
SBisson moved this task from Incoming to QA on the Growth-Team (Current Sprint) board.
SBisson added a subscriber: SBisson.

@Etonkovidova Can this be closed?

@SBisson in testwiki I cannot 'Mark for deletion' with 'Redirect for discussion' option. The action never finishes and the Console displays the error (it could work differently in enwiki, of course):

logPage@https://test.wikipedia.org/w/load.php?debug=false&lang=en&modules=ext.pageTriage.defaultDeletionTagsOptions%2CdefaultTagsOptions%2Cexternal%2CexternalDeletionTagsOptions%2CexternalTagsOptions%2Cinit%2Cmessages%2Cmodels%2Cutil%7Cext.pageTriage.views.toolbar%7Cjquery.badge.external%7Cmediawiki.messagePoster%7Cmediawiki.template.underscore&skin=vector&version=19v7b7f:211:782
submit/<@https://test.wikipedia.org/w/load.php?debug=false&lang=en&modules=ext.pageTriage.defaultDeletionTagsOptions%2CdefaultTagsOptions%2Cexternal%2CexternalDeletionTagsOptions%2CexternalTagsOptions%2Cinit%2Cmessages%2Cmodels%2Cutil%7Cext.pageTriage.views.toolbar%7Cjquery.badge.external%7Cmediawiki.messagePoster%7Cmediawiki.template.underscore&skin=vector&version=19v7b7f:209:387
fire@https://test.wikipedia.org/w/load.php?debug=false&lang=en&modules=ext.centralNotice.choiceData%2CgeoIP%2CkvStoreMaintenance%2CstartUp%7Cext.centralauth.ForeignApi%7Cext.centralauth.centralautologin.clearcookie%7Cext.cx.campaigns…
 undefined

JTannerWMF moved this task from Inbox to To Triage on the Growth-Team board.
SBisson removed SBisson as the assignee of this task.Oct 31 2018, 6:21 PM

Looking at it in the debugger, specialDeletionTagging isn't a defined variable, so specialDeletionTagging[rfd].getLogPageTitle() in the example above doesn't work.

That's not what I see. Instead, specialDeletionTagging is defined, but tagObj.tag is set to 'rfd-NPF', and there's no such key in specialDeletionTagging.

Looks like this was directly caused by the previous fix for this bug, which changed rfd to rdf-NPF in ext.pageTriage.defaultDeletionTagsOptions.js without also updating specialDeletionTagging in ext.pageTriage.delete.js.

Change 473294 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/PageTriage@master] Unbreak RFD: use the same template name everywhere

https://gerrit.wikimedia.org/r/473294

Change 473294 merged by jenkins-bot:
[mediawiki/extensions/PageTriage@master] Unbreak RFD: use the same template name everywhere

https://gerrit.wikimedia.org/r/473294

Etonkovidova added a comment.EditedMon, Nov 26, 7:48 PM

Check in testwiki (wmf.6), 'Redirects for discussion' option throws "Log page for today has not been created yet!" Other deletion options seems to be fine.

@kaldari - any idea why the warning message is specific to 'Redirects for discussion' option?

Assuming that production behaves differently for RfD, closing the task.

Etonkovidova closed this task as Resolved.Tue, Nov 27, 9:55 PM