Page MenuHomePhabricator

test_datatypes and test_entities of paraminfo_tests.WikibaseKnownTypesTests class fails
Closed, ResolvedPublic

Description

https://travis-ci.org/wikimedia/pywikibot/jobs/380185665

tests/paraminfo_tests.py:53: in _check_param_superset
    self.assertGreaterEqual(set(expected), set(values))
E   AssertionError: 
{'url', 'quantity', 'external-id', 'math', 'wikibase-property', 'globe-coordinate', 'tabular-data', 'time', 'monolingualtext', 'geo-shape', 'wikibase-item', 'string', 'commonsMedia'}
not greater than or equal to 
{'url', 'quantity', 'external-id', 'math', "wikibase-form", 'wikibase-property', 'globe-coordinate', "wikibase-lexeme", 'tabular-data', 'monolingualtext', 'time', 'geo-shape', 'wikibase-item', 'string', 'commonsMedia'}
tests/paraminfo_tests.py:43: in _check_param_values
    self.assertCountEqual(expected, values)
E   AssertionError: Element counts were not equal:
E   First has 0, Second has 1:  'lexeme'
E   First has 0, Second has 1:  'form'

Event Timeline

Xqt created this task.May 17 2018, 4:00 PM
Restricted Application added subscribers: pywikibot-bugs-list, Aklapper. · View Herald TranscriptMay 17 2018, 4:00 PM
Xqt renamed this task from test_datatypes and test_entities of WikibaseKnownTypesTests class fails to test_datatypes and test_entities of paraminfo_tests.WikibaseKnownTypesTests class fails .May 17 2018, 4:01 PM
Dalba triaged this task as High priority.May 17 2018, 4:09 PM
Dalba added a comment.May 17 2018, 4:15 PM

Apparently the error only occures on test.wikidata.org job.

Xqt claimed this task.May 17 2018, 4:21 PM

Change 433602 had a related patch set uploaded (by Xqt; owner: Xqt):
[pywikibot/core@master] [bugfix] re-enable WikibaseKnownTypesTests

https://gerrit.wikimedia.org/r/433602

Change 433602 merged by jenkins-bot:
[pywikibot/core@master] [bugfix] re-enable WikibaseKnownTypesTests

https://gerrit.wikimedia.org/r/433602

Xqt closed this task as Resolved.May 18 2018, 10:23 AM
Xqt reopened this task as Open.May 23 2018, 2:42 PM
Xqt removed Xqt as the assignee of this task.

test_entities fails again for all tests on Travis but I cannot reproduce it locally for several sites :-(

tests/paraminfo_tests.py:235: 
_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ 
tests/paraminfo_tests.py:43: in _check_param_values
    self.assertCountEqual(expected, values)
tests/aspects.py:118: in assertCountEqual
    return self.assertItemsEqual(*args, **kwargs)
E   AssertionError: Element counts were not equal:
E   First has 0, Second has 1:  u'lexeme'
E   First has 0, Second has 1:  u'form'
=============================== warnings summary ===============================
JJMC89 added a subscriber: JJMC89.May 23 2018, 4:01 PM

Lexicographical data is now live outside the test sites. The previous patch only addressed the test sites.

if self.site.sitename in ('test:test', 'wikidata:test'):
    unsupported = ['form', 'lexeme']  # T194890
Xqt added a comment.EditedMay 23 2018, 4:16 PM

Lexicographical data is now live outside the test sites.

Yes. I should clear the cache bevor runnig the tests ;-)

jayvdb added a subscriber: jayvdb.May 24 2018, 2:43 AM

This can be closed?

I've created T195435 for the larger project of getting these entities types to work.

Dalba added a comment.May 24 2018, 3:30 AM

This can be closed?
I've created T195435 for the larger project of getting these entities types to work.

I think it would be better to have a more immediate solution for the test failures.

Change 434843 had a related patch set uploaded (by Dalba; owner: Dalba):
[pywikibot/core@master] paraminfo_tests.py: Add 'form' and 'lexeme' to unsupported types

https://gerrit.wikimedia.org/r/434843

Change 434843 merged by jenkins-bot:
[pywikibot/core@master] paraminfo_tests.py: Add 'form' and 'lexeme' to unsupported types

https://gerrit.wikimedia.org/r/434843

Xqt closed this task as Resolved.May 24 2018, 4:30 AM
Xqt claimed this task.
Xqt reassigned this task from Xqt to Dalba.
Vvjjkkii renamed this task from test_datatypes and test_entities of paraminfo_tests.WikibaseKnownTypesTests class fails to ptcaaaaaaa.Jul 1 2018, 1:09 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii removed Dalba as the assignee of this task.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed subscribers: gerritbot, Aklapper.
CommunityTechBot renamed this task from ptcaaaaaaa to test_datatypes and test_entities of paraminfo_tests.WikibaseKnownTypesTests class fails .Jul 2 2018, 6:39 AM
CommunityTechBot closed this task as Resolved.
CommunityTechBot assigned this task to Dalba.
CommunityTechBot updated the task description. (Show Details)
CommunityTechBot added subscribers: gerritbot, Aklapper.