Page MenuHomePhabricator

Release 5.8.2 (1421)
Closed, ResolvedPublic

Description

Release version: 5.8.2
Release tag: releases/5.8.2
Release SHA1: 4440503b2ae003a1d1f0875f7a7b35d84230b696
App Store Submission Date: 6/18/18
App Store Approval Date: 6/18/18
App Store Release Date: 6/19/18
Regression Testing URL: See subtask


  • Update contributors list
  • Update "Licenses" section (e.g. new libraries, fonts, images, etc.)
  • Verify Tweaks are disabled in build submitted to iTunesConnect via internal testing
  • Submit Beta on iTunes Connect for external testing review, and verify distribution
  • Submit RC on iTunes Connect for App Store review with automatic release disabled.
  • Notify TSG with RC build number
  • Post to mobile-l when Beta is approved for external testing
  • Install previous (active) App Store version, then update to release candidate via TestFlight and verify app load
  • Review Regression testing report, triage bugs, and identify any blockers
  • Release to App Store (NOT on a Friday!)
  • Update central mobile release history once released
  • Update version number in feedback email link
  • Post on mobile-l

Event Timeline

LGoto created this task.May 23 2018, 7:11 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 23 2018, 7:11 PM
JMinor triaged this task as High priority.May 25 2018, 9:20 PM
LGoto updated the task description. (Show Details)Jun 5 2018, 5:44 PM
LGoto updated the task description. (Show Details)Jun 5 2018, 6:13 PM
JoeWalsh updated the task description. (Show Details)Jun 5 2018, 6:30 PM
LGoto updated the task description. (Show Details)Jun 18 2018, 9:12 PM
LGoto renamed this task from Release 5.8.2 (x) to Release 5.8.2 (1421).Jun 18 2018, 9:20 PM
JMinor updated the task description. (Show Details)
JMinor added subscribers: NHarateh_WMF, JoeWalsh, JMinor.

@NHarateh_WMF or @JoeWalsh can you make the git tag for 1421? Thanks

JMinor updated the task description. (Show Details)Jun 21 2018, 9:56 PM
NHarateh_WMF added a comment.EditedJun 22 2018, 12:40 AM

@JMinor created releases/5.8.2, SHA is 4440503b2ae003a1d1f0875f7a7b35d84230b696

LGoto updated the task description. (Show Details)Jun 26 2018, 8:06 PM
LGoto added a comment.Jun 26 2018, 8:11 PM

@NHarateh_WMF shouldn't the tag be 5.8.2?

@LGoto Yes, thank you! It's releases/5.8.2, I created the right tag but made a mistake in the comment above 😬 edited now, thank you for pointing it out!

LGoto added a comment.Jun 26 2018, 9:45 PM

@NHarateh_WMF Thanks, looks like that's the last bit for this one!

LGoto closed this task as Resolved.Jun 26 2018, 9:45 PM
LGoto claimed this task.
LGoto updated the task description. (Show Details)
Vvjjkkii renamed this task from Release 5.8.2 (1421) to kfcaaaaaaa.Jul 1 2018, 1:08 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii removed LGoto as the assignee of this task.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
CommunityTechBot renamed this task from kfcaaaaaaa to Release 5.8.2 (1421).Jul 2 2018, 1:33 PM
CommunityTechBot closed this task as Resolved.
CommunityTechBot assigned this task to LGoto.
CommunityTechBot updated the task description. (Show Details)
CommunityTechBot added a subscriber: Aklapper.