Page MenuHomePhabricator

PHP version too low (5.5.9; says ""MediaWiki 1.32 needs PHP 7.0.0")
Closed, DuplicatePublic

Description

The PHP version on Toolforge may be a bit too low for some projects. See the below code snippet for details

tools.sau226test@tools-bastion-02:~/public_html/maintenance$ php update.php --quick
Error: You might be using an older PHP version (PHP 5.5.9-1ubuntu4.25).
MediaWiki 1.32 needs PHP 7.0.0 or higher or HHVM version 3.18.5.

Check if you have a newer php executable with a different name.


tools.sau226test@tools-bastion-02:~/public_html/maintenance$

Is there a newer version of PHP available under a different executable or will the version be upgraded in the future or stay constant?

Event Timeline

Sau226 created this task.May 25 2018, 11:40 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 25 2018, 11:40 AM
Reedy added a subscriber: Reedy.May 25 2018, 11:50 AM

Don't run master? ;)

REL1.31 does it too @Reedy :)

Paladox removed a subscriber: Paladox.May 25 2018, 12:04 PM
Aklapper renamed this task from PHP version too low to PHP version too low (5.5.9; says ""MediaWiki 1.32 needs PHP 7.0.0").May 25 2018, 6:12 PM
Vvjjkkii renamed this task from PHP version too low (5.5.9; says ""MediaWiki 1.32 needs PHP 7.0.0") to qacaaaaaaa.Jul 1 2018, 1:07 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii triaged this task as High priority.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
CommunityTechBot renamed this task from qacaaaaaaa to PHP version too low (5.5.9; says ""MediaWiki 1.32 needs PHP 7.0.0").Jul 2 2018, 3:47 PM
CommunityTechBot closed this task as a duplicate.
CommunityTechBot raised the priority of this task from High to Needs Triage.
CommunityTechBot updated the task description. (Show Details)
CommunityTechBot added a subscriber: Aklapper.