Page MenuHomePhabricator

Enable the ability to add a signature whilst using Visual Editor on Meta in userspace
Closed, DeclinedPublic

Description

This would be extremely useful when working on pages that require signatures but also use VE, e.g photo essay pages for Wiki Loves competitions.

https://meta.wikimedia.org/wiki/User:John_Cummings/Photo_essays/tester

I'm assuming there is a reason for this to be dissabled but there doesn't seem to be a place to discuss this on Meta.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 25 2018, 2:14 PM
Aklapper changed the task status from Open to Stalled.May 25 2018, 6:04 PM

Is this about "Insert > Your Signature"? If so, this is displayed for me on https://meta.wikimedia.org/w/index.php?title=Help_talk:Editing&veaction=editsource
In general, clear steps to reproduce are welcome. See https://mediawiki.org/wiki/How_to_report_a_bug

Thanks @Aklapper

Hmm, it seems to be inconsistent across namespaces, its greyed out in Userspace, which is what I was testing it in, see https://meta.wikimedia.org/wiki/User:John_Cummings?veaction=edit

On which Wikimedia site which is not meta is the signature option offered in userspace?

On which Wikimedia site which is not meta is the signature option offered in userspace?

Sorry I miss-understood your message, I looked at all Wikimedia sites in English and it appears that none currently do, is there a technical reason this happens?

Aklapper changed the task status from Stalled to Open.

I looked at all Wikimedia sites in English and it appears that none currently do, is there a technical reason this happens?

Best background info I can find seems to be T53154: VisualEditor: Provide a tool to insert a talk signature in namespaces that need it. Not sure that's helpful though.

Restricted Application added a project: VisualEditor. · View Herald TranscriptMay 27 2018, 10:15 PM

Signatures are only enabled on certain namespaces. People don't leave messages on user pages, so the user namespace is not enabled by default.

Deskana renamed this task from Enable the ability to add a signature whilst using Visual Editor on Meta to Enable the ability to add a signature whilst using Visual Editor on Meta in userspace.May 28 2018, 11:01 AM
Deskana added a subscriber: Deskana.

I've renamed this task to more accurately reflect the state of things.

Deskana closed this task as Declined.May 28 2018, 11:06 AM

Per @Esanders, this is intended functionality. Users are generally not recommended to insert signatures into pages in the user space, so the button isn't shown there. If you want users to be able to insert signatures using the button in the visual editor, you should probably reevaluate the namespace you've chosen to put your page in. (In your case, it looks like it's a test page in user space, which is obviously sensible, and that you're intending to move it into a namespace where signatures are used, which will effectively resolve your problem.)

Per @Esanders, this is intended functionality. Users are generally not recommended to insert signatures into pages in the user space, so the button isn't shown there. If you want users to be able to insert signatures using the button in the visual editor, you should probably reevaluate the namespace you've chosen to put your page in. (In your case, it looks like it's a test page in user space, which is obviously sensible, and that you're intending to move it into a namespace where signatures are used, which will effectively resolve your problem.)

Thanks for the clear explanation :)

Vvjjkkii renamed this task from Enable the ability to add a signature whilst using Visual Editor on Meta in userspace to bacaaaaaaa.Jul 1 2018, 1:08 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii triaged this task as High priority.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
CommunityTechBot raised the priority of this task from High to Needs Triage.
CommunityTechBot closed this task as Declined.
CommunityTechBot renamed this task from bacaaaaaaa to Enable the ability to add a signature whilst using Visual Editor on Meta in userspace.
CommunityTechBot added a subscriber: Aklapper.