Page MenuHomePhabricator

Edit conflict in Wikidata Lexeme when adding a reference after editing a form
Closed, ResolvedPublic

Description

Adding a reference to a Wikidata lexeme statement may result in a edit conflict. This may be after editing a form. Reloading the page will resolve the problem.

Related Objects

Event Timeline

Fnielsen created this task.May 25 2018, 4:43 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 25 2018, 4:43 PM
Fnielsen renamed this task from Edit conflict in Wikidata Lexeme when adding a reference after editing a form statement to Edit conflict in Wikidata Lexeme when adding a reference after editing a form.May 25 2018, 4:47 PM
Fnielsen updated the task description. (Show Details)

This may or may not be the same as T182102. Can you try to reproduce and give information on where you added the statement and in which order? Was the reference on the same statement or a different one?

Lydia_Pintscher triaged this task as High priority.May 27 2018, 5:56 PM

After https://www.wikidata.org/w/index.php?title=Lexeme:L1234&diff=686190332&oldid=686190168

I try to add a reference-URL property value and get an error. I would have expected that it went through.

I can add the reference URL after a reload of the page: https://www.wikidata.org/w/index.php?title=Lexeme:L1234&diff=686191117&oldid=686190332

It doesn't "feel" like T182102 to me.

Vvjjkkii renamed this task from Edit conflict in Wikidata Lexeme when adding a reference after editing a form to t9baaaaaaa.Jul 1 2018, 1:07 AM
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
Greta_Doci_WMDE renamed this task from t9baaaaaaa to Edit conflict in Wikidata Lexeme when adding a reference after editing a form.Jul 2 2018, 8:03 AM
Greta_Doci_WMDE updated the task description. (Show Details)
Greta_Doci_WMDE added a subscriber: Aklapper.

I tested this in different browsers and no error was shown. I created a new statement with a reference and was publish ok, i edited a form and then tried to add a reference in a statement and was ok. Unless I skipped any step, this looks ok now. @Fnielsen can you please tell me when exactly the error happens, when you type/paste the reference value, or when you click Publish? Can you please test it again to see if it works for you too?

I cannot reproduce it now. Perhaps it has been solved. These edits went though alright: https://www.wikidata.org/w/index.php?title=Lexeme%3AL1234&type=revision&diff=705379362&oldid=705379136

Lydia_Pintscher closed this task as Resolved.Jul 2 2018, 3:13 PM
Lydia_Pintscher claimed this task.

Thanks for testing. In this case let's close it and please reopen if it happens again.