Page MenuHomePhabricator

Option to Turn Off Status Updates in Phabricator Task-Threads
Closed, DeclinedPublic

Description

Related upstream task: https://secure.phabricator.com/T12963 ("Aggregate similar stories in Feed, Notifications and Timelines")

This post is about updates that appear in the middle of the thread, for example:

Johnywhy renamed this task from Request: Allow passing a MediaWiki parameter in the internal link syntax to Request: Allow passing MediaWiki parameters in the internal link syntax. Sat, May 26, 10:30 PM

Johnywhy updated the task description. (Show Details)

I often revise and improve my posts.

@AKlapper commented:

Would you please prepare task description changes locally and once done add them here in one edit, to not create gazillions of "Johnywhy updated the task description. (Show Details)" entries which make the discussion in this task harder to read because of all the required scrolling?"

But it's not practical to draft my changes offline, because I always want the public version to be the latest and greatest.

These status updates are INCREDIBLY ANNOYING, serve no great function relative how much they interrupt the thread, and make the thread harder to read. Actual comments get buried in the status updates.

If the purpose is to indicate to reader “did this post change since the last time i viewed the page”, that could be communicated with a simple visual flag. In addition, the timestamp of the last edit could be displayed, with a link to switch to (or expand) the full history. In other words, the same method on Phabricator's own discussion forum:

In the meantime, people can hide those updates by adding the following to your own phabricator css:

.phui-timeline-minor-event, .phui-timeline-spacer{
display:none;
}

I use a google chrome browser extension to apply CSS to phabricator.
https://chrome.google.com/webstore/detail/css-and-javascript-inject/ckddknfdmcemedlmmebildepcmneakaa

Event Timeline

Johnywhy created this task.May 28 2018, 2:02 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 28 2018, 2:02 AM
Johnywhy updated the task description. (Show Details)May 28 2018, 2:15 AM
Johnywhy updated the task description. (Show Details)May 28 2018, 2:20 AM
Aklapper triaged this task as Lowest priority.EditedMay 28 2018, 6:41 AM
Aklapper edited projects, added Phabricator (Upstream); removed Phabricator.

I neither expect upstream developers to implement this nor Wikimedia to maintain some custom patch so I'm afraid that obfuscating a task's changelog won't happen.

Restricted Application added a project: Upstream. · View Herald TranscriptMay 28 2018, 6:41 AM

I neither expect upstream developers to implement this

Because?

If you decline this task, then don't complain about it, as you did.

Aklapper added a comment.EditedMay 28 2018, 10:07 AM

@Johnywhy: Please check your tone here. No need to shoot the messenger.

Because?

Because that is my understanding of upstream development's priorities. See https://secure.phabricator.com/book/phabcontrib/article/feature_requests/ and especially the "Understanding the Upstream" section. You are free to request such a feature in upstream.

If you decline this task, then don't complain about it, as you did.

I did not "complain"; I kindly asked you to consider a different workflow. Not every potential problem that is based on human behavior needs a technical solution.

Johnywhy added a comment.EditedMay 28 2018, 10:25 AM

Your "human problem"-- excessive status messages-- is the byproduct of my preferred workflow. That preferred workflow is a benefit for me.

Excessive status messages are caused by technology. This is technology that we're using, and its design causes a human problem for you, while providing a benefit to me.

You're asking me to throw out a benefit to myself for your convenience. You're asking me to change my flow due to a flaw in this user-interface. You're asking me to endure more effort, and to prevent readers from having access to my latest version, so that you won't have to see status updates. You're asking me to not use the technology as it's designed to be used.

That's inappropriate. Making the technology work better for BOTH of us is a better fix. If you don't like the way the technology works, change the technology.

For example, if the purpose is to indicate to reader "did this post change since the last time i viewed the page", that could be communicated with a simple visual flag. In addition, the timestamp of the last edit could be displayed, with a link to switch to (or expand) the full history.

Putting status updates someplace besides the comment flow doesn't "obscure" history, anymore than wiki page history is "obscured" by putting it in a separate view (as MediaWiki does), instead of cluttering wikipages with change updates.

Currently, status update messages on Phabricator obscure actual comments, as you observed. I think it's an uncommon, and awkward, design for discussion software.

If a poster tried to obscure their own changes from other readers, that would be obfuscation. But that's not what's being suggested here. If a reader applies my CSS, above, to hide other people's status updates, that is not obfuscation.

See https://secure.phabricator.com/book/phabcontrib/article/feature_requests/ and especially the "Understanding the Upstream" section. You are free to request such a feature in upstream.

They mention paying customers. I assume MediaWiki is a paying customer of phacility. Correct? As such, i suggest you or MediaWiki submit a feature request to phacility for less-obtrusive status updates, rather than asking me to stop using the software as it's designed.

I've submitted a request to Phacility. Have you?
https://discourse.phabricator-community.org/t/request-less-obtrusive-status-updates/1530

discourse.phabricator-community.org uses the very same status-update that i suggested above for phabricator:

Aklapper removed a subscriber: Aklapper.May 29 2018, 9:28 AM

I've submitted a request to Phacility.

Thanks for that!

Have you?

I did not and do not plan to, as everyone can request whatever they'd like to upstream.

@Johnywhy: Please do not re-subscribe me to a task after I have unsubscribed myself from a task. Thanks.

Please do not re-subscribe me to a task after I have unsubscribed myself from a task.

I didn't. However, if I quote your comment, then apparently Phabricator re-subscribes you. Not my fault. That's another case of you asking me to go out of my way, and perform extra manual effort for your convenience. Again you're asking me not to use the software as it's designed. Your options are: ask Phabricator devs to remove that behavior. And/or remove your comments so no one can quote them.

Johnywhy updated the task description. (Show Details)May 29 2018, 1:39 PM
Aklapper removed a subscriber: Aklapper.May 29 2018, 2:52 PM

Please stop CC'ing me by quoting my name. Thanks.

In T195728#4239408, Aklapper wrote:

Please stop CC'ing me by quoting my name. Thanks.

the thread you linked states:
Quoting or otherwise mentioning another user in a comment might be more common, but task editing is more important and users shouldn't be scared of improving tasks for the fear of stalking unwilling users.

[[ https://phabricator.wikimedia.org/T76993 | This thread ]]states:
We've only seen negative feedback about this behavior from one install, but use it frequently on this install and believe it is a useful feature overall, even if it isn't always perfect. As a general rule, we don't make upstream changes which only benefit one install. But if this feature is unusually disruptive on your install, the cost of maintaining that patch might be smaller than the cost of having the feature.

it's unclear what the status of this behavior is, but it sounds like it not going to be changed.
i removed the @ when i mentioned AKlapper, hopefully that will help.

Johnywhy added a subscriber: Aklapper.EditedMay 30 2018, 7:33 AM

@Aklapper, Phabricator Support informed me:

Aklapper can now Mute the conversation, which should stop this. Also, since he’d removed himself from the subscribers, it shouldn’t auto-add him on mentions.

https://discourse.phabricator-community.org/t/request-less-obtrusive-status-updates/1530/4?u=johnywhy

Therefore, there's no need to ask me to stop mentioning you. Just mute it. Although, according to Phabricator Support, you shouldn't even have to mute it. They say, above, once you remove yourself, mentions should not re-subscribe you.

If that doesn't work as described by Phabricator Support, please let them know at the thread I linked.

Thx

Aklapper updated the task description. (Show Details)May 31 2018, 6:16 PM
Aklapper moved this task from Backlog to Reported Upstream on the Upstream board.
Aklapper removed a subscriber: Aklapper.Jun 1 2018, 10:49 AM

They say, above, once you remove yourself, mentions should not re-subscribe you.

@Johnywhy: That is unfortunately incorrect. Again: Please do not re-subscribe me to this task. Thanks.

Johnywhy added a subscriber: Aklapper.EditedJun 2 2018, 12:05 AM

I tried to unsubscribe you just now, but it appears i don't have that power. Sorry about that.

Tried to unsubscribe you by removing the mention, but doubt that will work either. Sorry about that.

Aklapper closed this task as Declined.Jun 2 2018, 11:41 AM
Aklapper updated the task description. (Show Details)

No plans to implement an option to turn off status updates in task threads (which is what is requested in this task), hence reflecting reality and declining this task.

If at all, an upstream fix for https://secure.phabricator.com/T12963 would provide a different approach ("Aggregate similar stories in Feed, Notifications and Timelines").

Vvjjkkii renamed this task from Option to Turn Off Status Updates in Phabricator Task-Threads to f6baaaaaaa.Jul 1 2018, 1:07 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii raised the priority of this task from Lowest to High.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
CommunityTechBot renamed this task from f6baaaaaaa to Option to Turn Off Status Updates in Phabricator Task-Threads.Jul 2 2018, 7:29 AM
CommunityTechBot closed this task as Declined.
CommunityTechBot lowered the priority of this task from High to Lowest.
CommunityTechBot updated the task description. (Show Details)
CommunityTechBot added a subscriber: Aklapper.