Page MenuHomePhabricator

Regression: Links containing "action" always show the editor on mobile version regardless of value
Closed, ResolvedPublic1 Story Points

Description

At itwiki village pump it was pointed out that mobile version has some troubles with links containing the "action" parameters. Let's take as example the village pump page itself (mobile version). If you manually go to https://it.m.wikipedia.org/wiki/Wikipedia:Officina?action=edit, the usual editor pops up for a second and is then overlapped by a new editor which only contains the header of the page (everything that comes before the first section). Or, if you go to https://it.m.wikipedia.org/wiki/Wikipedia:Officina?action=purge, the window for purging the page is shown for a second and then the same partial editor comes out. This makes "action" completely unuseful for mobile users.

Event Timeline

Daimona created this task.Jun 1 2018, 10:20 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 1 2018, 10:20 AM
Jhernandez moved this task from Needs triage to Triaged on the Mobile board.Jun 4 2018, 10:51 AM
Jdlrobson added a subscriber: Jdlrobson.

This seems like a regression. This used to work fine.
Not sure if editing code outside MobileFrontend is causing this so tagging VisualEditor until we know the root cause

Yeah, VE is quite likely involved in this bug. I also tried to test this bug on my local wiki, but I actually surrendered due to Parsoid requirement for VE. Anyway, with MF alone it seems to work fine.

@DLynch I'm not sure 100% sure, but T185729 (I2275b011d2b3c03462e3c1711d3135ce672596e8) looks a little suspect

Jdlrobson renamed this task from Links containing "action=xxx" always show the editor on mobile version to Regression: Links containing "action" always show the editor on mobile version regardless of value.Jun 4 2018, 2:48 PM
ovasileva triaged this task as Normal priority.Jun 4 2018, 2:53 PM
DLynch claimed this task.Jun 4 2018, 3:18 PM

Change 437271 had a related patch set uploaded (by DLynch; owner: DLynch):
[mediawiki/skins/MinervaNeue@master] Fix action!=edit opening the editor

https://gerrit.wikimedia.org/r/437271

Change 437271 merged by jenkins-bot:
[mediawiki/skins/MinervaNeue@master] Fix action!=edit opening the editor

https://gerrit.wikimedia.org/r/437271

Fixed on beta cluster. However, I see that for action=edit the same things happen. Is this an intended behaviour? If the user goes to an "action=edit" link, wouldn't he expect to be editing the whole page instead of the first section?

DLynch added a comment.Jun 4 2018, 4:31 PM

@Daimona: I'm not opposed here, but the MobileFrontend currently only does section-editing. The mimic'd behavior here is as-if you had visited the page and then clicked the edit button at the very top of the page. (I think this is quite confusing even without this action=edit behavior, naturally.)

@DLynch thanks, got it :-) We'll wait for a major change to MF, then

Ignazio added a subscriber: Ignazio.EditedJun 7 2018, 9:46 PM

"action=edit" allowed to edit a complete page. Why now not? It's a huge limit for the MobileFrontend.

Deskana closed this task as Resolved.Jun 11 2018, 3:07 PM
Deskana added a subscriber: Deskana.

This issue is fixed. Any requests about changing the behaviour of MobileFrontend's handling of section editing should go in a different task.

Jdlrobson reopened this task as Open.Jun 11 2018, 3:25 PM

"action=edit" allowed to edit a complete page. Why now not? It's a huge limit for the MobileFrontend.

@Deskana i agree with this. This used to be the case yo make the editor resilient to js errors/power editors but the change from @DLynch seems to have disabled it. Conmit message says "Make ?veaction=edit/editsource and ?action=edit trigger the appropriate mobile
editing mode." Could you explain the reasoning behind this change? I often use the fallback for certain power editor task. The mobile editor and fallback editor should not be interchangeable in the same way as visual editor is
.

Jdlrobson closed this task as Resolved.Jun 11 2018, 3:30 PM

Whoops didnt mean to reopen it but i do think that @Ignazio needs a a reply!

I've made T196915 for the edit-a-full-page issue.

Jdforrester-WMF set the point value for this task to 1.Jun 13 2018, 6:26 PM
Vvjjkkii renamed this task from Regression: Links containing "action" always show the editor on mobile version regardless of value to pubaaaaaaa.Jul 1 2018, 1:06 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii removed DLynch as the assignee of this task.
Vvjjkkii raised the priority of this task from Normal to High.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed the point value for this task.
Vvjjkkii removed subscribers: gerritbot, Aklapper.
Daimona renamed this task from pubaaaaaaa to Regression: Links containing "action" always show the editor on mobile version regardless of value.Jul 1 2018, 12:29 PM
Daimona closed this task as Resolved.
Daimona assigned this task to DLynch.
Daimona lowered the priority of this task from High to Normal.
Daimona updated the task description. (Show Details)
Daimona set the point value for this task to 1.
Daimona added subscribers: gerritbot, Aklapper.

Change 453181 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[mediawiki/skins/MinervaNeue@master] Drop issues on editor

https://gerrit.wikimedia.org/r/453181

Change 453181 merged by jenkins-bot:
[mediawiki/skins/MinervaNeue@master] Drop issues on editor

https://gerrit.wikimedia.org/r/453181