Page MenuHomePhabricator

New Pages Feed: draft addition
Closed, ResolvedPublic

Description

Parent task for the New Pages Feed work to add draft pages to the feed, filter them by AfC state, and sort them by AfC submitted date.

Adding drafts to the feed is one of three major work items for T193782. Please see that epic or this task's subtasks for more information.

In terms of rollout, we will want to release together those subtasks that are named with 1* [e.g. New Pages Feed: filter to draft states (1.2)]. The second release can include those subtasks that are named with 2* [e.g. New Pages Feed: submitted date sorting option for drafts (2)].

Related Objects

StatusAssignedTask
ResolvedMMiller_WMF
ResolvedMMiller_WMF
ResolvedSamwilson
ResolvedMooeypoo
ResolvedSBisson
ResolvedMusikAnimal
ResolvedMusikAnimal
ResolvedSBisson
ResolvedSBisson
ResolvedSBisson
ResolvedMMiller_WMF
ResolvedSBisson
ResolvedSamwilson
ResolvedSamwilson
ResolvedMusikAnimal
ResolvedMusikAnimal
DeclinedNone
ResolvedSamwilson
ResolvedMusikAnimal
ResolvedSBisson
DuplicateNone
ResolvedSBisson
Resolvedkostajh
ResolvedEtonkovidova
ResolvedCatrope
ResolvedSBisson
ResolvedSBisson

Event Timeline

MMiller_WMF updated the task description. (Show Details)Jun 1 2018, 5:38 PM

@MusikAnimal @Samwilson -- I just went through the current build on CommTech wiki and noted a set of issues, listed below, with gifs for some. These are in addition to the known issues that you sent to me:

  • When I select certain combinations of checkbox filters in the New Page Patrol "Set filters" menu, they don't always stick and affect the list. In the gif below, I am trying to uncheck the "Unreviewed pages" option, but it won't stay unchecked.

  • When I select "All" as the state for "Articles for Creation", nothing happens to the list. It shows some subset of the drafts. See gif below.

  • For one of the drafts, the gray preview of the draft's content in the list differs from the actual content of the draft. In the gif below, the preview says, "A declined draft." But when I open the page, the draft says, "This draft is being reviewed now."

  • When a draft has conflicting categories on it, it's unclear which state the feed will put it in. For instance, this draft has both the declined and pending categories. The feed puts it in state "Awaiting review" but not also in state "Declined". Though this edge case should not occur, it is possible. My preferred business logic is that the feed lists it in both states. What are our constraints here?
  • We should remove the "Category" and "Orphan" metadata listed next to each draft, since those are not relevant.
MusikAnimal added a comment.EditedJun 21 2018, 7:46 PM

Thanks for the thorough testing!

When I select certain combinations of checkbox filters in the New Page Patrol "Set filters" menu, they don't always stick and affect the list. In the gif below, I am trying to uncheck the "Unreviewed pages" option, but it won't stay unchecked.

Confirmed regression :(

When I select "All" as the state for "Articles for Creation", nothing happens to the list. It shows some subset of the drafts. See gif below.

I think this was due to data corruption after we changed the code. I can't repro now. Let me know if you can!

For one of the drafts, the gray preview of the draft's content in the list differs from the actual content of the draft. In the gif below, the preview says, "A declined draft." But when I open the page, the draft says, "This draft is being reviewed now."

Confirmed. The snippet for drafts are not updated, but they are for mainspace pages. Baffling!

When a draft has conflicting categories on it, it's unclear which state the feed will put it in. For instance, this draft has both the declined and pending categories. The feed puts it in state "Awaiting review" but not also in state "Declined". Though this edge case should not occur, it is possible. My preferred business logic is that the feed lists it in both states. What are our constraints here?

Only one value can be stored for the state, so we go in order: 1) Unsubmitted 2) Pending 3) Under review 4) Declined. Whichever one it finds first, in that order, is the state that gets assigned. One would have to manually add the second category for this to happen in production, or (maybe) add a second template. Both scenarios should be very rare. The reviewers will have to fix it.

We should remove the "Category" and "Orphan" metadata listed next to each draft, since those are not relevant.

Done!

All of the above bugs should now be fixed! :)

There is one oddity -- sometimes when switching from AfC to NPP, your old NPP filters are forgotten. I don't think this is a huge deal, but I'll still try to fix it.

@MusikAnimal @Samwilson -- I retested everything, and I confirm that all the bugs I listed are fixed. I have one new one:

The "total unreviewed pages" number at the bottom of the feed isn't right. The two screenshots below show it disagreeing with the list for both NPP and AfC settings.


This seems to be because of the caching. The 'unreviewed' stats at the bottom there are cached for 10 minutes (and nothing refreshes the cache when an item is updated, I guess by design?).

We have CACHE_NONE in /vagrant/mediawiki/LocalSettings.php, but I wonder if there's another part of the Vagrant config that's turning the cache on? (Sorry, I'm not completely familiar with how things are set up there.)

Anyway, I can't see anything else that could be doing this, and the numbers are all correct in my testing (on local, and on commtech after waiting ten minutes).

Vvjjkkii renamed this task from New Pages Feed: draft addition to ytbaaaaaaa.Jul 1 2018, 1:06 AM
Vvjjkkii triaged this task as High priority.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
CommunityTechBot raised the priority of this task from High to Needs Triage.
CommunityTechBot renamed this task from ytbaaaaaaa to New Pages Feed: draft addition.
CommunityTechBot added a subscriber: Aklapper.
Niharika removed a subscriber: Niharika.Aug 6 2018, 5:11 PM

@MMiller_WMF Should this ticket now be transferred to the Growth team board?

Niharika added a subscriber: Niharika.

@MMiller_WMF Should this ticket now be transferred to the Growth team board?

I'll be bold and move it.

Niharika removed a subscriber: Niharika.Aug 17 2018, 5:41 PM

Thanks, @Niharika -- I'm sorry I missed this.

Niharika removed a subscriber: Niharika.Aug 17 2018, 7:32 PM

No problem!

JTannerWMF moved this task from Q1 2018-19 to FY 2019-20 on the Growth-Team board.Sep 26 2018, 5:55 PM
MMiller_WMF closed this task as Resolved.Oct 1 2018, 8:48 PM
MMiller_WMF claimed this task.

We have deployed all this work to English Wikipedia and announced that it is available for AfC reviewers here. I am resolving this task.

MaxSem removed a subscriber: MaxSem.Oct 1 2018, 8:54 PM