Page MenuHomePhabricator

Allow for autoconfirmed users to use globally blacklisted links as references
Closed, DeclinedPublic

Description

Allow for globally blacklisted links to be used by users that are autoconfirmed if the links are between "<ref>" and "</ref>" tags, a lot of good useful educational links are globally blacklisted because either one user or a spambot didn't use them as was seen fit by the maintainers, and requests to have links removed by good faith users are usually ignored or rejected. As most spambots usually only add links to "External links" sections and rarely do edits other than what they're intended for it might be wiser to let other users link to reliable sources, there is no reason why content should fall the victim to blacklisting and links should be inspected on a case-by-case basis and not have reliable sources removed and replaced by "{{Citation needed}}" tags purely because a link was being misused on another page by another user (as verifiability should always be seen as more important).

Event Timeline

DonTrung created this task.Jun 3 2018, 8:47 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 3 2018, 8:47 AM

I assume that "globally blacklisted links" refers to the list at https://meta.wikimedia.org/wiki/Spam_blacklist linked from https://meta.wikimedia.org/wiki/Blacklists

Legoktm closed this task as Declined.Jun 3 2018, 7:07 PM
Legoktm added a subscriber: Legoktm.

A related task might be T36928: Create a user right that allows ignoring the spam blacklist, but that doesn't seem like it is going to be implemented either.

Vvjjkkii renamed this task from Allow for autoconfirmed users to use globally blacklisted links as references to orbaaaaaaa.Jul 1 2018, 1:06 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii triaged this task as High priority.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
CommunityTechBot raised the priority of this task from High to Needs Triage.
CommunityTechBot closed this task as Declined.
CommunityTechBot renamed this task from orbaaaaaaa to Allow for autoconfirmed users to use globally blacklisted links as references.
CommunityTechBot added a subscriber: Aklapper.