Page MenuHomePhabricator

Rename reason not populated
Closed, ResolvedPublic

Description

Until last week, accepting GlobalRenameQueue requests automatically generated a log entry for Special:Log/gblrename. It's no longer creating one.


Timezone: Asia/Seoul

  • 09:16, 3 June 2018 TonyBallioni (talk | contribs | block) globally renamed CIULLO CORPORATION to Massimiliano Ciullo <= no reason, regression
  • 19:31, 20 April 2018 -revi (talk | contribs | block) globally renamed ATC Secretary to Theatrelover01 (per [[https://meta.wikimedia.org/wiki/Special:GlobalRenameQueue/request/42019|request]]) <= auto-populated "Per request". Before the regression.

This is causing serious inconvenience for the renamers. I suspect 599f6444cf200ef7ef929cec64d98560f1ca80a0 is the offending commit?

Event Timeline

revi created this task.Jun 3 2018, 10:53 AM
Restricted Application added a project: User-revi. · View Herald TranscriptJun 3 2018, 10:53 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
revi raised the priority of this task from Normal to High.Jun 3 2018, 10:54 AM
revi moved this task from Incoming to Radar on the User-revi board.
revi added a project: GlobalRename.
revi added a subscriber: Volker_E.Jun 3 2018, 10:58 AM
Trijnstel added a subscriber: Trijnstel.
Framawiki added a comment.EditedJun 3 2018, 1:30 PM

Found https://meta.wikimedia.org/wiki/MediaWiki:Gadget-renameQueueReason.js gadget, that is enabled by default for global renamers and stewards. This script is broken because it can't find the new "reason" input.
I've requested a temporary hotfix on https://meta.wikimedia.org/wiki/Meta:Requests_for_help_from_a_sysop_or_bureaucrat#MediaWiki:Gadget-renameQueueReason.js_needs_hotfix

See also this hold change that implement it in the extension but that still need help: https://gerrit.wikimedia.org/r/#/c/197944/

I suspect 599f6444cf200ef7ef929cec64d98560f1ca80a0 is the offending commit?

I don't think so, Commit only changed way of viewing. Name, Id, value is same as before. Thanks :)

revi added a comment.Jun 3 2018, 3:30 PM

That is the only patch affecting Special:GlobalRenameQueue/request/. And 2018-05-05 patch had no effect on our workflow.

Found https://meta.wikimedia.org/wiki/MediaWiki:Gadget-renameQueueReason.js gadget, that is enabled by default for global renamers and stewards. This script is broken because it can't find the new "reason" input.
I've requested a temporary hotfix on https://meta.wikimedia.org/wiki/Meta:Requests_for_help_from_a_sysop_or_bureaucrat#MediaWiki:Gadget-renameQueueReason.js_needs_hotfix
See also this hold change that implement it in the extension but that still need help: https://gerrit.wikimedia.org/r/#/c/197944/

Billinghurst fixed the gadget and it seems to be solved now?? https://meta.wikimedia.org/w/index.php?title=MediaWiki%3AGadget-renameQueueReason.js&type=revision&diff=18100669&oldid=12022426

Jayprakash12345 raised the priority of this task from High to Needs Triage.Jun 4 2018, 9:58 AM
Framawiki closed this task as Resolved.Jun 4 2018, 6:27 PM
Framawiki claimed this task.

I've created T196397: Pre-fill reason field with a link to the rename request for the long-term implementation in the extension.

This ticket was about meta gadget that was broken. This problem is solved, so let's close it.

Vvjjkkii renamed this task from Rename reason not populated to frbaaaaaaa.Jul 1 2018, 1:06 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii removed Framawiki as the assignee of this task.
Vvjjkkii triaged this task as High priority.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
CommunityTechBot renamed this task from frbaaaaaaa to Rename reason not populated.Jul 2 2018, 12:42 AM
CommunityTechBot closed this task as Resolved.
CommunityTechBot assigned this task to Framawiki.
CommunityTechBot raised the priority of this task from High to Needs Triage.
CommunityTechBot updated the task description. (Show Details)
CommunityTechBot added a subscriber: Aklapper.
MarcoAurelio moved this task from Backlog to Closed on the GlobalRename board.Sep 1 2018, 12:15 PM