Page MenuHomePhabricator

Add support for "it" pronouns in MW preferences ("It edits wiki pages")
Closed, DuplicatePublic

Description

I have recently decided to use "it" pronouns (because they're the only option (other than singular "they") that isn't an unnatural-sounding neologism), but the MW software only provides "he", "she", and singular "they" as choices. Of course, it would be easier to add an "advanced" option that provides HTML forms for the subject, object, possessive determiner, possessive, and "-self" pronouns. Same goes for Phabricator.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 4 2018, 11:39 PM
Reedy added a subscriber: Reedy.Jun 5 2018, 12:01 AM

Same goes for Phabricator.

Needs completely separate tasks filing, and then one filing with upstream at Phabricator

See (and discuss in) T61643: Provide further options than only binary gender for providing more than 3 options. I've closed this task as a duplicate of T61643.

Vvjjkkii renamed this task from Add support for "it" pronouns in MW preferences ("It edits wiki pages") to 6mbaaaaaaa.Jul 1 2018, 1:05 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii triaged this task as High priority.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
CommunityTechBot renamed this task from 6mbaaaaaaa to Add support for "it" pronouns in MW preferences ("It edits wiki pages").Jul 1 2018, 9:42 PM
CommunityTechBot closed this task as a duplicate.
CommunityTechBot raised the priority of this task from High to Needs Triage.
CommunityTechBot updated the task description. (Show Details)
CommunityTechBot added a subscriber: Aklapper.