Page MenuHomePhabricator

EventStreams are currently producing output in bursts of many items instead of real time
Closed, DeclinedPublic

Description

It seems to me that EventStreams are buffering the changes made on wikis and then send them like each 5 seconds in a huge burst of modifications, instead of showing them in a real time.

Is there any reason for this? It makes it very hard to watch the real time stream as there is always nothing for couple of seconds and then suddenly hundreds of changes in milisecond and then nothing again.

Event Timeline

Petrb created this task.Jun 5 2018, 2:36 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 5 2018, 2:36 PM
Vvjjkkii renamed this task from EventStreams are currently producing output in bursts of many items instead of real time to tlbaaaaaaa.Jul 1 2018, 1:05 AM
Vvjjkkii triaged this task as High priority.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
CommunityTechBot renamed this task from tlbaaaaaaa to EventStreams are currently producing output in bursts of many items instead of real time.Jul 1 2018, 8:48 PM
CommunityTechBot raised the priority of this task from High to Needs Triage.
CommunityTechBot updated the task description. (Show Details)
CommunityTechBot added a subscriber: Aklapper.
Ottomata closed this task as Declined.Tue, Nov 19, 3:11 PM
Ottomata added a subscriber: Ottomata.

I can't reproduce this, is it still happening?

I'm closing, but feel free to reopen.