Create user rights on azwiki
Closed, ResolvedPublic

Description

Hi! Please create new user rights and special pages on azwiki. User rights: patroller, autopatroller and etc. Special pages: Special:Unreviewed pages, Special:Oldreviewed pages, Special:Reviewed pages

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptTue, Jun 5, 5:45 PM

Hi @Neriman2003, thanks for reporting this.
Do you plan to work on this yourself? If not, please remove yourself as assignee.
Also, please see https://meta.wikimedia.org/wiki/Requesting_wiki_configuration_changes for information required.
Removing MediaWiki-extensions-FlaggedRevs as this is unrelated to the general code base of that MediaWiki extension and is instead about the configuration of Wikimedia servers.

Urbanecm removed Neriman2003 as the assignee of this task.EditedTue, Jun 5, 6:12 PM

@Aklapper: I'm emptying the Assigned To field, because I asked for this task on another task - so I presume this is up to others.

@Neriman2003: As Aklapper said, it is a need to clearly name what you want to be added. We really cannot read your mind ;). Thanks!

@Aklapper : Hi. I'm sysop in azwikipedia. Now Patrol system is working in azwiki but only sysops can patrol. We want to give patrol rights to some users as a patroller. You can check the voting in our local wiki. Please let me know what need we do anymore for creating new user group for patrolling in our wiki. Thanks in advance.

Urbanecm claimed this task.Wed, Jun 6, 12:50 PM
Urbanecm triaged this task as Normal priority.

Ok, I finally understood you.

Restricted Application added a project: User-Urbanecm. · View Herald TranscriptWed, Jun 6, 12:50 PM

Change 437777 had a related patch set uploaded (by Sau226; owner: sau226):
[operations/mediawiki-config@master] Implementing Patroller User Rights for azwiki

https://gerrit.wikimedia.org/r/437777

Sau226 added a subscriber: Sau226.EditedWed, Jun 6, 3:32 PM

I've made a change that will hopefully let you have the user group activated. It still needs to be approved by system administrators and put on the server but that should happen inside a week. Hopefully @Urbanecm or someone else will help you make this change live. I honestly have no idea on that process

@Sau226 : Great thanks for your support.

Will do that, thanks!

@Sau226: Just to extend your knowledge, the process is as follows:

Configuration changes are deployed in SWAT windows. Those windows happens 3 times a workday but Tuesday (2 windows) and Friday (no window). The always up to date calendar is at https://wikitech.wikimedia.org/wiki/Deployments. There might be some exceptions, for example, a network maintenance work might take the SWAT's place. This doesn't happen very often, but can happen.

If you want to have a config change deployed in SWAT window, you must schedule it for some SWAT window at the Deployments page at wikitech under your IRC nickname (or under IRC nickname of somebody else, provided you have their permission for such scheduling). The window you use depends on you, usually based on your location. For exact syntax, look at some other SWAT window that was used and adapt it :). There is no formal rule saying that the patch author must be the one who schedules the patch for a SWAT, so there's no problem with me scheduling your change for a SWAT. The only rule is that each SWAT window cannot be used for deploying more than 6 patches _together_.

During the window, you should be present in #wikimedia-operations on freenode. On the start of the window, a bot will ping you and announce start of the window. Soonly after, a SWAT deployer will say something like "I can SWAT today". The SWAT deployer will ping you as soon as your patch will be deployed. To minimalize the risc, changes can (and usually are) deployed at test servers first. You can connect to the test servers via the process described on https://wikitech.wikimedia.org/wiki/X-Wikimedia-Debug#Browser_extensions. Basically, it's just a browser extension. The deployer will choose the test server and push the changes to the test servers first. Then, you will be asked to test the changes. After successful testing, you will confirm it is working as intended and the SWAT deployer will push the changes to production. As soon as all of your patches are deployed, you can quit the IRC channel.

If you want to take care about your change yourself, please feel free to schedule it. Otherwise, please just comment here, I will schedule it. As I said, I just wanted to explain the process to you.

Best,
Martin

PS: I've reviewed your commit, please amend it according to my review. Thanks!

Thanks for support!

Sau226 added a comment.EditedThu, Jun 7, 9:09 AM

@Urbanecm I'm afraid my timezone is incompatible with the deploy windows. I will therefore ask that you help me take care of it. I have seen your review and have edited the patch accordingly.

P.S: Thank you everyone for giving me the chance to have my first "big" commit deployed

Thank you. The commit looks good now. I will schedule it with my other
patches, probably in the week of June 11.

Hi all. İs there any update? Please give me information about this task?
Thanks in advance.

Hello, it is waiting on deployment. I need to schedule it for some window. I have other patches to deploy (more than 12) and some patches has higher priority than this one. I hope I can deploy it in this week, but I'm absolutely not sure. High priority should be solved before this (normal priority) and this before other tasks that has low/lowest priority, I hope you can understand :).

@Urbanecm : Of course understood :) Thanks a lot for information.

I've scheduled it for upcoming deployment window. Unfortunately, it will be deployed at the end of the window, so if some bad thing happen, it can be skipped and scheduled for other window. I try to schedule patches based on their priority, as explained above. Thank you for being so patient.

Change 437777 merged by jenkins-bot:
[operations/mediawiki-config@master] Implementing Patroller User Rights for azwiki

https://gerrit.wikimedia.org/r/437777

Mentioned in SAL (#wikimedia-operations) [2018-06-13T14:00:38Z] <zfilipin@deploy1001> Synchronized wmf-config/InitialiseSettings.php: SWAT: [[gerrit:437777|Implementing Patroller User Rights for azwiki (T196488)]] (duration: 00m 57s)

Urbanecm closed this task as Resolved.Wed, Jun 13, 2:02 PM
Urbanecm reassigned this task from Urbanecm to Sau226.

Sucessfully deployed. Please check and if anything should be broken, please reopen and comment. I or somebody else will fix this. Pro formo reassigning to @Sau226, the actual patch uploader. Thank you for your work, @Sau226!

Eldarado reopened this task as Open.Wed, Jun 13, 2:23 PM

@Urbanecm and @Sau226 : Thank you so much for your works, but there is a some problems. 1. User groups (patrul and avtopatrul) was added but administrators can't give this status to users. Could you please fix this?

  1. FlaggedRevs system is not working like "ruviki" and "trviki". We also want the edits will publish after patrull's check. How can we fix this?

Thanks in advance

Change 440163 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[operations/mediawiki-config@master] Allow sysops to grant autopatrolled and patroller on azwiki

https://gerrit.wikimedia.org/r/440163

Change 440163 merged by jenkins-bot:
[operations/mediawiki-config@master] Allow sysops to grant autopatrolled and patroller on azwiki

https://gerrit.wikimedia.org/r/440163

Mentioned in SAL (#wikimedia-operations) [2018-06-13T18:20:48Z] <twentyafterfour@deploy1001> Synchronized wmf-config/InitialiseSettings.php: SWAT: sync 5b47244 14ca2ba 63bc100m and 2569a77 refs T196488, T196744, T196727, T196763 (duration: 00m 57s)

Urbanecm closed this task as Resolved.Wed, Jun 13, 6:27 PM

Deployed. Should anything be broken, please reopen&comment.

In fact. azwiki do not have flaggedrevs. It has the ordinary patrol (so not blocking to displaying). FlaggedRevs request will be declined, it is not going to be deploy to futher wikis, because it is expensive to configure and other reasons, see https://meta.wikimedia.org/wiki/Flagged_Revisions#Enabling.