Page MenuHomePhabricator

Page Preview should not strip space before period
Closed, ResolvedPublic

Description

API:
https://en.wikipedia.org/api/rest_v1/page/summary/.NET_Foundation

{"type":"standard","title":".NET Foundation","displaytitle":".NET Foundation","namespace":{"id":0,"text":""},"titles":{"canonical":".NET_Foundation","normalized":".NET Foundation","display":".NET Foundation"},"pageid":46762138,"lang":"en","dir":"ltr","revision":"787437872","tid":"ab0506f5-4895-11e8-8c29-681bb1fdb7b8","timestamp":"2017-06-25T12:09:23Z","description":"organization to improve open-source development around the .NET framework","content_urls":{"desktop":{"page":"https://en.wikipedia.org/wiki/.NET_Foundation","revisions":"https://en.wikipedia.org/wiki/.NET_Foundation?action=history","edit":"https://en.wikipedia.org/wiki/.NET_Foundation?action=edit","talk":"https://en.wikipedia.org/wiki/Talk:.NET_Foundation"},"mobile":{"page":"https://en.m.wikipedia.org/wiki/.NET_Foundation","revisions":"https://en.m.wikipedia.org/wiki/Special:History/.NET_Foundation","edit":"https://en.m.wikipedia.org/wiki/.NET_Foundation?action=edit","talk":"https://en.m.wikipedia.org/wiki/Talk:.NET_Foundation"}},"api_urls":{"summary":"https://en.wikipedia.org/api/rest_v1/page/summary/.NET_Foundation","metadata":"https://en.wikipedia.org/api/rest_v1/page/metadata/.NET_Foundation","references":"https://en.wikipedia.org/api/rest_v1/page/references/.NET_Foundation","media":"https://en.wikipedia.org/api/rest_v1/page/media/.NET_Foundation","edit_html":"https://en.wikipedia.org/api/rest_v1/page/html/.NET_Foundation","talk_page_html":"https://en.wikipedia.org/api/rest_v1/page/html/Talk:.NET_Foundation"},"extract":"The .NET Foundation is an independent organization, incorporated on March 31, 2014, by Microsoft, to improve open-source software development and collaboration around the.NET Framework. It was launched at the annual Build 2014 conference held by Microsoft. The foundation is license-agnostic, and projects that come to the foundation are free to choose any open-source license, as defined by the Open Source Initiative (OSI). The foundation uses GitHub to host the open-source projects it manages.","extract_html":"<p>The <b>.NET Foundation</b> is an independent organization, incorporated on March 31, 2014, by Microsoft, to improve open-source software development and collaboration around the.NET Framework. It was launched at the annual Build 2014 conference held by Microsoft. The foundation is license-agnostic, and projects that come to the foundation are free to choose any open-source license, as defined by the Open Source Initiative (OSI). The foundation uses GitHub to host the open-source projects it manages.</p>"}

Event Timeline

Krinkle created this task.Jun 6 2018, 2:09 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Krinkle moved this task from Backlog to Summary on the Page Content Service board.Jun 6 2018, 2:11 AM
bearND triaged this task as Normal priority.Jun 6 2018, 2:28 PM
bearND moved this task from Needs triage to Kanban on the Reading-Infrastructure-Team-Backlog board.
MSantos claimed this task.Jun 28 2018, 2:09 PM
MSantos moved this task from To Do to Doing on the Reading-Infrastructure-Team-Backlog (Kanban) board.

Change 443087 had a related patch set uploaded (by MSantos; owner: MSantos):
[mediawiki/services/mobileapps@master] [POC] Summary: Don't strip space before period

https://gerrit.wikimedia.org/r/443087

Change 443088 had a related patch set uploaded (by MSantos; owner: MSantos):
[mediawiki/services/mobileapps@master] Summary: Don't strip space before period

https://gerrit.wikimedia.org/r/443088

This comment was removed by MSantos.

Change 443088 abandoned by MSantos:
Summary: Don't strip space before period

Reason:
Commit shouldn't be pushed before the test. It was supposed to be an alternative to https://gerrit.wikimedia.org/r/443087, but it has to be discarded.

https://gerrit.wikimedia.org/r/443088

Vvjjkkii renamed this task from Page Preview should not strip space before period to ckbaaaaaaa.Jul 1 2018, 1:05 AM
Vvjjkkii removed MSantos as the assignee of this task.
Vvjjkkii raised the priority of this task from Normal to High.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii edited subscribers, added: MSantos; removed: gerritbot, Aklapper.
Krinkle renamed this task from ckbaaaaaaa to Page Preview should not strip space before period.Jul 1 2018, 11:59 PM
Krinkle assigned this task to MSantos.
Krinkle updated the task description. (Show Details)
CommunityTechBot lowered the priority of this task from High to Normal.Jul 5 2018, 6:58 PM

Change 443087 merged by jenkins-bot:
[mediawiki/services/mobileapps@master] Summary: Don't strip space before period

https://gerrit.wikimedia.org/r/443087

Stashbot added a subscriber: Stashbot.

Mentioned in SAL (#wikimedia-operations) [2018-07-11T20:16:33Z] <bsitzmann@deploy1001> Started deploy [mobileapps/deploy@03fa731]: Update mobileapps to b5e152d (T195325 T189830 T177619 T196523)

Mentioned in SAL (#wikimedia-operations) [2018-07-11T20:20:04Z] <bsitzmann@deploy1001> Finished deploy [mobileapps/deploy@03fa731]: Update mobileapps to b5e152d (T195325 T189830 T177619 T196523) (duration: 03m 30s)

Mentioned in SAL (#wikimedia-operations) [2018-07-11T22:18:16Z] <bsitzmann@deploy1001> Started deploy [mobileapps/deploy@03fa731]: Update mobileapps to b5e152d (T195325 T189830 T177619 T196523)

Mentioned in SAL (#wikimedia-operations) [2018-07-11T22:25:00Z] <bsitzmann@deploy1001> Finished deploy [mobileapps/deploy@03fa731]: Update mobileapps to b5e152d (T195325 T189830 T177619 T196523) (duration: 06m 44s)

Jhernandez added a subscriber: Jhernandez.EditedJul 12 2018, 11:41 AM
> curl -s https://en.wikipedia.org/api/rest_v1/page/summary/.NET_Foundation | jq .extract
"The .NET Foundation is an independent organization, incorporated on March 31, 2014, by Microsoft, to improve open-source software development and collaboration around the.NET Framework. It was launched at the annual Build 2014 conference held by Microsoft. The foundation is license-agnostic, and projects that come to the foundation are free to choose any open-source license, as defined by the Open Source Initiative (OSI). The foundation uses GitHub to host the open-source projects it manages."

Let me know when it can be verified in prod (see "the.NET Framework" there).

bearND added subscribers: Pchelolo, bearND.

@Pchelolo Hmm, I think there's something wrong with ChangeProp. I just ran the ?action=purge command and directly on the prod machines I get the new version 1.3.7,

bsitzmann@scb1001:/srv/deployment/mobileapps$ curl -sI localhost:8888/en.wikipedia.org/v1/page/summary/.NET_Foundation | grep Spec
Content-Type: application/json; charset=utf-8; profile="https://www.mediawiki.org/wiki/Specs/Summary/1.3.7"

The output looks correct directly on scb1001:

bsitzmann@scb1001:/srv/deployment/mobileapps$ curl -s localhost:8888/en.wikipedia.org/v1/page/summary/.NET_Foundation | jq .extract
"The .NET Foundation is an independent organization, incorporated on March 31, 2014, by Microsoft, to improve open-source software development and collaboration around the .NET Framework. It was launched at the annual Build 2014 conference held by Microsoft. The foundation is license-agnostic, and projects that come to the foundation are free to choose any open-source license, as defined by the Open Source Initiative (OSI). The foundation uses GitHub to host the open-source projects it manages."

but externally (through RB) I only get the old content:

curl -sI https://en.wikipedia.org/api/rest_v1/page/summary/.NET_Foundation | grep 'Specs'
content-type: application/json; charset=utf-8; profile="https://www.mediawiki.org/wiki/Specs/Summary/1.3.6"

@Jhernandez Looks like it's working now. I see 1.3.7 externally, too, now. Usually just running ?action=purge on the affected page or waiting for an edit or a transclusion update should fix it. I guess ChangeProp was still recovering from the outages and failing over.

Jhernandez closed this task as Resolved.Jul 13 2018, 3:57 PM

Cool! Thanks for checking Bernd. Confirmed fixed! 👍