Page MenuHomePhabricator

[TopLists] several Less ParseError
Closed, ResolvedPublic

Description

dummy change https://gerrit.wikimedia.org/r/#/c/437696/

When running tests for the TopLists extension:

There were 2 errors:

1) extensions/TopLists/resources/css/list.less in the "ext.toplists.list.styles" module
Less_Exception_Chunk: ParseError: Unexpected input in list.less on line 15, column 2
13| 
14| #toplists-loading-screen {
15|     @include blockInput;
16|     margin-top: -20px;
17|     padding-top: 90px;
18| }

vendor/oyejorge/less.php/lib/Less/Parser.php:677
vendor/oyejorge/less.php/lib/Less/Parser.php:621
vendor/oyejorge/less.php/lib/Less/Parser.php:498
includes/resourceloader/ResourceLoaderFileModule.php:985
tests/phpunit/LessFileCompilationTest.php:46
tests/phpunit/MediaWikiTestCase.php:423
maintenance/doMaintenance.php:94
2) extensions/TopLists/resources/css/editor.less in the "ext.toplists.editor.styles" module
Less_Exception_Chunk: ParseError: Unexpected input in editor.less on line 30, column 2
28| 
29| #toplists-loading-screen {
30|     @include blockInput;
31| }
32| 
33| #toplist-editor {

vendor/oyejorge/less.php/lib/Less/Parser.php:677
vendor/oyejorge/less.php/lib/Less/Parser.php:621
vendor/oyejorge/less.php/lib/Less/Parser.php:498
includes/resourceloader/ResourceLoaderFileModule.php:985
tests/phpunit/LessFileCompilationTest.php:46
tests/phpunit/MediaWikiTestCase.php:423
maintenance/doMaintenance.php:94
There was 1 warning:

1) Warning
The data provider specified for ResourcesTest::testFileExistence is invalid.
ParseError: Unexpected input in list.less on line 15, column 2
13| 
14| #toplists-loading-screen {
15|     @include blockInput;
16|     margin-top: -20px;
17|     padding-top: 90px;
18| }

maintenance/doMaintenance.php:94

Event Timeline

hashar created this task.Jun 6 2018, 9:41 AM
Restricted Application added a project: Social-Tools. · View Herald TranscriptJun 6 2018, 9:41 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
hashar added a comment.Jun 6 2018, 9:49 AM

It does not seem to work? I am tempted to just archive the TopLists extension.

ashley added a comment.Jun 8 2018, 9:54 PM

TopLists has been and is a work-in-progress that's just...not being worked on very actively. It's an old Wikia extension which needs quite a bit of love if we are to ever make it functional again. This task is more or less of a duplicate of T158377: Properly convert SCSS to LESS code in TopLists; the biggest roadblock in making TopLists great again is T158390: TopLists has a hard dependency on ImageServing, which, the last time I looked into it, would've required either non-trivial core changes or a port of some kind of the ImageServing extension, and both of these options significantly increased the complexity of the project.

@SamanthaNguyen, what do you think about @hashar's suggestion above?

SamanthaNguyen closed this task as Invalid.Jun 9 2018, 12:15 AM

@hashar: Hey Hashar, thanks for creating this task. Me and ashley talked privately on IRC and agreed that we should archive the extension, so I'll take of creating that Cleanup task and completing the stuff on the checklist. :) Because of this, I'll close this task as invalid.

hashar added a comment.Jun 9 2018, 5:29 AM

Thank you @ashley and @SamanthaNguyen . Note the archiving is not definitive, the extension can be restored at any time.

Vvjjkkii renamed this task from [TopLists] several Less ParseError to 0jbaaaaaaa.Jul 1 2018, 1:05 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii triaged this task as High priority.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
MacFan4000 renamed this task from 0jbaaaaaaa to [TopLists] several Less ParseError.Jul 2 2018, 11:38 AM
MacFan4000 updated the task description. (Show Details)