Page MenuHomePhabricator

Unable to install Math as "mathoid" role on MediaWiki-Vagrant on labs
Open, NormalPublic

Description

Setting up with 'vagrant enable-role mathoid' instead of 'math' since that's broken now that texvc is removed from the Math extension...

Seems to fail building the native rsvg component of a node module?

brion@ogvjs-testing:/srv/mediawiki-vagrant$ vagrant up --provision
Bringing machine 'default' up with 'lxc' provider...
==> default: Checking if box 'debian/stretch64' is up to date...
==> default: Starting container...
==> default: Waiting for machine to boot. This may take a few minutes...
    default: SSH address: 10.0.3.228:22
    default: SSH username: vagrant
    default: SSH auth method: private key
==> default: Machine booted and ready!
==> default: Forwarding ports...
==> default: 8080 (guest) => 8080 (host) (adapter eth0)
==> default: 443 (guest) => 4430 (host) (adapter eth0)
==> default: 10042 (guest) => 10042 (host) (adapter eth0)
==> default: Setting hostname...
==> default: Exporting NFS shared folders...
==> default: Preparing to edit /etc/exports. Administrator privileges will be required...
● nfs-server.service - NFS server and services
   Loaded: loaded (/lib/systemd/system/nfs-server.service; enabled; vendor preset: enabled)
   Active: active (exited) since Wed 2018-06-06 22:05:14 UTC; 1min 7s ago
  Process: 612 ExecStart=/usr/sbin/rpc.nfsd $RPCNFSDARGS (code=exited, status=0/SUCCESS)
  Process: 610 ExecStartPre=/usr/sbin/exportfs -r (code=exited, status=0/SUCCESS)
 Main PID: 612 (code=exited, status=0/SUCCESS)
    Tasks: 0 (limit: 4915)
   Memory: 0B
      CPU: 0
   CGroup: /system.slice/nfs-server.service
==> default: Mounting NFS shared folders...
==> default: Running provisioner: lsb_check...
==> default: Running provisioner: file_perms...
==> default: Running provisioner: shell...
    default: Running: /tmp/vagrant-shell20180606-1260-ghr3zt.sh
==> default: Running provisioner: puppet...
==> default: Running Puppet with environment vagrant...
==> default: Info: Loading facts
==> default: Notice: Compiled catalog for mediawikivagrant.mediawiki-vagrant.dev in environment vagrant in 3.09 seconds
==> default: Info: Applying configuration version '1528322789.d71e4aba'
==> default: Notice: /Stage[main]/Npm/Exec[npm_set_cache_dir]/returns: executed successfully
==> default: Notice: /Stage[main]/Packages::Librsvg2_dev/Package[librsvg2-dev]/ensure: created
==> default: Notice: /Stage[main]/Npm::Globals/Npm::Global[mocha]/Exec[npm_global_mocha]/returns: executed successfully
==> default: Notice: /Stage[main]/Npm::Globals/Npm::Global[grunt]/Exec[npm_global_grunt]/returns: executed successfully
==> default: Notice: /Stage[main]/Npm::Globals/Npm::Global[grunt-cli]/Exec[npm_global_grunt-cli]/returns: executed successfully
==> default: Notice: /Stage[main]/Npm::Globals/Npm::Global[node-gyp]/Exec[npm_global_node-gyp]/returns: executed successfully
==> default: Notice: /Stage[main]/Npm::Globals/Npm::Global[node-pre-gyp]/Exec[npm_global_node-pre-gyp]/returns: executed successfully
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/File[/vagrant/logs/mathoid.log]/ensure: created
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/File[/etc/logrotate.d/mathoid]/ensure: defined content as '{md5}033868b68ab709f6c084c192a5e57286'
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Git::Clone[mathoid]/File[/vagrant/srv/mathoid]/ensure: created
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Git::Clone[mathoid]/Exec[git_clone_mathoid]/returns: executed successfully
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/File[mathoid_config_yaml]/ensure: defined content as '{md5}dda351b8ff30039ee3f1aa6df63a7632'
==> default: Info: /Stage[main]/Mathoid/Service::Node[mathoid]/File[mathoid_config_yaml]: Scheduling refresh of Service[mathoid]
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: 
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: > librsvg@0.7.0 install /vagrant/srv/mathoid/node_modules/librsvg
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: > node-gyp rebuild
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: 
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: make: Entering directory '/vagrant/srv/mathoid/node_modules/librsvg/build'
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns:   CXX(target) Release/obj.target/rsvg/src/Rsvg.o
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns:   CXX(target) Release/obj.target/rsvg/src/Enums.o
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns:   CXX(target) Release/obj.target/rsvg/src/Autocrop.o
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns:   SOLINK_MODULE(target) Release/obj.target/rsvg.node
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns:   COPY Release/rsvg.node
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: cp: preserving permissions for ‘Release/rsvg.node’: Operation not permitted
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: rsvg.target.mk:165: recipe for target 'Release/rsvg.node' failed
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: make: *** [Release/rsvg.node] Error 1
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: make: Leaving directory '/vagrant/srv/mathoid/node_modules/librsvg/build'
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: gyp ERR! build error 
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: gyp ERR! stack Error: `make` failed with exit code: 2
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: gyp ERR! stack     at ChildProcess.onExit (/usr/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:285:23)
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: gyp ERR! stack     at emitTwo (events.js:106:13)
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: gyp ERR! stack     at ChildProcess.emit (events.js:191:7)
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:219:12)
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: gyp ERR! System Linux 4.9.0-6-amd64
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: gyp ERR! command "/usr/bin/node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: gyp ERR! cwd /vagrant/srv/mathoid/node_modules/librsvg
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: gyp ERR! node -v v6.14.2
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: gyp ERR! node-gyp -v v3.6.0
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: gyp ERR! not ok 
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: 
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: > dtrace-provider@0.8.7 install /vagrant/srv/mathoid/node_modules/bunyan/node_modules/dtrace-provider
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: > node-gyp rebuild || node suppress-error.js
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: 
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: make: Entering directory '/vagrant/srv/mathoid/node_modules/bunyan/node_modules/dtrace-provider/build'
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns:   TOUCH Release/obj.target/DTraceProviderStub.stamp
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: make: Leaving directory '/vagrant/srv/mathoid/node_modules/bunyan/node_modules/dtrace-provider/build'
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: npm WARN optional dep failed, continuing librsvg@0.7.0
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: 
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: > microtime@2.1.8 install /vagrant/srv/mathoid/node_modules/microtime
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: > prebuild-install || node-gyp rebuild
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: 
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: sh: 1: prebuild-install: not found
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: make: Entering directory '/vagrant/srv/mathoid/node_modules/microtime/build'
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns:   CXX(target) Release/obj.target/microtime/src/microtime.o
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns:   SOLINK_MODULE(target) Release/obj.target/microtime.node
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns:   COPY Release/microtime.node
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: cp: preserving permissions for ‘Release/microtime.node’: Operation not permitted
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: microtime.target.mk:132: recipe for target 'Release/microtime.node' failed
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: make: *** [Release/microtime.node] Error 1
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: make: Leaving directory '/vagrant/srv/mathoid/node_modules/microtime/build'
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: gyp ERR! build error 
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: gyp ERR! stack Error: `make` failed with exit code: 2
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: gyp ERR! stack     at ChildProcess.onExit (/usr/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:285:23)
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: gyp ERR! stack     at emitTwo (events.js:106:13)
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: gyp ERR! stack     at ChildProcess.emit (events.js:191:7)
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:219:12)
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: gyp ERR! System Linux 4.9.0-6-amd64
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: gyp ERR! command "/usr/bin/node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: gyp ERR! cwd /vagrant/srv/mathoid/node_modules/microtime
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: gyp ERR! node -v v6.14.2
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: gyp ERR! node-gyp -v v3.6.0
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: gyp ERR! not ok 
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: npm WARN deprecated kad-memstore@0.0.1: Please upgrade to @kadenceproject/kadence - See https://kadence.github.io
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: npm WARN deprecated kad-fs@0.0.4: Please upgrade to @kadenceproject/kadence - See https://kadence.github.io
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: npm ERR! Linux 4.9.0-6-amd64
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: npm ERR! argv "/usr/bin/node" "/usr/bin/npm" "install" "--no-bin-links"
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: npm ERR! node v6.14.2
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: npm ERR! npm  v2.15.12
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: npm ERR! code ELIFECYCLE
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: 
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: npm ERR! microtime@2.1.8 install: `prebuild-install || node-gyp rebuild`
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: npm ERR! Exit status 1
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: npm ERR! 
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: npm ERR! Failed at the microtime@2.1.8 install script 'prebuild-install || node-gyp rebuild'.
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: npm ERR! This is most likely a problem with the microtime package,
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: npm ERR! not with npm itself.
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: npm ERR! Tell the author that this fails on your system:
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: npm ERR!     prebuild-install || node-gyp rebuild
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: npm ERR! You can get information on how to open an issue for this project with:
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: npm ERR!     npm bugs microtime
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: npm ERR! Or if that isn't available, you can get their info via:
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: npm ERR! 
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: npm ERR!     npm owner ls microtime
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: npm ERR! There is likely additional logging output above.
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: 
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: npm ERR! Please include the following file with any support request:
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: npm ERR!     /vagrant/srv/mathoid/npm-debug.log
==> default: Error: /usr/bin/npm install --no-bin-links returned 1 instead of one of [0]
==> default: Error: /Stage[main]/Mathoid/Service::Node[mathoid]/Npm::Install[/vagrant/srv/mathoid]/Exec[/vagrant/srv/mathoid_npm_install]/returns: change from notrun to 0 failed: /usr/bin/npm install --no-bin-links returned 1 instead of one of [0]
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Service::Gitupdate[mathoid]/File[/etc/mw-vagrant/services/mathoid.conf]/ensure: defined content as '{md5}21ead5dbcbba47daaac97d8d9702cc60'
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Systemd::Service[mathoid]/File[/lib/systemd/system/mathoid.service]/ensure: defined content as '{md5}4cf1a61ee4ce6cd705a71222eb729eb9'
==> default: Info: /Stage[main]/Mathoid/Service::Node[mathoid]/Systemd::Service[mathoid]/File[/lib/systemd/system/mathoid.service]: Scheduling refresh of Service[mathoid]
==> default: Info: /Stage[main]/Mathoid/Service::Node[mathoid]/Systemd::Service[mathoid]/File[/lib/systemd/system/mathoid.service]: Scheduling refresh of Exec[systemd reload for mathoid]
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Systemd::Service[mathoid]/Exec[systemd reload for mathoid]: Triggered 'refresh' from 1 events
==> default: Notice: /Stage[main]/Mathoid/Service::Node[mathoid]/Systemd::Service[mathoid]/Service[mathoid]: Dependency Exec[/vagrant/srv/mathoid_npm_install] has failures: true
==> default: Warning: /Stage[main]/Mathoid/Service::Node[mathoid]/Systemd::Service[mathoid]/Service[mathoid]: Skipping because of failed dependencies
==> default: Info: /Stage[main]/Mathoid/Service::Node[mathoid]/Systemd::Service[mathoid]/Service[mathoid]: Unscheduling all events on Service[mathoid]
==> default: Info: Systemd::Service[mathoid]: Unscheduling all events on Systemd::Service[mathoid]
==> default: Info: Service::Node[mathoid]: Unscheduling all events on Service::Node[mathoid]
==> default: Notice: /Stage[main]/Role::Mathoid/Mediawiki::Settings[Mathoid]/File[/vagrant/settings.d/puppet-managed/10-Mathoid.php]/ensure: defined content as '{md5}4d4f1401b27fd963a4e9ceb7a3ceb4b3'
==> default: Notice: /Stage[main]/Eventlogging::Devserver/Systemd::Service[eventlogging-devserver]/Service[eventlogging-devserver]/ensure: ensure changed 'stopped' to 'running'
==> default: Info: /Stage[main]/Eventlogging::Devserver/Systemd::Service[eventlogging-devserver]/Service[eventlogging-devserver]: Unscheduling refresh on Service[eventlogging-devserver]
==> default: Info: Stage[main]: Unscheduling all events on Stage[main]
==> default: Notice: Applied catalog in 153.80 seconds
The SSH command responded with a non-zero exit status. Vagrant
assumes that this means the command failed. The output for this command
should be in the log above. Please read the output to determine what
went wrong.

Event Timeline

brion created this task.Jun 6 2018, 10:12 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 6 2018, 10:12 PM
brion added a comment.Jun 6 2018, 10:13 PM

sh: 1: prebuild-install: not found is suspicious

Vvjjkkii renamed this task from Unable to install Math as "mathoid" role on MediaWiki-Vagrant on labs to gibaaaaaaa.Jul 1 2018, 1:05 AM
Vvjjkkii triaged this task as High priority.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
mobrovac renamed this task from gibaaaaaaa to Unable to install Math as "mathoid" role on MediaWiki-Vagrant on labs.Jul 1 2018, 11:22 AM
mobrovac lowered the priority of this task from High to Normal.
mobrovac updated the task description. (Show Details)
CommunityTechBot raised the priority of this task from Normal to Needs Triage.Jul 5 2018, 6:58 PM
mobrovac triaged this task as Normal priority.Jul 6 2018, 9:32 AM
Pkra moved this task from Incoming to Mathoid on the Math board.Dec 10 2018, 8:22 PM

@brion Is this still a relevant bug or should we close?