Page MenuHomePhabricator

The link to deletion log on Special:Undelete sometimes sends to the wrong page
Closed, ResolvedPublic

Description

I noticed this little issue with special:undelete. To reproduce this you have to be admin; if you are on Beta Cluster, you can just go here and skip to step 7, otherwise:

  1. Create a page and make two edits (so that it has 3 revisions)
  2. Perform a revision delete on the second revision
  3. Delete the whole page
  4. Create it again
  5. Go to the history, then click on "View or restore xxx deleted edits?"
  6. Click on the version that you previously RevDel'ed
  7. Check out the message at the top: "This page revision has been deleted. You can view it; details can be found in the deletion log."
  8. Click on "deletion log"

You should be sent to deletion log for that page, but you are instead sent to deletion log for "Special:Undelete". This is because the revision is shown on Special:Undelete and the involved system message (rev-deleted-text-view) makes use of {{PAGENAME}}. The fix shouldn't be hard, but I don't know whether I'll be able to do it myself. BTW, repro steps could possibly be simplified but I didn't even try, since the problem is already quite clear.

Event Timeline

Daimona created this task.Jun 7 2018, 5:45 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 7 2018, 5:45 PM
Vvjjkkii renamed this task from The link to deletion log on Special:Undelete sometimes sends to the wrong page to agbaaaaaaa.Jul 1 2018, 1:05 AM
Vvjjkkii triaged this task as High priority.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
Daimona renamed this task from agbaaaaaaa to The link to deletion log on Special:Undelete sometimes sends to the wrong page.Jul 1 2018, 10:24 AM
Daimona raised the priority of this task from High to Needs Triage.
Daimona updated the task description. (Show Details)
Daimona added a subscriber: Aklapper.

Change 554417 had a related patch set uploaded (by Ammarpad; owner: Ammarpad):
[mediawiki/core@master] Fix wrong title links on Special:Undelete

https://gerrit.wikimedia.org/r/554417

Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptDec 4 2019, 6:57 AM
Ammarpad claimed this task.Dec 4 2019, 7:00 AM
Ammarpad added a subscriber: Ammarpad.

The same wrong link is shown for suppression log. The above patch should fix that.

Ammarpad triaged this task as Low priority.Dec 4 2019, 7:01 AM
Umherirrender closed this task as Resolved.Jul 14 2020, 8:03 PM

Change 554417 merged by jenkins-bot:
[mediawiki/core@master] Fix wrong title links on Special:Undelete

https://gerrit.wikimedia.org/r/554417