Page MenuHomePhabricator

Revisions have disappeared since migration to WMF hosting
Closed, ResolvedPublic

Description

Some revision contents can't be found. For example, look at the history of Sails of Care, where revision 4657503 can be seen at 07:46, 4 June 2018‎. Then click through to view it and get the following error:

The revision #4657503 of the page named "Sails of Care" does not exist.

It seems that not all of all database tables were copied across in the final switch over.

Related Objects

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 11 2018, 1:41 AM

@DeepBlue This is a pretty bad issue as it affects many pages.

I agree that this is pretty bad. It looks like the tail end of the database dump didn't load since it looks like the dump is complete.

So the good news is that it looks like the data is available.

The bad news is that new data has been added to the wiki, so we can't just load

Now the problem: we can't just add re-import the data since that would overwrite the updates made since.

Ideas?

Do you have an idea of how many revisions were not imported? And whether there is any other missing data?

I'd be inclined to say that the data added since the import should be discarded, and the whole original dump re-imported (assuming it's all there and doing so works successfully on a separate test database). It hasn't been that long, and I don't think there's that much been added.

That said, is there a chance that the missing data can be inserted? Because it seems likely that the revision IDs of the new data will not overlap with the missing data (because the auto-increment value would have probably been set when the new database tables were created, and if not we'd probably see some wrong content). But that seems risky, and might result in problems that we don't see for a long time.

I no longer remember when exactly the switch happened but we hardly had any activity during the past month. I suggest to export all pages that there edited and created by regular users, not bots, with all revisions. Move the working database in again in a second step and import the previously exported pages in a third step. Only one user would need to register again which I think is acceptable.

I guess it will be cool to tackle this rather sooner than later.

Samwilson triaged this task as High priority.Jun 28 2018, 10:48 PM

I'd go so far as to suggest that editing be disabled until this is fixed.

I guess it will be cool to tackle this rather sooner than later.

Working on it at the moment, hopefully it should be resolved by middle of next week. Sorry, forgot to update you guys

Thanks for working on it! :-)

Is going to be any data loss for the edits made recently?

Is going to be any data loss for the edits made recently?

No, none at all if this method works out in our testing. However, it will require a few hours of the wiki being readonly while we fiddle with the database and such.

DeepBlue added a comment.EditedJun 30 2018, 4:01 PM

This fix may be delayed a bit while we update to the upcoming LTS 1.31 version from legacy 1.29

Vvjjkkii renamed this task from Revisions have disappeared since migration to WMF hosting to vabaaaaaaa.Jul 1 2018, 1:04 AM
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
CommunityTechBot renamed this task from vabaaaaaaa to Revisions have disappeared since migration to WMF hosting.Jul 2 2018, 2:56 PM
CommunityTechBot updated the task description. (Show Details)
CommunityTechBot added a subscriber: Aklapper.

Currently I have confirmed that the proposed solution will work but have yet to update the wiki. I'm getting a few errors but they don't seem to be related to the database so hopefully things will continue to go smoothly.

We will be attempting to finalize this fix tomorrow but for that we will be putting the wiki into readonly mode from approx. 10AM to 4PM EST

DeepBlue closed this task as Resolved.Jul 4 2018, 10:28 PM
DeepBlue claimed this task.

The pages have been restored to Wikiapiary. Maintainence has finished and the site is in read/write mode.