Page MenuHomePhabricator

Enable citoid on sw wikipedia.
Closed, ResolvedPublic

Description

Hi there! I'm Muddyb from Swahili Wikipedia. In our Wikipedia, we do not have an automatic reference function as the English Wikipedia. When you press CTRL+SHIFT+K to get reference TAB you find some functions are disabled including AUTOMATIC. It works only if you are crunching the codes MANUAL. It is very hard to use it when you on the VISUAL Editor. On the English Wikipedia, I apply the same method and it works perfect fine. When I'm trying to to do the same on the Swahili Wikipedia, not working. There is no automatic referencing. I was wondering if you could help us fixing the auto-referencing function on our Wiki.

Best!

Event Timeline

Muddyb created this task.Jun 11 2018, 6:38 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 11 2018, 6:38 AM
Aklapper renamed this task from Automatic reference function on the Swahili Wikipedia to "Add a citation" dialog on Swahili Wikipedia does not offer "Automatic".Jun 11 2018, 9:38 AM
Restricted Application added a project: VisualEditor. · View Herald TranscriptJun 11 2018, 9:38 AM

Hi @Muddyb, thanks for taking the time to report this and welcome to Wikimedia Phabricator!
It took me a while to realize that this seems to be about VisualEditor as the Editor being used. For future reference, please follow https://mediawiki.org/wiki/How_to_report_a_bug and provide clear steps (click by click) to reproduce the problem. Thanks!

Hi @Muddyb, thanks for taking the time to report this and welcome to Wikimedia Phabricator!
It took me a while to realize that this seems to be about VisualEditor as the Editor being used. For future reference, please follow https://mediawiki.org/wiki/How_to_report_a_bug and provide clear steps (click by click) to reproduce the problem. Thanks!

If I understood better this reply, suggests I should start all over again step-by-step?

Deskana triaged this task as Normal priority.Jun 12 2018, 6:43 PM
Deskana edited projects, added Citoid; removed VisualEditor-MediaWiki-References.
Deskana moved this task from To Triage to External and Administrivia on the VisualEditor board.
Deskana added subscribers: Mvolz, Deskana.

Citoid is not set up on your wiki, which is why it does not work. There is work you will need to do to get it set up. You may find the instructions on how to enable Citoid on your wiki helpful. @Mvolz may also be able to help you, time permitting.

Citoid is not set up on your wiki, which is why it does not work. There is work you will need to do to get it set up. You may find the instructions on how to enable Citoid on your wiki helpful. @Mvolz may also be able to help you, time permitting.

:Thanks for the info. Dear @Mvolz kindly help me out fixing the problem whenever you are ready. I've tried to follow some instructions on CITOID but wasn't successful. I ended up importing a bunch of templates from English Wikipedia, yet the problem still exists.

Mvolz added a comment.EditedJun 14 2018, 9:57 AM

Citoid is not set up on your wiki, which is why it does not work. There is work you will need to do to get it set up. You may find the instructions on how to enable Citoid on your wiki helpful. @Mvolz may also be able to help you, time permitting.

:Thanks for the info. Dear @Mvolz kindly help me out fixing the problem whenever you are ready. I've tried to follow some instructions on CITOID but wasn't successful. I ended up importing a bunch of templates from English Wikipedia, yet the problem still exists.

Do you have any native citation templates? Those can be used as well.

The main reason the imported citation templates don't work yet is they don't have any templatedata, see: https://www.mediawiki.org/wiki/Help:TemplateData

Citoid is not set up on your wiki, which is why it does not work. There is work you will need to do to get it set up. You may find the instructions on how to enable Citoid on your wiki helpful. @Mvolz may also be able to help you, time permitting.

:Thanks for the info. Dear @Mvolz kindly help me out fixing the problem whenever you are ready. I've tried to follow some instructions on CITOID but wasn't successful. I ended up importing a bunch of templates from English Wikipedia, yet the problem still exists.

Do you have any native citation templates? Those can be used as well.
The main reason the imported citation templates don't work yet is they don't have any templatedata, see: https://www.mediawiki.org/wiki/Help:TemplateData

Hello back! I have created it https://sw.wikipedia.org/wiki/Kigezo:TemplateData still the problem persist. And would please be so kind explain to me a bit about the NATIVE TEMPLATE? How to go about it? See it here: https://sw.wikipedia.org/wiki/Picha:Error_report_on_adding_citation_on_the_SWWP.png

Citoid is not set up on your wiki, which is why it does not work. There is work you will need to do to get it set up. You may find the instructions on how to enable Citoid on your wiki helpful. @Mvolz may also be able to help you, time permitting.

:Thanks for the info. Dear @Mvolz kindly help me out fixing the problem whenever you are ready. I've tried to follow some instructions on CITOID but wasn't successful. I ended up importing a bunch of templates from English Wikipedia, yet the problem still exists.

Do you have any native citation templates? Those can be used as well.
The main reason the imported citation templates don't work yet is they don't have any templatedata, see: https://www.mediawiki.org/wiki/Help:TemplateData

Hello back! I have created it https://sw.wikipedia.org/wiki/Kigezo:TemplateData still the problem persist. And would please be so kind explain to me a bit about the NATIVE TEMPLATE? How to go about it? See it here: https://sw.wikipedia.org/wiki/Picha:Error_report_on_adding_citation_on_the_SWWP.png

You don't need a Template called template data (that page can be deleted), you need to add a special text called "template data" to all the templates you wish to use. I've added some to Template:Citation here: https://sw.wikipedia.org/w/index.php?title=Kigezo:Citation/hati&action=history

It's the bit that starts <templatedata> and ends </templatedata>

By "native templates" I mean citation templates that were not imported from English wiki. You do not NEED them if you don't already have them, the English wiki ones will work! But many wikis that already have their own citation templates prefer to use the ones they have already so I wanted to check first. It looks like sw wiki does not have any.

Template:Citation is basically done, unless you wish to translate the "label" and "description" into Swahili - of course it's a lot of work! Now if you go to https://sw.wikipedia.org/w/index.php?title=Kigezo:Citation/hati&action=edit you will now see a button that says "Manage TemplateData" at the top you can click on the parameters to translate the "label" and "description".

I've reenabled it now that the template data has been added, please test it out!

Mvolz closed this task as Resolved.Jun 18 2018, 10:38 AM
Mvolz claimed this task.
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptJun 18 2018, 10:38 AM

Citoid is not set up on your wiki, which is why it does not work. There is work you will need to do to get it set up. You may find the instructions on how to enable Citoid on your wiki helpful. @Mvolz may also be able to help you, time permitting.

:Thanks for the info. Dear @Mvolz kindly help me out fixing the problem whenever you are ready. I've tried to follow some instructions on CITOID but wasn't successful. I ended up importing a bunch of templates from English Wikipedia, yet the problem still exists.

Do you have any native citation templates? Those can be used as well.
The main reason the imported citation templates don't work yet is they don't have any templatedata, see: https://www.mediawiki.org/wiki/Help:TemplateData

Hello back! I have created it https://sw.wikipedia.org/wiki/Kigezo:TemplateData still the problem persist. And would please be so kind explain to me a bit about the NATIVE TEMPLATE? How to go about it? See it here: https://sw.wikipedia.org/wiki/Picha:Error_report_on_adding_citation_on_the_SWWP.png

You don't need a Template called template data (that page can be deleted), you need to add a special text called "template data" to all the templates you wish to use. I've added some to Template:Citation here: https://sw.wikipedia.org/w/index.php?title=Kigezo:Citation/hati&action=history
It's the bit that starts <templatedata> and ends </templatedata>
By "native templates" I mean citation templates that were not imported from English wiki. You do not NEED them if you don't already have them, the English wiki ones will work! But many wikis that already have their own citation templates prefer to use the ones they have already so I wanted to check first. It looks like sw wiki does not have any.
Template:Citation is basically done, unless you wish to translate the "label" and "description" into Swahili - of course it's a lot of work! Now if you go to https://sw.wikipedia.org/w/index.php?title=Kigezo:Citation/hati&action=edit you will now see a button that says "Manage TemplateData" at the top you can click on the parameters to translate the "label" and "description".
I've reenabled it now that the template data has been added, please test it out!

Thank you. It's working fine now. Means a lot.

Vvjjkkii renamed this task from "Add a citation" dialog on Swahili Wikipedia does not offer "Automatic" to tabaaaaaaa.Jul 1 2018, 1:04 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii removed Mvolz as the assignee of this task.
Vvjjkkii raised the priority of this task from Normal to High.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
Mvolz renamed this task from tabaaaaaaa to Enable citoid on sw wikipedia.Jul 1 2018, 9:10 AM
Mvolz closed this task as Resolved.
Mvolz claimed this task.
Mvolz lowered the priority of this task from High to Normal.
Mvolz updated the task description. (Show Details)
CommunityTechBot renamed this task from Enable citoid on sw wikipedia to "Add a citation" dialog on Swahili Wikipedia does not offer "Automatic".Jul 3 2018, 2:27 PM
CommunityTechBot updated the task description. (Show Details)
MusikAnimal renamed this task from "Add a citation" dialog on Swahili Wikipedia does not offer "Automatic" to Enable citoid on sw wikipedia..Jul 3 2018, 2:28 PM