Page MenuHomePhabricator

Ask users for address data after donating
Closed, ResolvedPublic

Description

As a donor,
I want to only carry out the mandatory steps for donating,
so that I can complete my donation within a short amount of time.

We want to try out moving the address form for donors to the very end of the donation process (i. e. donation confirmation page).

Acceptance Criteria

  • The process for direct debit donations remains as it is.
  • For all other payment types,
    • the confirmation page contains a paragraph that asks for the donor's address.
    • Clicking on the respective link leads to the address form.
    • Filling out the address form updates an existing data set with the given address.
    • After submitting the address form
      • A confirnation mail is being sent.
      • The confirmation page is being displayed to the donor again, leaving out the address form part.

Screenshots

← updated, 2018-07-03

← new, after address input, 2018-07-19

Notes

  • We did an indirect redirect from banners to the payment providers already as a banner test. Maybe we can re-use the behaviour (submit all data that is needed to create an anonymous donation).
  • Design: There are "Too many buttons" on the same page, since we ask for Mitgliedschaft, Reciept and Mail. Two things could alleviate: 1) Ask these in a short, all-steps-optional stepwise process 2) Get a design for secondary actions for buttons, currently we only have the white-on-blue and thus have no hierarchy of actions.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 11 2018, 10:53 AM
Restricted Application added a project: WMDE-FUN-Team. · View Herald TranscriptJun 11 2018, 10:54 AM
Vvjjkkii renamed this task from Ask users for address data after donating to aabaaaaaaa.Jul 1 2018, 1:04 AM
Vvjjkkii triaged this task as High priority.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
kai.nissen renamed this task from aabaaaaaaa to Ask users for address data after donating.Jul 2 2018, 7:40 AM
kai.nissen lowered the priority of this task from High to Medium.
kai.nissen updated the task description. (Show Details)
kai.nissen edited projects, added Story; removed Epic.
kai.nissen added a subscriber: Aklapper.
kai.nissen updated the task description. (Show Details)Jul 2 2018, 8:59 AM
Jan_Dittrich updated the task description. (Show Details)Jul 3 2018, 7:50 AM
Jan_Dittrich updated the task description. (Show Details)Jul 3 2018, 7:52 AM

@Jan_Dittrich please keep the comments on sheet 5 in mind. The call for mitgliedschaft won´t be an the "Adresspage". Also, I suggest to only have one submit button and the framing of the further action (Spendenbescheinigung, Bestätigung per eMail) could be better. tbd

@kai.nissen: The "When non-direct-debit payment is selected in the banner, create donation and go directly to payment provider/success page (for bank transfer)" was implemented in the banner logic (going to donation/add instead of donation/new) and probably should be kept that way. We can reuse the banner code, but for the non-banner flow, we still need to implement some logic, as outlined in T198604: Change "add donation" page. Or should we drop/depriortize that subticket and concentrate und the confirmation page?

@gabriel-wmde Compared to the traffic from banners, non-banner users are a very small group of users. If we do not work on T198604, would that mean, that in some cases the non-banner users would see the address form twice (first where it is now, and again on the confirmation page if they chose "anonymous")?

Jan_Dittrich updated the task description. (Show Details)Jul 19 2018, 1:30 PM

Since @Tim_WMDE asked me about the blue framed box and it's content: For longer text e.g. "donation promise" via bank transfer, the text goes between the amount/payment method and the "Spendennummer" and enlarges the box by doing so.

If there are problems to do that (markup/tech debt) you could also do this:

Semantically, the box shall be (or shall evolve to) a notification of the actions just done.

Note to self: Make sure the page looks correct when printed.

The mockup above incorporates a lot of changes that need to be tested independently. As just discussed with @Tim_WMDE and @Hanna_Petruschat_WMDE, we diverge from the mockup:

  • The call-to-action regarding the membership application is not being changed, but kept as it is now.
  • The bank account data needed for bank transfer donations is being displayed right below the summarizing sentence ("Sie möchten 50€ per Überweisung spenden.")
  • The address form is positioned below the button that slides it down when clicked.

Hey @tmletzko @Tobias_Schumann_WMDE,

since Kai is absent, can you test our implementation? The changes can be found on the test server, you can enable them with this URL:

https://test-spenden-2.wikimedia.de/?skin=0&da=1

And you disable them with this URL:

https://test-spenden-2.wikimedia.de/?skin=0&da=0

Normally users would be coming in from banners, so to fake that simply make an anonymous donation, this will give you the option to enter your address on the confirmation page if you have the test enabled. The frontpage remains unchanged for now, so all changes are limited to the donation confirmation page.

@Tim_WMDE thanks. a few remarks from my side for now.

  • I rather have the wording: Möchten Sie eine Spendenbescheinigung erhalten?
  • please delete the sentence "Bei Spenden über 200€ ist die Spendenbestätigung für die Steuererklärung notwendig" below the button. Otherwise, we decrease the adress rate.
  • the subheader on the adressform should be excluded. The sentence "Sie können auch ohne Angabe Ihrer Adresse spenden." does not make sense here. I would rather delete the whole subheader.
  • I wonder why the donation comment function is not visible
  • Please change wording on adress confirm page from "Sie haben Ihre Adress-Daten eingegeben. Wir senden Ihnen eine Spendenbescheinigung. " "Vielen Dank. Wir senden Ihnen die Zuwendungsbescheinigung an folgende Adresse." Ideally, we leave out the copy " Danke. Ihre Spende über 75,00 € per Kreditkarte wurde gebucht. Spendennummer: 2779939" since it is redundant to the donation confirmation page. It would be nice to have a structured form for the adress data and to have a clearer presence of the adressdata aswell. Currently, the font is too small and too light.
  • I wonder if having different colours for the buttons on the donation confirmation page would be better. Currently, it is blue for both. I rather have the CtA for the membership in green (also due to consistency with the following page) to have a better differentiation. But I see the point of keeping the same button colour as with CTRL.

this

I looked at this UI as @Tim_WMDE told me.

To not create mess, let's tackle what was defined in the ticket above – @tmletzko please put button colors and other UX concerns in an extra ticket, so it can be tackled (is that according to dev needs as well, @RazShuty ?)

For some things that might be errors on the side of design.

I wonder why the donation comment function is not visible

Indeed, this was seemingly forgotten in the design (or done in a conversation?). Relating to the problem that the page’s functionalities don’t have a meaningful design representation, and the page needs a full redesign to keep all functions structured.

the subheader on the adressform should be excluded. The sentence "Sie können auch ohne Angabe Ihrer Adresse spenden." does not make sense here. I would rather delete the whole subheader.

I did not see this issue in the screen, but if it is there, it indeed makes no sense.

Tim_WMDE added a comment.EditedAug 2 2018, 3:54 PM

I wonder why the donation comment function is not visible

I think this got lost since Überweisung never shows the comment functionality and we usually use that payment method for our tests, so this was a regression which we did not notice before during development, thanks for catching it. This has been fixed and deployed now.

Hey @tmletzko ,

It seems to me like the Acceptance Criterias have been met and generally we prefer these things to go through our regular process, so currently the bug is fixed and if it's OK @kai.nissen and I can join forces with @Jan_Dittrich and speak about the changes you want and introduce that to the team in their next iteration....

hey @RazShuty @Jan_Dittrich @Tim_WMDE difficult on this one since this one is quite complicated because the process involves a few steps. It is actually a whole new user journey. Two points I take out of this. 1) @kai.nissen, UX and FUN needs to take better care of conceptionalizing before FUN-tech puts hand on it. If we had done so, we would have seen the mentioned things and 2) we need to make sure that certains flexibilty still exists. I am ok when desired modifications are taken care in the following sprint for this one but in the last quarter of the year, this will be troubling (I know we should avoid those kind of tech tasks during the campaign, but experience says this can happen).

For this case: a few things are copy related, which I can do by myself once I know where the page is.

Hey @tmletzko,

1st a quick Hi, I haven't properly introduced myself, I am Raz the new Engineering Manager for FUN and TechWish (replacing Tobi while he's on parental leave).
Sorry if my last message lacked context...

To the point now: I understand what you are saying, that's why we should iron out those things before hand, changing things after costs time and money... I can share a simple graph of costs of features when changes are introduced, but it's easy to imagine it, each phase later we introduce change to a feature the costs jump is exponential.

Thus, You, me and @kai.nissen (and in some cases @Jan_Dittrich or someone from his team) should iron out everything, because once it hits the devs, we've made our commitment to them that the Acceptance Criteria are perfect and they can start, if we don't do that we screwed up, not them...

Feel free to speak with me personally - I tend to sound strict and annoying in messages, but I'm never mean it that way...
We can also have a chat every week or two just to get to know each other better and how to work together as I assume it might be a bit different than your regular mode of operation...

Raz

kai.nissen closed this task as Resolved.Mon, Jan 13, 4:42 PM