Page MenuHomePhabricator

There isn't a way to search for missing pages
Closed, DuplicatePublic

Description

Problem
I'm trying to search for deleted pages, I realize there isn't a concept of this in MediaWiki, so I really am looking for deleted revisions in which the page itself is missing. The best I can come up with is something like this:
all: https://test.wikipedia.org/w/api.php?action=query&generator=alldeletedrevisions&formatversion=2&gadrdir=newer
search: https://test.wikipedia.org/w/api.php?action=query&generator=alldeletedrevisions&formatversion=2&gadrdir=newer&gadrprefix=T
but as you can see, it may or may not include missing pages.

Solution
Add a parameter of some sort that would query the revision table where ar_page_id cannot be JOIN'd (i.e. where the page is missing).

Event Timeline

dbarratt created this task.Jun 11 2018, 5:03 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 11 2018, 5:03 PM
Restricted Application added a subscriber: MGChecker. · View Herald TranscriptJun 11 2018, 5:30 PM
Anomie added a subscriber: Anomie.

Yes, as you mentioned in T192023#4273204 this seems like a duplicate of that task.

Vvjjkkii renamed this task from There isn't a way to search for missing pages to 48aaaaaaaa.Jul 1 2018, 1:05 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii triaged this task as High priority.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
CommunityTechBot renamed this task from 48aaaaaaaa to There isn't a way to search for missing pages.Jul 2 2018, 2:12 PM
CommunityTechBot closed this task as a duplicate.
CommunityTechBot raised the priority of this task from High to Needs Triage.
CommunityTechBot updated the task description. (Show Details)
CommunityTechBot added a subscriber: Aklapper.