Page MenuHomePhabricator

Wikibase phpunit failure blocking WikidataPageBanner patches
Closed, DuplicatePublic

Description

Seen on https://gerrit.wikimedia.org/r/440003

19:46:47 There was 1 error:
19:46:47 
19:46:47 1) WikibaseQuality\ConstraintReport\Tests\Specials\SpecialConstraintReportTest::testExecute with data set "valid input - existing item" ('$id', array(), 'qqx', array(Hamcrest\Core\CombinableMatcher Object (...), Hamcrest\Core\CombinableMatcher Object (...), Hamcrest\Core\CombinableMatcher Object (...), Hamcrest\Core\CombinableMatcher Object (...), Hamcrest\Core\CombinableMatcher Object (...), WMDE\HamcrestHtml\ComplexTagMatcher Object (...), Hamcrest\Core\CombinableMatcher Object (...), Hamcrest\Core\CombinableMatcher Object (...), Hamcrest\Core\CombinableMatcher Object (...), Hamcrest\Core\CombinableMatcher Object (...), Hamcrest\Core\CombinableMatcher Object (...), Hamcrest\Core\CombinableMatcher Object (...)))
19:46:47 Hamcrest\AssertionError: Failed to assert output: value status - warning
19:46:47 Expected: is valid html piece having child (tag matching outline `<span class="wbqc-status wbqc-status-warning"/>` and having child (with tag name "label" and having text contents "(wbqc-constraintreport-status-warning)"))
19:46:47 but: valid html piece having no children (tag matching outline `<span class="wbqc-status wbqc-status-warning"/>` and having child (with tag name "label" and having text contents "(wbqc-constraintreport-status-warning)"))
19:46:47 Actual html:
19:46:47 <div class="wbqc-explanation"><p>(wbqc-constraintreport-explanation-part-one)</p><p>(wbqc-constraintreport-explanation-part-two)</p></div><div class='mw-htmlform-ooui-wrapper oo-ui-layout oo-ui-panelLayout'><form action='/wiki/index.php/Special:ConstraintReport' method='post' enctype='application/x-www-form-urlencoded' class='mw-htmlform mw-htmlform-ooui oo-ui-layout oo-ui-formLayout'><div class='oo-ui-layout oo-ui-panelLayout oo-ui-panelLayout-padded oo-ui-panelLayout-framed'><fieldset class='oo-ui-layout oo-ui-labelElement oo-ui-fieldsetLayout'><legend class='oo-ui-fieldsetLayout-header'><span class='oo-ui-iconElement-icon'></span><span class='oo-ui-labelElement-label'>(wbqc-constraintreport-form-section)</span></legend><div class='oo-ui-fieldsetLayout-group'><div aria-disabled='false' class='oo-ui-widget oo-ui-widget-enabled'><div id="mw-htmlform-section"><div id='ooui-php-18' class='mw-htmlform-field-HTMLTextField wbqc-constraintreport-form-entity-id oo-ui-layout oo-ui-labelElement oo-ui-fieldLayout oo-ui-fieldLayout-align-top' data-ooui='{"_":"mw.htmlform.FieldLayout","fieldWidget":{"tag":"mw-input-entityid"},"align":"top","errors":[],"notices":[],"$overlay":true,"label":{"html":"(wbqc-constraintreport-form-entityid-label)"},"classes":["mw-htmlform-field-HTMLTextField","wbqc-constraintreport-form-entity-id"]}'><div class='oo-ui-fieldLayout-body'><span class='oo-ui-fieldLayout-header'><label for='ooui-php-17' class='oo-ui-labelElement-label'>(wbqc-constraintreport-form-entityid-label)</label></span><div class='oo-ui-fieldLayout-field'><div id='mw-input-entityid' aria-disabled='false' class='wbqc-constraintreport-form-entity-id oo-ui-widget oo-ui-widget-enabled oo-ui-inputWidget oo-ui-textInputWidget oo-ui-textInputWidget-type-text oo-ui-textInputWidget-php' data-ooui='{"_":"OO.ui.TextInputWidget","placeholder":"(wbqc-constraintreport-form-entityid-placeholder)","name":"entityid","inputId":"ooui-php-17","classes":["wbqc-constraintreport-form-entity-id"]}'><input type='text' tabindex='0' aria-disabled='false' name='entityid' value='' placeholder='(wbqc-constraintreport-form-entityid-placeholder)' id='ooui-php-17' class='oo-ui-inputWidget-input' /><span class='oo-ui-iconElement-icon'></span><span class='oo-ui-indicatorElement-indicator'></span></div></div></div></div></div></div></div></fieldset></div>
19:46:47 <input id="wpEditToken" type="hidden" value="+\" name="wpEditToken"/>
19:46:47 <input type="hidden" value="Special:ConstraintReport" name="title"/>
19:46:47 <div class="mw-htmlform-submit-buttons">
19:46:47 <span aria-disabled='false' id='ooui-php-19' class='mw-htmlform-submit oo-ui-widget oo-ui-widget-enabled oo-ui-flaggedElement-primary oo-ui-flaggedElement-progressive oo-ui-inputWidget oo-ui-buttonElement oo-ui-buttonElement-framed oo-ui-labelElement oo-ui-buttonInputWidget' data-ooui='{"_":"OO.ui.ButtonInputWidget","type":"submit","value":"(wbqc-constraintreport-form-submit-label)","flags":["primary","progressive"],"label":"(wbqc-constraintreport-form-submit-label)","classes":["mw-htmlform-submit"]}'><button type='submit' tabindex='0' aria-disabled='false' value='(wbqc-constraintreport-form-submit-label)' class='oo-ui-inputWidget-input oo-ui-buttonElement-button'><span class='oo-ui-iconElement-icon oo-ui-image-invert'></span><span class='oo-ui-labelElement-label'>(wbqc-constraintreport-form-submit-label)</span><span class='oo-ui-indicatorElement-indicator oo-ui-image-invert'></span></button></span></div>
19:46:47 </form></div><h3>(wbqc-constraintreport-result-headline) <a title="Item:Q1" href="/wiki/index.php/Item:Q1">Q1</a> (Q1)</h3><p><span class="wbqc-status wbqc-status-todo"><label aria-disabled='false' class='oo-ui-widget oo-ui-widget-enabled oo-ui-labelElement-label oo-ui-labelElement oo-ui-labelWidget'>(wbqc-constraintreport-status-todo)</label></span>: 1</p><table class="wikitable sortable jquery-tablesort"><tr><th role="columnheader button">(wbqc-constraintreport-result-table-header-status)</th><th role="columnheader button">(wbqc-constraintreport-result-table-header-property)</th><th role="columnheader button">(wbqc-constraintreport-result-table-header-message)</th><th role="columnheader button">(wbqc-constraintreport-result-table-header-constraint)</th></tr></table>
19:46:47 
19:46:47 /home/jenkins/workspace/mwext-testextension-hhvm-jessie/src/vendor/hamcrest/hamcrest-php/hamcrest/Hamcrest/MatcherAssert.php:115
19:46:47 /home/jenkins/workspace/mwext-testextension-hhvm-jessie/src/vendor/hamcrest/hamcrest-php/hamcrest/Hamcrest/MatcherAssert.php:64
19:46:47 /home/jenkins/workspace/mwext-testextension-hhvm-jessie/src/vendor/hamcrest/hamcrest-php/hamcrest/Hamcrest.php:29
19:46:47 /home/jenkins/workspace/mwext-testextension-hhvm-jessie/src/extensions/WikibaseQualityConstraints/tests/phpunit/Specials/SpecialConstraintReportTest.php:180
19:46:47 /home/jenkins/workspace/mwext-testextension-hhvm-jessie/src/tests/phpunit/MediaWikiTestCase.php:420
19:46:47 /home/jenkins/workspace/mwext-testextension-hhvm-jessie/src/maintenance/doMaintenance.php:94
19:46:47 
19:46:47 FAILURES!
19:46:47 Tests: 17576, Assertions: 147827, Errors: 1, Skipped: 33.

Event Timeline

Restricted Application added a project: Wikidata. · View Herald TranscriptJun 12 2018, 8:44 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Also blocking ContentTranslation patches.

thiemowmde triaged this task as High priority.Jun 13 2018, 9:17 AM
thiemowmde moved this task from In discussion to Blocked on the Wikidata-Page-Banner board.

Looks like a dupe of T197017 which should be fixed already, can you retry your CI builds?

The CI on both extensions is green again.

Vvjjkkii renamed this task from Wikibase phpunit failure blocking WikidataPageBanner patches to 15aaaaaaaa.Jul 1 2018, 1:04 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
CommunityTechBot closed this task as a duplicate.
CommunityTechBot renamed this task from 15aaaaaaaa to Wikibase phpunit failure blocking WikidataPageBanner patches.
CommunityTechBot added a subscriber: Aklapper.