Page MenuHomePhabricator

Delete actions do not appear on watchlist (Hungarian Wikipedia issue)
Closed, ResolvedPublic

Description

On the Hungarian Wikipedia the delete actions do not appear on user's watchlist, however other actions (such as move, suppress, undelete) do. It is a known problem and was fixed at least once (maybe around 2014?) during my career but it returned again. The interesting thing is that the mobile-side is not affected. It should be fixed.

Example:

My watchlist on desktop:


My watchlist on mobile:

How to reproduce:

  • Go to Kategória:Azonnali törlésre váró lapok (Category:Candidates for speedy deletion in Hungarian)
  • Watchlist a random page (if you cannot find any candidates, try it later)
  • Check your watchlist after few hours

Event Timeline

Bencemac created this task.Jun 17 2018, 2:15 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 17 2018, 2:15 PM

What cames to my mind: Try to disable "new filters for edit review" in Beta preferences, if it will change anything.

@Urbanecm It doesn't help. It affects every editor, no matter they are using the old or the new watchlist.

Vvjjkkii renamed this task from Delete actions do dot appear on watchlist (Hungarian Wikipedia issue) to 2raaaaaaaa.Jul 1 2018, 1:03 AM
Vvjjkkii triaged this task as High priority.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
CommunityTechBot renamed this task from 2raaaaaaaa to Delete actions do dot appear on watchlist (Hungarian Wikipedia issue).Jul 2 2018, 4:43 AM
CommunityTechBot raised the priority of this task from High to Needs Triage.
CommunityTechBot updated the task description. (Show Details)
CommunityTechBot added a subscriber: Aklapper.
Bencemac renamed this task from Delete actions do dot appear on watchlist (Hungarian Wikipedia issue) to Delete actions do not appear on watchlist (Hungarian Wikipedia issue).Jul 21 2018, 1:18 PM
Restricted Application added a project: Growth-Team. · View Herald TranscriptJul 21 2018, 1:18 PM

I can reproduce this, and I can confirm that it happens on huwiki but doesn't happen on testwiki or on enwiki. Very strange.

We are considering this for Growth team maintenance work.

Bencemac updated the task description. (Show Details)Aug 28 2018, 6:47 PM

Mystery solved: this is caused by MediaWiki-extensions-LiquidThreads adding page_namespace != 90 (90 is the Thread namespace) to the WHERE clause, which then causes all rows that don't have a corresponding row in the page table (meaning, deleted pages) to be dropped, because NULL != 90 is false (that sounds strange, but any comparison involving null is false).

This was caused by rELQT5c867745a737: Remove impossible query condition, which we should just revert.

Change 458621 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/LiquidThreads@master] Revert "Remove impossible query condition"

https://gerrit.wikimedia.org/r/458621

Change 458621 merged by jenkins-bot:
[mediawiki/extensions/LiquidThreads@master] Revert "Remove impossible query condition"

https://gerrit.wikimedia.org/r/458621

because NULL != 90 is false (that sounds strange, but any comparison involving null is false).

Hmm, is this MediaWiki specific?

because NULL != 90 is false (that sounds strange, but any comparison involving null is false).

Hmm, is this MediaWiki specific?

No, see the MySQL documentation: https://dev.mysql.com/doc/refman/8.0/en/working-with-null.html

Etonkovidova closed this task as Resolved.EditedSep 17 2018, 8:51 PM
Etonkovidova added a subscriber: Etonkovidova.

The fix works in betalabs and in testwiki (wmf.22):