Page MenuHomePhabricator

Change syntaxhighlight icon to something else than a previously signature pensil
Closed, DuplicatePublic

Description

I am talking about the pre-2017 "new" wikitext editor.

Recently its icons were redesigned and signature icon was changed from a pensil to some abracadabra. While I am not a fan of this, it is fine.

The problem is that more recently there was a new icon added providing syntaxhighlight feature, and it uses a pensil. I have found myself pressing it three times today instead of the signature button, the first time not noticing doing so and saving the edit unsigned.

This is no good and the inconvenience is uncalled for.

I would really appreciate a fast change, besides a pensil is a bad representation of syntax highlight.

Event Timeline

Base created this task.Jun 17 2018, 8:29 PM
Restricted Application added a project: Community-Tech. · View Herald TranscriptJun 17 2018, 8:29 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

It's actually a highlighter, but I agree it looks like a pencil and thus may cause confusion.

Lofhi added a subscriber: Lofhi.Jun 18 2018, 10:02 AM

Confusions are also reported on frwiki, some people have had trouble disabling syntaxhighlight.

some people have had trouble disabling syntaxhighlight.

Is this because they didn't know the toggle button (highlighter icon) was there, or the button isn't working?

Syntax highlighting has been out as a beta feature for almost a year now. There are thousands of people using it all over our projects. Changing the icon now will cause them a lot of confusion.

There have been prior discussions about the icon and there has not been unanimous support about changing it one way or another. At this stage it is too late to change it, unfortunately.

Base added a comment.Jun 18 2018, 11:07 PM

So it is ok to force juggle icons for millions so that thousands do not suffer from change? This is a corrupted approach.

TheDJ added a subscriber: TheDJ.Jun 19 2018, 9:26 AM

@Base please don't use words as 'corrupted'. It's not conductive to the conversation.

The redesign of the signature button was independent of this. It is recognised that the icon for syntax highlighting is not ideal. It's just that no one has been able to come up with anything better. Do you have a design that is better ?

@Niharika it's never too late to change something. What you mean is the your team is not going to invest additional cost into this issue considering the stage of the project.

Base added a comment.Jun 25 2018, 1:48 AM

@TheDJ , a lamp or whatever else suggesting highlighting without looking as something already present else would perfectly do.

Vvjjkkii renamed this task from Change syntaxhighlight icon to something else than a previously signature pensil to oraaaaaaaa.Jul 1 2018, 1:03 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii triaged this task as High priority.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
CommunityTechBot raised the priority of this task from High to Needs Triage.
CommunityTechBot closed this task as a duplicate.
CommunityTechBot renamed this task from oraaaaaaaa to Change syntaxhighlight icon to something else than a previously signature pensil.
CommunityTechBot added a subscriber: Aklapper.