Page MenuHomePhabricator

Text selection is offset one line from cursor location
Closed, DuplicatePublic

Description

Chrome Version 67.0.3396.87 (Official Build) (64-bit)
MacOS 10.13.5 (17F77)

This is a weird one, and I haven't figured out how to reproduce it, but opening this task to record my observations.

I got into a state where as I was trying to select text by dragging the mouse over it, I was getting text selected one line below where my mouse cursor was.

. This was entirely reproducible within that editing session, but I haven't yet been able to reproduce it in another window.

Note: the attached screenshot was taken with Grab and timed screen capture. I'm not sure how faithfully that reproduces the cursor location, but the image is a reasonable representation of what was happening.

If I moved the cursor up and down a few pixels, it acted as if the cursor hotspot was at the very bottom of the drawn cursor icon. Normally, for the insertion I-bar, the hotspot is the vertical center of the icon.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 18 2018, 12:48 PM
RoySmith closed this task as Invalid.Jun 18 2018, 12:49 PM

Oooops, accidentally created as a duplicate of T197592

Vvjjkkii renamed this task from Text selection is offset one line from cursor location to mqaaaaaaaa.Jul 1 2018, 1:03 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii triaged this task as High priority.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
CommunityTechBot renamed this task from mqaaaaaaaa to Text selection is offset one line from cursor location.Jul 2 2018, 4:40 AM
CommunityTechBot closed this task as a duplicate.
CommunityTechBot raised the priority of this task from High to Needs Triage.
CommunityTechBot updated the task description. (Show Details)
CommunityTechBot added a subscriber: Aklapper.