Page MenuHomePhabricator

Public summary and mobile-sections endpoints return old description for a specific page
Closed, ResolvedPublic

Description

https://es.wikipedia.org/api/rest_v1/page/summary/Manuel_Belgrano

The underlying Wikidata item was vandalized and then the vandalism reverted on June 11. The public summary endpoint for eswiki still shows the bad description, "pornstar argento".

Prod MCS returns the correct description (verified on scb1001).

The public endpoint returns the bad description even after a Varnish purge.

Therefore it seems like we're stuck with a bad summary stored in RESTBase and not updated after the reversion.

This shows up in the Android app but interestingly not the iOS app (maybe it still gets descriptions from mobileview).

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald Transcript
-jem- added a subscriber: -jem-.Jun 18 2018, 6:27 PM
Mholloway updated the task description. (Show Details)Jun 18 2018, 6:28 PM
Mholloway updated the task description. (Show Details)Jun 18 2018, 6:32 PM
Mholloway renamed this task from public summary endpoint returns old description for a specific page to Public summary and mobile-sections endpoints return old description for a specific page.Jun 18 2018, 6:46 PM
Mholloway updated the task description. (Show Details)
Mholloway updated the task description. (Show Details)Jun 18 2018, 7:36 PM

@Pchelolo According to https://github.com/wikimedia/change-propagation/blob/master/config.example.wikimedia.yaml#L548-L566 it looks like both summary and mobile-sections should be updated when the description changes. Is it not currently working?

bearND added a comment.EditedJun 18 2018, 8:10 PM

@Mholloway ran [[ https://es.wikipedia.org/wiki/Manuel_Belgrano?action=purge | ?action=purge ]] on the page, which updated the output for summary and mobile-sections for this page. If you still see the old values in the browser hit shift-refresh.

Ok, so the problem is that in order to minimize the load we try (in a very hacky way) to only rerender summary/mobile content if the description of the item changes. We check the edit comment to estimate that: https://github.com/wikimedia/change-propagation/blob/master/config.example.wikimedia.yaml#L530 The comment for the revert wasn't in the list of possible comments we react on.

This should fix it: https://github.com/wikimedia/change-propagation/pull/275

Pchelolo moved this task from Backlog to doing on the Services board.Jun 19 2018, 2:41 PM
Pchelolo edited projects, added Services (doing); removed Services.

Change 441054 had a related patch set uploaded (by Mobrovac; owner: Mobrovac):
[mediawiki/services/change-propagation/deploy@master] Bug fix: Add Reverted to WD description checks

https://gerrit.wikimedia.org/r/441054

Change 441054 merged by Mobrovac:
[mediawiki/services/change-propagation/deploy@master] Bug fix: Add restore to WD description checks

https://gerrit.wikimedia.org/r/441054

Mentioned in SAL (#wikimedia-operations) [2018-06-26T09:18:11Z] <mobrovac@deploy1001> Started deploy [changeprop/deploy@5d8eaf1]: Bug fix: Add restore to WD description checks - T197626

Mentioned in SAL (#wikimedia-operations) [2018-06-26T09:19:25Z] <mobrovac@deploy1001> Finished deploy [changeprop/deploy@5d8eaf1]: Bug fix: Add restore to WD description checks - T197626 (duration: 01m 14s)

mobrovac closed this task as Resolved.Jun 26 2018, 9:20 AM
mobrovac assigned this task to Pchelolo.
mobrovac triaged this task as Medium priority.
mobrovac edited projects, added Services (done); removed Patch-For-Review, Services (doing).
mobrovac added a subscriber: mobrovac.

Fix deployed, resolving.

Vvjjkkii renamed this task from Public summary and mobile-sections endpoints return old description for a specific page to ppaaaaaaaa.Jul 1 2018, 1:02 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii removed Pchelolo as the assignee of this task.
Vvjjkkii raised the priority of this task from Medium to High.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed subscribers: gerritbot, Aklapper.
mobrovac renamed this task from ppaaaaaaaa to Public summary and mobile-sections endpoints return old description for a specific page.Jul 1 2018, 11:37 AM
mobrovac closed this task as Resolved.
mobrovac assigned this task to Pchelolo.
mobrovac lowered the priority of this task from High to Medium.
mobrovac updated the task description. (Show Details)
mobrovac removed a subscriber: Pchelolo.