Page MenuHomePhabricator

BlueSpicePermissionManager: missing rights in $wgAvailableRights
Open, NormalPublic

Description

BlueSpicePermissionManager fails the MediaWiki core test AvailableRightsTest::testAvailableRights which should be an easy fix:

16:55:39 1) AvailableRightsTest::testAvailableRights
16:55:39 Additional user rights need to be added to $wgAvailableRights or via the "UserGetAllRights" hook. See the instructions at: https://www.mediawiki.org/wiki/Manual:User_rights#Adding_new_rights
16:55:39 Failed asserting that two arrays are equal.
16:55:39 --- Expected
16:55:39 +++ Actual
16:55:39 @@ @@
16:55:39  Array (
16:55:39 +    0 => 'create'
16:55:39 +    1 => 'passwordreset'
16:55:39 +    2 => 'renameuser'
16:55:39 +    3 => 'searchfiles'
16:55:39 +    4 => 'skipcaptcha'
16:55:39 +    5 => 'viewfiles'

Details

Related Gerrit Patches:

Event Timeline

hashar triaged this task as Normal priority.Jun 21 2018, 8:35 PM
hashar created this task.
Vvjjkkii renamed this task from BlueSpicePermissionManager: missing rights in $wgAvailableRights to 3haaaaaaaa.Jul 1 2018, 1:02 AM
Vvjjkkii raised the priority of this task from Normal to High.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
CommunityTechBot renamed this task from 3haaaaaaaa to BlueSpicePermissionManager: missing rights in $wgAvailableRights.Jul 2 2018, 11:12 AM
CommunityTechBot lowered the priority of this task from High to Normal.
CommunityTechBot updated the task description. (Show Details)
CommunityTechBot added a subscriber: Aklapper.

Change 452291 had a related patch set uploaded (by Pwirth; owner: Pwirth):
[mediawiki/extensions/BlueSpicePermissionManager@master] Add missing GroupPermission registration for right permissionmanager-viewspecialpage T197900

https://gerrit.wikimedia.org/r/452291

Change 452291 merged by jenkins-bot:
[mediawiki/extensions/BlueSpicePermissionManager@master] Add missing GroupPermission registration for right permissionmanager-viewspecialpage T197900

https://gerrit.wikimedia.org/r/452291

Pwirth closed this task as Resolved.Aug 13 2018, 12:05 PM
hashar reopened this task as Open.Aug 22 2018, 9:41 AM

I tried again on Change 446075 by commenting check experimental and the structure test still fails:

1) AvailableRightsTest::testAvailableRights
Additional user rights need to be added to $wgAvailableRights or via the "UserGetAllRights" hook. See the instructions at: https://www.mediawiki.org/wiki/Manual:User_rights#Adding_new_rights
Failed asserting that two arrays are equal.
--- Expected
+++ Actual
@@ @@
 Array (
+    0 => 'create'

/workspace/src/tests/phpunit/structure/AvailableRightsTest.php:53
/workspace/src/maintenance/doMaintenance.php:94

Change 455184 had a related patch set uploaded (by Hashar; owner: Hashar):
[integration/config@master] Mark BlueSpicePermissionManager as broken

https://gerrit.wikimedia.org/r/455184

Change 455184 merged by jenkins-bot:
[integration/config@master] Mark BlueSpicePermissionManager as broken

https://gerrit.wikimedia.org/r/455184

Pwirth added a subscriber: Pwirth.Aug 24 2018, 4:00 PM

@hashar This problem was initialy caused by adding any rights, that are registered in roles to the AvailableRights array in the BlueSpiceFoundation. This was fixed here: https://gerrit.wikimedia.org/r/#/c/mediawiki/extensions/BlueSpiceFoundation/+/450511/