Page MenuHomePhabricator

runJobs.php: PHP Fatal error
Closed, InvalidPublic

Description

Hey guys!

I just run the "php runJobs.php" at a MedaWiki 1.29.0, and it returned the following (for the first time):

PHP Deprecated: Comments starting with '#' are deprecated in /etc/php5/cli/php.ini on line 299 in Unknown on line
0
PHP Notice: unserialize(): Error at offset 52482 of 65535 bytes in /var/lib/mediawiki/includes/jobqueue/JobQueueDB
.php on line 807
PHP Fatal error: Unsupported operand types in /var/lib/mediawiki/extensions/CirrusSearch/includes/Job/ElasticaWrit
e.php on line 44

Can you tell me how to fix it? I don't know what's going on.

Thanks in advance!

Event Timeline

Mainframe98 changed the task status from Open to Stalled.Jun 22 2018, 5:54 AM
Mainframe98 added a project: CirrusSearch.
Mainframe98 added a subscriber: Mainframe98.

Hello, in order to help resolve this, we're missing one piece of information. We'll need to know which version of CirrusSearch you are running. This will allow us to find the version of the file mentioned in the error you reported.

The first deprecation error is not from MediaWiki itself; that one originates from PHP's configuration file, and is exactly what the message says. According to the php manual they should use semicolons instead.

Additionally, you're running an outdated version of MediaWiki. Chances are that this issue is resolved in a newer version of MediaWiki. Be aware that the recently released version of MediaWiki will require PHP 7, and it appears you are running version 5 currently.

@EAFM: MediaWiki 1.29.0 is an old unsupported insecure version. Hence I am going to close this task as invalid. Feel free to reopen if the problem still appears in a supported version and after following https://mediawiki.org/wiki/How_to_report_a_bug to provide clear steps to reproduce the problem.
For general support questions, see https://www.mediawiki.org/wiki/Project:Support_desk - thanks.

@Mainframe98 Hi there! Its running Elasticsearch 5.5.2 with CirrusSearch 0.2 .

@Aklapper Ok, I'll check it out.

Thank you guys, I'll consider to update it.

For reference: this might be a duplicate of T124196

Vvjjkkii renamed this task from runJobs.php: PHP Fatal error to mhaaaaaaaa.Jul 1 2018, 1:02 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii triaged this task as High priority.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
CommunityTechBot renamed this task from mhaaaaaaaa to runJobs.php: PHP Fatal error.Jul 2 2018, 11:03 AM
CommunityTechBot closed this task as Invalid.
CommunityTechBot raised the priority of this task from High to Needs Triage.
CommunityTechBot updated the task description. (Show Details)
CommunityTechBot added a subscriber: Aklapper.